• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 230
  • Last Modified:

Exchange 2003 ActiveSync doesn't want to work,

We have a new Windows 2003 SBS Server with Exchange 2003. Whenever one of our new Motorola MPX200 smartphones tries to connect to the exchange server to get ActiveSync info, I get :

Synchronization failed due to an error on the server. Try again.
Error code: HTTP_500

I have tried the solutions below, and nothing seems to work (see links at bottom). I have tried mucking around with the permissions in IIS myself to try and solve the problem, but I am afraid I have no idea what is actually required by ActiveSync for it to work. We are doing this on the local network (through "passthrough" mode), so it definitely is not a firewall issue. The user that I am trying to log in as can use OMA and OWA just fine. We are trying to get another "server ActiveSync" device in here to make sure it isn't a problem with the phones (although that error message makes me think it is a problem with IIS). This is really frustrating, anyone have any luck getting their SBS 2003 server to talk ActiveSync? What are your permissions/authentication types on all of your ActiveSync related folders in IIS? Any help would be appreciated!

http://www.cewindows.net/faqs/activesync/mis.htm

We did step 7 (we have a local certificate) on the phones.
We did step 17 as well, but after going through all of the Sharepoint related fixes it turns out Sharepoint is not "extending" the IIS server so you can't do the "exclude" procudere listed here (step 2), we did however set up Sharepoint to use Kerberos:

http://support.microsoft.com/?id=823265&FR=1

I turned off SSL on all of the IIS folders as well.

Spencer

Let me know if you guys need any more information.
0
evoluder
Asked:
evoluder
1 Solution
 
nisters10Commented:
I get the same error every now and again whilst using activesync to an MIS server (exchange 2000) - Normally a restart if IIS on the exchange fixs it. has it evre worked?
0
 
evoluderAuthor Commented:
Actually, I did a modified version of a KB article that had use recreate the virtual folder used by Exchange in IIS. However, instead of making a new folder without SSL as described in the KB article (which did NOT work), I exported the current Exchange virtual folder to XML, imported it as a new folder and then disabled SSL. So apparently the recreation described in the KB article is missing some piece of information (never could figure out what). This worked great. I can track down the KB article in question if anyone is interested.
0
 
moduloCommented:
PAQed, with points refunded (500)

modulo
Community Support Moderator
0
 
zookeepa1Commented:
evoluder:

thanks for posting this answer over a year ago....Your way still works.  Oh yeah here is the KB article you spoke of http://support.microsoft.com/default.aspx?kbid=817379   KB Article 817379
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now