• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 749
  • Last Modified:

"[Darren's] Documents" missing in "Files stored on this computer"

The shortcuts of users' document in "Files stored on this computer" group are missing, even the document folder of myself, when I open "my computer" window,  but the "Shared Document" is still there. It happened when I upgraded my Windows 2000 to Windows XP. How could I fix the problem and let every user's document accessible when I open "my computer" window?

I am an administrator of the computer, so it won't be due to lack of permission.
0
darrenlin
Asked:
darrenlin
  • 4
  • 3
  • 3
1 Solution
 
gemartiCommented:
Description of File Sharing and Permissions in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

SUMMARY
Windows XP enables you to share files and documents with other users on your computer and other users on a network. Windows XP introduces a new user interface (UI) in the Windows XP Home Editions and Windows XP Professional that is known as Simple File Sharing, and includes a new Shared Documents feature.

This article describes the new interfaces that are introduced in Windows XP and how to enable, disable, configure, and troubleshoot file sharing in Windows XP.

Note Windows XP Home Edition-based computers always have Simple File Sharing enabled.
0
 
sramesh2kCommented:
This one is an interesting problem! IIRC, i could not fix this issue when I came across this question earlier. The following solution works for few users.

Open Registry Editor and goto:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DocFolderPaths

In the right-pane, see if all the user accounts are listed and correct paths for their 'my documents' folder are listed. If not, you may need to add the entries.

In my case:
New String Value [Ramesh] and set the path as "C:\Documents and Settings\Ramesh\My Documents"

If this does not help, change your user account type to Administrator. [if not already]
0
 
sramesh2kCommented:
This one is an interesting problem! IIRC, i could not fix this issue when I came across this question earlier. The following solution works for few users.

Open Registry Editor and goto:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DocFolderPaths

In the right-pane, see if all the user accounts are listed and correct paths for their 'my documents' folder are listed. If not, you may need to add the entries.

In my case:
New String Value [Ramesh] and set the path as "C:\Documents and Settings\Ramesh\My Documents"
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
darrenlinAuthor Commented:
I checked the registry, only to find my name and others' are listed correctly. And I am sure that the security/permission settings are correct since I am able to access "My Documents" folder by various ways like Start Menu except the group "Files stored on this computer" in "my counputer" window.
0
 
gemartiCommented:
You didn't join a domain did you?  If you are connected to a network domain, the Shared Documents, Shared Pictures, and Shared Music folders are not available.
0
 
gemartiCommented:
>>I am able to access "My Documents" folder by various ways like Start Menu except the group "Files stored on this computer" in "my counputer" window

Are you saying that when you try to access this folder you can't?
Or are you saying it isn't there?

0
 
darrenlinAuthor Commented:
> You didn't join a domain did you?
Nope, I joined a workgroup.

> Are you saying that when you try to access this folder you can't?
> Or are you saying it isn't there?

Sorry, I think I made you confused.
I mean, I can access files in my document by clicking "My Document" in Start Menu, or just typing "C:\Documents and Settings\Darren\My Documents." in Windows Explorer. However, when I open "My Computer" window, in the "Files stored on this computer" group, I find no "Darren's Documents, " (Darren refering to myself) or others', but the shortcut of "Shared Documents" is still there.

In brief, the folders are there, and I can access them, but most of the links in "Files stored on this computer" are missing.
0
 
darrenlinAuthor Commented:
Thanks everyone that gives advices. I fixed the problem by a recent Windows Update.
0
 
sramesh2kCommented:
Great! Darren. If you know the hotfix#, please feel free to post here.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now