how do I enable autorun for camera wizard on insertion of flash card into card reader

I have had recurrent problems with getting the MS XP camera wizard to open when I insert a flash memory card into the card reader.

I have read all the posts on this topic here and none seem to help me!

I'd like to know how to edit the registry to enable or disable autorun feature for specific drives (I think this is where my problem lies).

I have enabled the autorun feature to run the camera wizard through the MY Computer for the removable media drives corresponding to the card reader but it didn't work.  I've tried uninstalling the drives through the device manager and they re-appear after startup and the problem persists.

RH
RichardHeldAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

timothyfryerCommented:
Is the Windows Image Acquisition service enabled and set to manual or automatic, also possibly plug and play service and universal plug and play service.  
gemartiCommented:
The registry location for AutoPlay Handlers.

START | RUN | REGEDIT
Navigate to:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\EventHandlers


You should see a couple of keys:
ShowPicturesOnArrival
VideoCameraArrival
gemartiCommented:
This is how it should look:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\EventHandlers\ShowPicturesOnArrival]
"MSWiaEventHandler"=""
"MSShowPicturesOnArrival"=""
"MSPrintPicturesOnArrival"=""
"MSOpenFolder"=""
"WebshotsShowPictures"=""
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

gemartiCommented:
Notice that the data are all empty REG_SZ values.
gemartiCommented:
Make sure that you don't have a key in the registry that is preventing the autorun.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

If you see a value: NoDriveTypeAutoRun REG_DWORD 0x20 for your camera then that is where the problem lies.
gemartiCommented:
I forgot about this one:

The AutoRun or AutoPlay Feature Does Not Work
http://support.microsoft.com/default.aspx?scid=kb;en-us;330135

SYMPTOMS
When you insert a CD-ROM into your CD-ROM drive, the AutoPlay or AutoRun feature may not work and may be unavailable. However, your CD-ROM drive may work correctly in every other way.

The information in this article applies to:
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition
RichardHeldAuthor Commented:
Hi,

Well, I read the replies and gemarti, I found that I have  NoDriveTypeAutoRun REG_DWORD  in my registry under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

the value is 0x00000091 (145)

What am I supposed to do to fix this problem? do I delete the Key or do I change the value to zero or something else?

The other Registry area you advised me about checked out to have all the same keys except for the webshots, and I have an adobe key in there that you hadn't listed.  The remainder was the same as you indicated.


timothyfryerCommented:
Also Shell Hardware Detection in services.
gemartiCommented:
>>What am I supposed to do to fix this problem? do I delete the Key or do I change the value to zero or something else?

Check this location in gpedit

START | RUN | GPEDIT.MSC
Navigate to:
Local Computer Policy | Computer Configuration | Administrative Templates | System

If "Turn off Autoplay" is enabled then set it to "Not Configured"

If it is already set to "Not Configured" then reopen the registry:
START | RUN | REGEDIT
Navigate to:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Click on this key so that it is highlighted.

Click FILE | Export
Save the file with a recognizable name like: NoAutoplay.reg
After you save the registry key delete the NoDriveTypeAutoRun value and its data

Reboot your machine.

If that doesn't resolve the problem you can put the value and data you deleted back by double cliking on the NoAutoPlay.reg file.

Note: Editing the registry can potentially damage your system. Make sure you have a backup before editing any key.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RichardHeldAuthor Commented:
thank you gemarti,  that seeemed to do the trick
gemartiCommented:
:)
Thank you.
taraibizaCommented:
Hi there,

Gemarti, I have followed this up until a certain point, I can't seem to run GPEDIT.MSC What am I doing wrong?  I have the exact same problem as RichardHeld and was hoping to resolve mine too.  Any ideas?  Anyone.......?
gemartiCommented:
Log on with an administrator's account. If your running XP Home try running SECPOL.MSC
taraibizaCommented:
Hi, Thanks for the quick response!  Unfortunately that doesn't seem to work either. Yes I am using XP home, and this is getting really frustrating as my card reader was fine until a few weeks ago, and now I am trawling the net in search of a solution! Do you suggest anything else?
n3vmtCommented:
the answer to fix my problem, but it worked. Eaither installing MS Windows XP Service Pack 2 or MS Media Player 10 caused this problem for me. Connecting my Sony DSC-V1 used to cause the MS camera wizard to pop up and picture transfer was easy but after the above mentioned 'upgrades' the camera only showed up as a removable media storage device (drive) and the wizard wouldn't work anymore. I found that for many people, uninstalling Real Player fixed their problem, but if you have tried that or don't have Real Player installed, download and run this file from Microsoft's website. It checks out all the autorun settings and fixes any that may not be properly configuered for autorun to work. (Also make sure you've tried configuering the autorun to actually perform the action you want in the device properties first).

[link name=http://www.microsoft.com/downloads/details.aspx?FamilyID=c680a7b6-e8fa-45c4-a171-1b389cfacdad&DisplayLang=en][/link]

If the link changes, just go to microsoft's drivers download page and in the search box type 'autoplay' which should lead you to a file called AutoFix.exe DL this file and run it following the instructions. Magic!

Yes, I'm in shock Microsoft actually did something right even though it was to fix something they did wrong. Anyway, good luck! If this helped you please let me know! I'd like to think 6 hours of time did more good than to just myself.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.