Do I have to use NWLink on XP workstations?

I have a 2 machine peer to peer network running one XP Home and one XP Pro.  I was unable to browse the network via My Network Places or the command line until I installed NWLink.  Why must I use NWLink for the computers to see each other?
Who is Participating?
stevenlewisConnect With a Mentor Commented:
>>I could not browse the network
sounds like a master browser issue
Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.

1 - On the master computer, set KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\MaintainServerList

to "YES". Set this key to "NO" on the other computers. Note that any computer using

the default setting "AUTO", which is later connected to the network will not be able

to browse until the key has been set to "NO" on that machine.

and on the pro machine
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled
You shouldn't, if  you enable NEtBIOS over tcp
Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.
vishal01Author Commented:
I tried that before installing the NWLink.  I use the ICF in XP along with a router for security.  I thought that the ICF was blocking the networking ports, so I opened 135-139 TCP + UDP and 445 TCP + UDP.  Still, without the NWLink protocol, I could not browse the network.  I dont mind using the NWLink as long as there are no security threats involved considering that I am using a Linksys WRT54G router (with SPI) as well as the XP firewall on each there anything else I can try or just leave good enough alone by using the NWLink?
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

NW is typically for NetWare...  It is not a "standard" protocol like a TCP/IP, but is based on a more proprietary protocol called IPX/SPX.  What that means is that the standard TCP/IP filters and rules would not apply to the NWLink, as far as I can understand.

You shouldn't have to mess with the ICF if they are both under the local area network.  Just follow Steven's instruction.

The one last thing you should check is whether or not the "Computer Browser" services is turned on.  If not, you might want to do so and wait for about 15 minutes, then see if you can browse your network neighborhood.

P.S.  You might suffer a little performance issue with the NWLink, but with 2 computer it is ok.  Do keep in mind that it is not a common protocol based on TCP/IP, so the practical use for you in your environment might not be great.  The more computer running with NWLink in your network, the more performance degradation you might suffer.

- Info
vishal01Author Commented:
Steven, Thank you - I will try this when I'm in front of the pc's and then accept your answer if it works.  I have tried just about everything else except this.  If not, Ill post another update.....
vishal01Author Commented:
Thank you....I know that the computer browser service is turned on; however, I have not set one of the computers's reg keys to master 'yes' and the others to 'no' as Steven pointed out.  I hope that will do it.  Thanks for everyone's help so far!
keep us informed :-)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.