Solved

Frontpage Extensions Forms : Cannot run the FrontPage Server Extensions on this page: "page.html"

Posted on 2004-04-04
46
13,980 Views
Last Modified: 2013-12-24
Hi,

I have frontpage server extensions working on my laptop with win xp and iis5.  i have frontpage 2002

when i create a new web in frontpage using one of the templates (e.g. personal) then it works fine, i can publish the web and enter information in the feedback form and it processes correctly.  this indicates that the server extensions are setup correctly and are working.

however, i am working on a site that i have copied from another web server.  i basically copied the entire folder and pasted it into my wwwroot folder.  the site/folder name is mySite.  so i have d:\inetpub\wwwroot\mySite\

i then added the virtual directory in iis to point to this folder and named it mySite also.

finally, i configured fp server extensions on this folder.

however, when i go to one of the feedback forms on the mySite site, fill in some information and click submit.. i get the following error:

Cannot run the FrontPage Server Extensions on this page: "http://localhost/mySite/Help.html"

i have read the kb article #156842 and checked that it is pointing to a valid _private folder... it seems to be - it points to the d:\inetpub\wwwroot\_private folder (which does exist)

i also tried changing it to point to the d:\inetpub\wwwroot\mySite\_private folder and that doesnt work either.

please help!

thanks.
0
Comment
Question by:sdlangers
  • 20
  • 13
  • 7
  • +1
46 Comments
 

Author Comment

by:sdlangers
ID: 10761293
great - thanks!  hopefully - this is the longest time without a response on this site yet!

also, im not sure if you can help with this - i had another question that i actually found the solution myself.. how can i take the points back for that one?
0
 
LVL 12

Expert Comment

by:rcmb
ID: 10761564
Excerpt from KB Article Q320872

Cause
This problem occurs if you create a page in FrontPage by using the Feedback Form template and then save the page to a subfolder instead of saving it to the root folder of the Web site. When a client submits the form, the FrontPage Save Results component tries to save the results to the wrong location. For example, if you saved the feedback page to a subfolder named Test, the Save Results component tries to save the results to the Test/_private folder, which does not exist.



Resolution
To resolve this problem, follow these steps:

Open your Web in FrontPage.


In the folder list, expand the _private folder that is in the root of your Web site.


Locate the Feedback.txt file. If you cannot locate this file, follow these steps:


On the File menu, click New, and then click Page or Web.

The task pane opens.


Under New from template, click Page Templates.


On the General tab, click Normal Page, and then click OK.


Switch to HTML view, and then delete all the HTML code.


On the File menu, click Save.


Locate and then double-click the _private folder that is in the root of your Web.


In the Save as type box, click All Files (*.*).


In the File name box, type Feedback.txt.


Click Save.


Open the page that contains the feedback form.


Right-click the form, and then click Form Properties.

Note that the File name field shows that the results will be saved to the relative path of _private/Feedback.txt, which does not exist. (For example, if you saved the feedback page to a subfolder named Test in the root of your Web site, this path is /Test/_private/Feedback.txt.)


Click Browse.


Locate and then double-click the _private folder that is in the root of your Web.


Click the Feedback.txt file, and then click OK.


Save the form page.





More Information
By default, the Save Results component in the Feedback Form template saves the results to a text file named _private/Feedback.txt in the root of your Web. By default, if you save the feedback page to a subfolder, the Save Results component points to a _private folder relative to the subfolder--a _private folder that does not exist--instead of to the _private folder in the root of your Web.
0
 

Author Comment

by:sdlangers
ID: 10761598
thanks, but thats not it - infact thats the same solution as on the kb article number i listed above.  as i said above, i checked the paths and all and they are correct as per that article.

this site was workign on a server - but when the site was copied to a new server it stopped working.

i also made a new fresh simple website and it works fine - so looks like the fp extensions are installed correctly.

any other ideas?
0
 
LVL 12

Expert Comment

by:rcmb
ID: 10761705
One thing of concern is - did the site you copied have fp server extensions already? I know you said "finally, i configured fp server extensions on this folder" but what I recommend is to import the folder into the existing web vice just doing a straight copy. This ensures server extensions are properly configured for all directories and also verifies the paths of all hidden folders.

RCMB
0
 

Author Comment

by:sdlangers
ID: 10761732
ok - the new computer was freshly installed... so there were no fp extensions.  so i copied over the root folder of the site onto the new computer, created the virtual directory in iis and then installed fp extensions and configured them for that new site.  is this correct?

thanks for the help!
0
 
LVL 12

Expert Comment

by:rcmb
ID: 10762157
Okay, I tried everything you did and so far I am having the same results you are. The way I resolved was to go to tools, server, permissions and reset the premissions settings to have the same permissions as the parent web. This was a tough one and really threw me. I created four virtual directories and everyone gave the same error you were seeing.

RCMB
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10762194
>the new computer was freshly installed... so there were no fp extensions.  so i copied over the root folder of the site onto the new computer, created the virtual directory in iis and then installed fp extensions and configured them for that new site.  is this correct?

Your local machine does not need the extensions - only the server.  Did you ask the hosting company to re-install the FP extensions.  This is usually the biggest problem with the FP extensions / forms.

-Corey
0
 
LVL 12

Expert Comment

by:rcmb
ID: 10762203
Corey

From what I understood he was running his machine as the server ("I have frontpage server extensions working on my laptop with win xp and iis5.  i have frontpage 2002") and there was no hosting company involved. Is this correct sdlangers?

RCMB
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10762213
Sorry - I did not see that.  Is this Pro (I hope)?  If it was a fresh install, did you get the security patch for FP extensions & make sure that everything else was patched / up to date?

And even though you did install the FP extensions, did you apply them to the web?

-Corey
0
 

Author Comment

by:sdlangers
ID: 10762236
people !  you're all missing the point.. please read my first post.

yes, im running off my own machine xp pro iis5 w/front page server extensions installed.

i know fpse are installed, cos i did a quick test site using one of the ms frontpage templates and used their feedback form template and it worked great.

also - the machine that i am copying the real website from DOES work.  i.e. the site works - the forms get submitted correctly and the results are saved to a text file correctly.

where it all goes wrong is when i try copy over the site from the server that works onto my machine.  when i do that - the site comes up, but the error message appears whenever you try submitting a form

hope this explains it better

someone please help !!
0
 

Author Comment

by:sdlangers
ID: 10762242
rcmb - sorry i missed your suggestion about the parent permissions - will try that now.. hang on
0
 
LVL 29

Assisted Solution

by:coreybryant
coreybryant earned 200 total points
ID: 10762255
Try to publish instead of copy.  

What's the URL of the message you completed yourself?  You can request a refund in the Customer support forum

-Corey
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10762258
Also can you create a test form on the local machine to see if it works?

-Corey
0
 

Author Comment

by:sdlangers
ID: 10762278
rcmb - i tried that and it doesnt work - it seems to have the same permissions as the parent web.  is there any way i can check this manually in IIS ?

corey - thanks for the tip on the message i fixed myself - here is the url:

http://www.experts-exchange.com/Databases/Q_20922644.html

also, please please read what i wrote above carefully - yes, i did create a test form and it worked - i've mentioned this three times now !

rcmb - it sounds like you're close on the permissions thing.. wonder why mine isnt working still ?
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10762340
Sorry sdlangers - I am just going thru the comments one by one & pointing out a few problems:
>ok - the new computer was freshly installed... so there were no fp extensions.  so i copied over the root folder of the site onto the new computer, created the virtual directory in iis and then installed fp extensions and configured them for that new site.  is this correct?

As rcmb pointed out you should not copy.  The above is not correct.  You should publish the website to your computer. You should apply the extensions before publishing.  FP extensions are the pickiest thing

What's the code of the form tag?

-Corey
0
 

Author Comment

by:sdlangers
ID: 10762367
no problem corey -just trying to keep my frustrations confined to frontpage!

how can i publish the web when im bringing it from another server?

just to recap - it works on ServerA (including fpse and everything)

i need to copy that website onto my pc - so i copied the folder to my wwwroot and installed the fpse  and it doesnt work.

i dont normally use fp, so how would i copy it over by publishing it?

thanks.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10762378
No worries - FP can be a hassle at times.  

Open up the web on the server - File - Open web - http://www.yourdomain.com/ & then go to file publish & choose the folder on your local machine.

(just the reverse process)  :)

-Corey
0
 
LVL 12

Expert Comment

by:rcmb
ID: 10762383
What version of FP server ext are you running? I am running FRSE 2002. When I went to the web interface to reset my permissions I just accepted the default and everything worked fine. You could go in manually to the directory and give everyone full control just to try it out.

RCMB
0
 

Author Comment

by:sdlangers
ID: 10762419
corey - i tried that and it doesnt work either - heres the steps i took:

1. copied the files to a different location
2. deleted my web directory in the wwwroot
3. deleted my virtual directory in IIS (so its the same as it was before i started copying anything)
4. opened frontpage
5. chose open web - pointed to the copy of the files
6. went to publish to http://localhost/MySite/

got this error message:

The page cannot be displayed
             The page cannot be displayed     The page you are looking for cannot be displayed because the page address is incorrect.       Please try the following:  If you typed the page address in the Address bar, check that it is entered correctly.  Open the  home page and then look for links to the information you want.  HTTP 405 - Resource not allowed Internet Information Services  Technical Information (for support personnel)  More information: Microsoft Support        

rcmb - thats exactly what i did - tried to reset it with the defaults and still no luck - im using 2002 also

looks like its a permissions problem alright.. any other ideas?
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10762500
You can't publish to http://localhost/MySite/ - as soon as you enter http - you are telling FP or your browser to go out into the internet.  Try to use the browse button & locate your FP web on your local machine.

-Corey
0
 

Author Comment

by:sdlangers
ID: 10762530
ok - now im confused.. how do i point it to my webserver without using http?  if i click browse.. i only get my network places.. and it seems like it wants me to pick a place that already exists..when i try browse to d:\inetpub\wwwroot it gives me the error message:

the folder is contained by a server-based web.  to access this web you must use the http:// url for the web server.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10762549
You should be able to browse your computer - it should have My Computer on the left & you should be able to go to that website you created.  

-Corey
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 31

Expert Comment

by:seanpowell
ID: 10762570
Just curious - when you open IIS, right click on the "MySite" Folder, and go to All Tasks > Check Server Extensions, what happens? You said you verified the extensions, but I just need to know you verified them this way.
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 10762596
Also, when you open localhost in FP, and then look at the MySite folder, which one does it look like?

http://www.pdgmedia.com/ee/fp_check.gif
0
 

Author Comment

by:sdlangers
ID: 10763063
sean,

it has the web icon.  i also did the check server extensions and no problems found.

is this right?
0
 

Author Comment

by:sdlangers
ID: 10763101
ok - now for some reason (after trying to recalculate and checking the extensions) on the form page, it shows:

[Frontpage save results component]

which indicates that the extensions are not setup correctly again.

is there anyway to completely remove the extensions and do it all again from scratch the right way?

thanks,
0
 
LVL 31

Accepted Solution

by:
seanpowell earned 300 total points
ID: 10763672
It may indicate that - it may also be a good sign, as it can be a better message than the one you had before.
It definitely means that the extensions were indeed the issue with the site.

Can you do these things for me and let me know at which point you either cannot duplicate the instructions, or you get the [Frontpage save results component] error?

1.   Open the MySite Web in FP.
2.   Create a new blank page, and insert a form with a single text box.
3.   Right click on the text box, go to Form Field Properties and call it "Name"
4.   Right click in the form and go to Form Properties.
5.   In the send to File Name field you should see this:
      http://localhost/MySite/_private/form_results.txt
6.   Save the page as myform.html
7.   Click on the html tab. You should see something very similar to this:
      <form method="POST" action="--WEBBOT-SELF--">
      <!--webbot bot="SaveResults" U-File="_private/form_results.txt" S-Format="TEXT/CSV" S-Label-Fields="TRUE" -->
      <p><input type="text" name="Name" size="20"><input type="submit" value="Submit" name="B1"><input type="reset" value="Reset" name="B2"></p>
      </form>
8.   Now go to File > Preview in Browser to view the page
9.   The url should be something like:
      http://localhost/MySite/myform.html
      If there's a problem, you will likely get the error message here. Failing that...
10.  View the source of the page. You should see something very similar to:
      <form method="POST" action="_vti_bin/shtml.dll/myform.html" webbot-action="--WEBBOT-SELF--">
      <!--webbot bot="SaveResults" U-File="_private/form_results.txt" S-Format="TEXT/CSV" S-Label-Fields="TRUE" startspan -->
      <input TYPE="hidden" NAME="VTI-GROUP" VALUE="0">
      <!--webbot bot="SaveResults" endspan i-checksum="43374" -->
      <p><input type="text" name="Name" size="20"><input type="submit" value="Submit" name="B1"><input type="reset" value="Reset" name="B2"></p>
      </form>
11.  Enter text in the box and hit submit.
12. Assuming everything went well, the URL should now read:
      http://localhost/MySite/_vti_bin/shtml.dll/new_page_1.htm

Let us know what happens :-)
Sean
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 10763710
Also, when you right click on MySite in IIS and select properties, which dialog box do you see, and are they exactly the same?

http://www.pdgmedia.com/ee/screen1.gif
or
http://www.pdgmedia.com/ee/screen2.gif

Sorry - just troubleshooting... I find it easier with graphics.
0
 

Author Comment

by:sdlangers
ID: 10767635
thanks sean - ill try that later (im at work now)  i appreciate your help
0
 

Author Comment

by:sdlangers
ID: 10769744
sean,

should i install the server extensions on the server before doing the steps listed above?  to start over, i have completely removed the extensions.

so i was planning to first, install them, then follow your steps above.. correct?
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 10770004
Well the steps above were assuming the extensions were there, I just wanted to find out at which point they were broken...

So yes, go and install first, and I'll have a Scotch and keep my fingers crossed...
0
 

Author Comment

by:sdlangers
ID: 10779503
Hi Sean,

hope you're still available.  Ok, to try and sort out the mess - here are the steps i took:

1. i removed fpse from the server (note - im now using the real server where this site is eventually meant to go - i was going to put a copy on my laptop first, to test, but i dont want to mess with that anymore - one less headache!  so this server has win2000 server, iis5)

2. i right clicked on the webserver name and selected configure FPSE.

3. this finished ok, so i installed FP on the server and created a blank new web called http://localhost/testFPSE

4. when it tried to create the web, i got the following error message:

Server error: the folder "/testFPSE" is marked executable - you are not allowed to put files into an executable folder on this server.

any idea how to fix this?

basically, i want to try and get a separate page up and working as per your steps above.

thanks.
0
 

Author Comment

by:sdlangers
ID: 10779605
never mind - i found the fix for that part - back to your steps now  !  ill report back in  a bit
0
 

Author Comment

by:sdlangers
ID: 10779680
sean,

ok - i've tracked it down a little bit:

when i followed your steps above, it worked when i made the form save the file to the _private/ folder

however, when i change it so it saves to the ../_private/ folder (i.e. one level up) it doesnt work.  this is the folder i need to save it to.

is this possible?  it should be, since on the original server, this is how it works.

i think i'm nearly there

thanks for all the help.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10779728
You said your contact was in http://localhost/mySite/Help.html - now if you are moving one level up that would seem to try to take it to http://localhost/_private ?  And I do not think that you can access that folder because it is not in the www folder that is accessible on the web.  It should be something like: http://localhost/mySite/_private - one level down.  I do not think that FP has access to a folder that is not in the www folder.  And your FP web is http://localhost/mySite/ - not http://localhost/

-Corey
0
 

Author Comment

by:sdlangers
ID: 10779748
corey,

you are right - that is the way im trying to do it.  for now, im working off a blank new website with only one page.

so basicaly i have:

http://localhost/testFPSE/test.html

when i set that to save to _private/results.txt  i.e. c:\inetpub\wwwroot\testFPSE\_private\results.txt - then it works fine

but when i set it to save to ../_private/results.txt i.e. C:\inetpub\wwwroot\_private\results.txt - then it doesnt work

however, i know this can be done, since this is the way it works on the old server (the one im copying it from) and it works fine there

i must be just missing some permissions setting

0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10779778
So on the web that is one the server right now, when you open it via FP: File - open Web - http://www.yourdomain.com - you do not see the _private folder there correct?  And you do not see the _private/results.txt file there correct?  

-Corey
0
 

Author Comment

by:sdlangers
ID: 10780000
no,

on the one that doesnt work - i.e. when i point the form to save to ../_private/results.txt

when i publish it and go to the page, it shows the error message : [Frontpage save results component] , meaning the server extensions didnt work on the page.

however, when i change it to point the form to save to the _private/results.txt - it works fine and when i do a submit the results are saved correctly.

does this explain it?
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10780060
Sean might know but I was always under the impression that FP extensions were installed on the web & that was it, meaning c:\inetpub\wwwroot\testFPSE\ and then your results would go to c:\inetpub\wwwroot\testFPSE\_private\results.txt - but you are not putting the results on the web (the testFPSE).  

So right now you have / want to have:
c:\inetpub\wwwroot\testFPSE
c:\inetpub\wwwroot\_private

Does the c:\inetpub\wwwroot\_private folder marked for anonymous users?  When you create the form & right click on the form - does it allow you to browse to c:\inetpub\wwwroot\_private ?  

-Corey
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10780075
I am assuming no, because I cannot view other folders.  But you are changing part of the FP form script.  I wonder if the _vti_cnf is being changed as well?  This file contains information that FP uses so that it knows how to handle the form.

I just created a test form & then looked @ the file in the _vti_cnf folder that corresponds to that file.  It contained:

vti_encoding:SR|utf8-nl
vti_author:SR|BRYANT01\\Administrator
vti_modifiedby:SR|BRYANT01\\Administrator
vti_timelastmodified:TR|08 Apr 2004 01:19:07 -0000
vti_timecreated:TR|08 Apr 2004 01:19:07 -0000
vti_cacheddtm:TX|08 Apr 2004 01:19:08 -0000
vti_filesize:IR|731
vti_cachedtitle:SR|New Page 1
vti_cachedbodystyle:SR|<body>
vti_cachedlinkinfo:VX|A|_derived/nortbots.htm B|_private/form_results.csv W|_private/form_results.csv
vti_cachedsvcrellinks:VX|FAUS|_derived/nortbots.htm FBUS|_private/form_results.csv
vti_cachedneedsrewrite:BR|true
vti_cachedhasbots:BR|true
vti_cachedhastheme:BR|false
vti_cachedhasborder:BR|false
vti_error0:SX|This page contains a FrontPage Save Results component that will not function properly until you publish your FrontPage Web to a server.
vti_error:IX|1
vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1252
vti_charset:SR|windows-1252
vti_hasruntimebots:BR|true
vti_title:SR|New Page 1
vti_extenderversion:SR|6.0.2.5516
vti_backlinkinfo:VX|

Create a form that goes to _private/results.txt.  And then create one that you want it to go to the folder / file not on the WWW.  Compare the _vti_cnf files.

-Corey
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10780084
Or copy the _vti_cnf folder that is in the c:\inetpub\wwwroot\testFPSE to the c:\inetpub\wwwroot\ folder.  Maybe that will work.  On the server now that it does work - I am assuming you FTP into the site to get the results.txt file?

-Corey
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 10785098
Hmmm - this is a fun one :-)

To recap a wee bit from your comment above:

============
so basicaly i have:
http://localhost/testFPSE/test.html

when i set that to save to _private/results.txt  i.e. c:\inetpub\wwwroot\testFPSE\_private\results.txt - then it works fine
but when i set it to save to ../_private/results.txt i.e. C:\inetpub\wwwroot\_private\results.txt - then it doesnt work
however, i know this can be done, since this is the way it works on the old server (the one im copying it from) and it works fine there
==============

testFPSE is a subweb of localhost, so the _private folder must be in that web. There's no way (that I know of) to access the _private folder under wwwroot from a subweb of wwwroot.

Are you absolutely 100% no questions asked positively sure that it works that way on the other site?

0
 

Author Comment

by:sdlangers
ID: 10785345
Sean, Corey,

thank you both for your help.

I've settled on changing all the forms to point to the _private folder rather than the ../_private folder.

For the record, yes, i'm positively sure that it works on the other server using ../_private folder - i know this, because i now have to go and change all the forms to point to the _private folder.

Anyways,  to recap - i think i spent all this time doing a huge circle when all along, the main problem was that it was trying to save to ../private and thats still not working.

so to fix it - i basically only reinstalled the FPSE and deleted the webfolder and re-published the site and it worked to the _private folder.

i think a split of the points is fair.
sean - i think your points were of more help, but corey - thanks for all yer effor - i'll split them 300/200
0
 

Author Comment

by:sdlangers
ID: 10785380
thanks a lot guys

if you ever come across the fix for using the wwwroot/_private folder, please think of me ! :)

thanks again
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 10785415
We will :-)

The reason I was asking is that the folder on the other web may have just been a folder - and not an actual subweb - which is why it worked.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Tomcat Ports in Xampp 8 119
WEB Service vs ??? 7 102
Intranet building Software 8 72
Add server behaviors to Dreamweaver CC 2015 2 91
When deciding to adopt any help desk solutions many factors should be explored before taking decisions. This will change from business to another but in general there are some kind of rule of thumb. Here are some quick tips: Do we need only ticket…
When setting up new project requests for our site, one of the most powerful tools our team has available to use is Axure (http://www.axure.com/). It’s a tool for creating software and web prototypes that can function and interact as if it were the a…
The purpose of this video is to demonstrate how to connect a WordPress website to Google Analytics. This will be demonstrated using a Windows 8 PC Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php :…
The purpose of this video is to demonstrate how to set up the permalinks on a WordPress Website. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Go t…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now