Cisco VPN won't connect over wireless but will if wired (Same router)

Hi,

I am trying to connect my Win XP machine to a Cisco VPN using VPN client ver 4.0.1 (rel) through my Linksys "EtherFast®
Wireless Access Point + Cable/DSL Router with 4-Port Switch".

When I connect to the router using an ethernet cable and the Local Area Connection (Intel Pro/100 NIC) it works just fine. However, if I connect wirelessly to the same router (Wireless Network Connection) it won't connect. When I click on 'connect' the login screen appears for a second and then closes immediately. The VPN client records this message in the log: "04/05/04  Sev=Warning/2      IKE/0xE3000099
Immature Navigation Termination due to error (Navigator:198)"

This occurs whether or not I am using WEP.

What kind of settings on the router would be different for wired connections than for wireless?
Could it have to do with XP's network connections?

I hope I've provided enough info. Thanks in advance to anyone with some ideas!
natGAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
rolltide_bamaConnect With a Mentor Commented:
i cannot remember what linksys version it was, but if you disable IPsec passthrough the client actually worked, it was really weird.. Or just flash the latest and you should be good to go.
0
 
lrmooreConnect With a Mentor Commented:
Been there, done that. My setup was:
Win2kPro
Linksys BEFW11S4 (version 1)
Cisco VPN 3.6x client

Worked perfectly wired, not at all wireless. Termination end log said 'malformed packet'
Using a Cisco 350 WAP on the same net, disabling the radio on the linksys, worked just fine

Opened a Bug case with Cisco TAC to try to get Cisco (which later bought Linksys) to work with them and figure out what was happening.
Linksys posted a firmware "fix" which was actually a down-rev from what I was using.

Upgraded Win2K to XP and all problems disappeared.
Now I use same router (first generation, ver 1.42z), XP, VPN client 4.03F and never have a problem.

I'm like you, I blame the router. Just try getting anyone at Linksys support to help. Suggest getting the latest firmware for your router..



0
 
natGAuthor Commented:
Alright, wll at least it looks like there's no user error on my part.

Thanks for the quick response. I'll check it out and post back..


NG
0
 
natGAuthor Commented:
Hey, bama, that worked! Of all the crazy things I tried, I never thought to try disabling the one thing I thought I needed most. Really weird indeed.

Anyway I'm giving some points to lrmoore for the speedy and comprehensive response- I will download the latest firmware and that should (hopefully) also solve the problem if I need to enable IPsec passthru again.

Thanks to both. Message boards are the greatest. I've never had a problem that couldn't be solved by someone out in the community. Cheers.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.