• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 825
  • Last Modified:

Suse 9.0, Nvidia Ti4600, Athlon 2000+, Gigabyte BoardComercial Drivers--Help Applying Comercial drivers

Hello,

Everything Is Running perfectly...Except for 3-d within Suse...

Within the Standard install, i use the Suse drivers provided, but there isn't an 3-d capabilities.Within Sax, i tried to toggle on 3-d support, and it mentioned i needed the comercial drivers to accomplish this. I did alittle research, and got the instructions...They were as followed:

1) Kernel sources must be installed and configured. Usually this means
installing the 'kernel-source' package with YaST2. Update it - if not
already done - via YaST2 Online Update (YOU).--->>>Not sure about this one...Even though it appears to be done...

2) Use the nvidia installer for 1.0-5336.

 sh NVIDIA-Linux-x86-1.0-5336-pkg1.run

3) Configure XFree86 with

 sax2 -m 0=nvidia (0 is a digit, not a letter!)

NOTE: There is no need to try to enable 3D support. It's already
      enabled, when the nvidia driver is running. Ignore the
      misleading error message, that 3D support can't be enabled.
      This problem will be fixed with SuSE > 9.0 and is related to the
      latest nvidia driver release.



I am trying to apply the Comercial Drivers and i Sh <driver name> and i get this(which i can't get past):

"No precompiled kernel interface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from the NVIDIA ftp site (ftp://download.nvidia.com)?
_______ ________
| yes | | no |
------------ --------------
>i clicked yes

"No matching precompiled kernel interface was found on the NVIDIA ftp site; this means that the installer will need to compile a kernel interface for your kernel.
_________
| OK |
----------------
>i clicked ok

" ERROR: Unable to find the kernel source tree for the currently running kernel. Please make sure you have installed the kernel source files for your kernel; on Red Hat Linux systems, for example, be sure you have the 'kernel-source' rpm installed. If you know the correct kernel source file are installed you may specify the kernel source path with the '--kernel-source-path' commandline option.


Any idea's??? An explanation would be great so i can understand whats going on.....

Also, what is SH ??



0
Johnysteaks
Asked:
Johnysteaks
  • 3
  • 3
  • 2
1 Solution
 
owensleftfootCommented:
" Update it - if not
already done - via YaST2 Online Update" may be your problem. You may have updated the kernel source but not your kernel. Therefore the kernel you are running doesnt match the  kernel source. leading to " ERROR: Unable to find the kernel source tree for the currently running kernel"

sh is the linux shell or command interpreter - sort of like command.com in dos (maybe you're too young to remember command.com :)
0
 
JohnysteaksAuthor Commented:
How Do Update the Kernal and how don i find out if the kernal does not match the kernal source...
0
 
owensleftfootCommented:
"uname -r" (without the quotes) will give you your kernel version. If it doesnt match the version in /usr/src I would download the source for your current kernel rather than updating your kernel - its easier :)
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Alf666Commented:
You have to do the followin in order :

1) Install the "kernel-source" package

2) Stop your X server using the following command (as root) in a terminal :
init 3

You will end up in terminal mode. Log in as root.


3) Relaunch the NVidia install script

4) Launch the following command in a terminal :
switch2nvidia_glx

5) Run Sax2 and select your NVidia card and driver.
Configure your display and exit

6) type the following command :
init 5

This should work.
0
 
JohnysteaksAuthor Commented:
3) Relaunch the NVidia install script     <----when i issue the SH <Nvidia File>, I believe i do not have an option to exit out to a command line, it's all menue driven...
I am @ work-so i haven't tried it....I am just going from memory...



4) Launch the following command in a terminal :  <--Should i be in a particular directory??
switch2nvidia_glx
0
 
Alf666Commented:
Theoritically, all should work with no particular hassle. No specific directory or whatever.

The menu driven install is in terminal mode, isn't it ?
0
 
JohnysteaksAuthor Commented:
Yes it is...I apologize if i am being to literal, but when you mean:


3) Relaunch the NVidia install script   <<--- It is uning the Sh <downloaded filename> ??


 
0
 
Alf666Commented:
Yes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now