Solved

IIS 6 default document error - "The system cannot find the file specified. "

Posted on 2004-04-05
9
3,074 Views
Last Modified: 2007-12-19
I have set the IIS default document for my site  to index.asp. It simply will not find this document unless i manually type it into the address.

http://IPaddres/index.asp - works
http://IPaddress - fails

The error I get is:
"The system cannot find the file specified. "

I set the default document in IIS6 on Windows 2003. This server was just setup recently. Has anbody ran into this trouble or have any ideas what might cause this to fail??

Thanks,
jordan
0
Comment
Question by:jrmcdona
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +3
9 Comments
 
LVL 6

Assisted Solution

by:BAlexandrov
BAlexandrov earned 50 total points
ID: 10761211
I currently use IIS6 there are no issues even that we have custom default document (legacy one - start.asp)

Could you try what is the result with
http://IPaddress/
0
 
LVL 37

Assisted Solution

by:meverest
meverest earned 50 total points
ID: 10761452
do you have more than one web site?  

also, check the documents tab content for typo.

cheers.
0
 
LVL 4

Expert Comment

by:anderson22
ID: 10762968
I had same problem with II6.  Remove and readd the web site to get the mapping to work.  It is related to some issue in the metabase.

-rca
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:jrmcdona
ID: 10766309
It is the only website I have on the site.

anderson22 - I will give that a shot.
0
 
LVL 14

Assisted Solution

by:alimu
alimu earned 50 total points
ID: 10821560
This is probably a silly question but have you allowed ASP on your site? This is disabled by default in IIS6 and needs to be explicitly allowed through web server extensions in the management console.
AJ
0
 

Author Comment

by:jrmcdona
ID: 10824319
I had ASP enabled. I reinstalled IIS and it works now. I am not sure what got corrupted!
0
 
LVL 4

Accepted Solution

by:
anderson22 earned 100 total points
ID: 10824522
There are some issues with IIS6 metabase and application pooling.  I couldn't find an exact source or cause, but the reinstall seems to fix the problem.

It is possible that this is caused by some update.  Also, I have been running my web server for two months with no more problems.

-rca
0
 
LVL 2

Expert Comment

by:M3hcSS
ID: 12907911
How does one check to see if .asp is allowed?

BRAND NEW to IIS 6.0 (wishing we didn't use it).
0
 
LVL 6

Expert Comment

by:BAlexandrov
ID: 12908019
From IIS Console, Web services node (next to web sites)


Don't wish that, it is much better than 5
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question