Solved

Why doesn't Internet Explorer 6 run a Movable Type CGI script?

Posted on 2004-04-05
11
317 Views
Last Modified: 2013-12-25
I'm trying to install Movable Type (a popular open-source web log application) on my web hosting provider's server. I uploaded the latest version, set permissions of .cgi files to 755 (as instructed in the Movable Type documentation), and made sure to upload .cgi files in ASCII mode. I also checked with my web hosting provider to make sure all required Perl modules are installed (they are).

The Movable Type documentation instructs me to open a CGI file in a browser (called mt-check.cgi) that is supposed to run a check to ensure all required Perl modules are installed.

Every time I try to open/run this CGI script in IE6, the "File Download" box pops up asking if I want to open or save the file. If I choose "Open," it just opens the CGI source code in Notepad.

I called tech support for my hosting provider---they opened the same URL (pointing to the CGI script) and it worked perfectly for them. (I neglected to ask them what browser they were using...)

Why won't IE6 run this script? I've poked around in Security settings and can't seem to find anything to get around this. I'd be grateful for any assistance!

Scott
0
Comment
Question by:lscottw
11 Comments
 
LVL 48

Expert Comment

by:Tintin
ID: 10761880
The behaviour you are seeing is nothing to do with the browser and everything to do with the web server.

Are you absolutely sure you were using the same URL as your tech support?

The other possibility is that your service provider operates a web cluster and that you were pointing to one of their servers that had a different configuration (ie: wasn't setup to run CGI scripts).

Try using the IP address of your webserver instead, and see if that makes a difference.
0
 

Author Comment

by:lscottw
ID: 10762682
Hmm...I suspect the problem is with the web server too...but my web hosting provider is giving me a bit of the runaround. I tried accessing the CGI script using my IP address, and got the same result (File Download dialog box).

If anyone cares to try, I'd be curious to see what results you get. The URL to the script I'm trying to run is:
http://www.shadepine.com/movabletype/mt-check.cgi

Meanwhile, I'll contact tech support again and try to break through the runaround!

Scott
0
 
LVL 48

Expert Comment

by:Tintin
ID: 10763069
I get the same result as you (shows the code), so my suspicion is that your tech support people are looking at another URL.
0
MIM Survival Guide for Service Desk Managers

Major incidents can send mastered service desk processes into disorder. Systems and tools produce the data needed to resolve these incidents, but your challenge is getting that information to the right people fast. Check out the Survival Guide and begin bringing order to chaos.

 
LVL 33

Expert Comment

by:shalomc
ID: 10763768
If you use virtual hosting, then your web site probably has more than a single url.
you may access it via http://www.yoursite.org

but your ISP may access it via something like http://www666.yourISP.com/hosting/yoursite.org
with proper configuration it should work in both cases, but hey, who said the configuration is proper?

ShalomC
0
 

Expert Comment

by:cameron_schuler
ID: 10770231
Works for me.   I'm using Mozilla FireBird.
0
 
LVL 48

Expert Comment

by:Tintin
ID: 10771187
When you do a DNS lookup on www.shadepine.com, do you get 65.18.191.242

If not, then your site could be on a webcluster or similar setup.

Interestingly enough, it's working for me today, so either the DNS is pointing to a different server, or your service prodvider fixed the problem.

0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 10777787
either this is a server problem, then ask your ISP
or your server is a virtual host (for example in apache) *and* your browser sends HTTP/1.0 request only, if so
tell your browser to send HTTP/1.1 requests
0
 
LVL 48

Expert Comment

by:Tintin
ID: 10779401
Can't be a browser issue as I used the same browsers a couple of days ago and it wasn't working (ie: downloaded the source), then the following day, it was working.
0
 

Author Comment

by:lscottw
ID: 10812796
To everyone who responded---I finally figured out the problem, and (as is so often the case) the problem was user error: I had the incorrect path to Perl entered in one of MovableType's configuration scripts. (DOH!)

So I can't blame the problem on IE6, which worked fine and executed the script once I corrected the path.

Thanks again,
Scott
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 12002694
PAQed, with points refunded (500)

Computer101
E-E Admin
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will aim to show you how simple is making a small application in WhizBase, how to add, remove and update data in the DB. I will make a small address book application where you can add, browse, update and remove addresses. I wi…
Introduction This tutorial will give you a fast look what you can do with WhizBase. I expect you already know how to work with HTML at least, and that you understand the basics of the internet and how the internet works. WhizBase is a server-s…
Learn the basics of modules and packages in Python. Every Python file is a module, ending in the suffix: .py: Modules are a collection of functions and variables.: Packages are a collection of modules.: Module functions and variables are accessed us…
In this fifth video of the Xpdf series, we discuss and demonstrate the PDFdetach utility, which is able to list and, more importantly, extract attachments that are embedded in PDF files. It does this via a command line interface, making it suitable …

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question