Solved

IE gives me "bad gateway" error when trying to access intranet sites thru vpn

Posted on 2004-04-05
21
1,218 Views
Last Modified: 2008-03-10
I connect to the office with the Contivity VPN Client V04_65.30 from Nortel Networks.  I connect just fine and can do most things, including accessing intranet sites via Netscape.  Its just IE that is the problem.  I get this error when trying to access an intranet site:
"
Bad Gateway
The following error occurred:
[code=DNS_HOST_NOT_FOUND] The host name was not found during the DNS lookup. Contact your system administrator if the problem is not found by retrying the URL.
--------------------------------------------------------------------------------
Please contact the administrator.
"
Help desk at the 'office' isn't much help, unfortunately, but I need to access an application that I developed that runs on the intranet with IE.  Apparantly I'm the only one who has this problem.

The only protection that I have running is zonealarm, and it doesn't matter whether it is on or not.  I have no Norton applications running.

I've got all kinds of security settings on IE set low, and all my settings seem to be what help desk says they should be.  The version of IE is: 6.0.2800.1106.xpsp2... I'm running XP Pro.

In IE -> Tools -> Internet Options -> Connections: its all blank.  'Never dial a connection' is selected, but greyed out.  Under Lan settings: 'Automatically detect settings' is the only thing selected.  I'm on cable.

I hope this is just a stupid setting that I've missed.  Perhaps somebody has run into this before??

Thanks,
Janice
0
Comment
Question by:jelything
  • 6
  • 6
  • 5
  • +1
21 Comments
 
LVL 5

Expert Comment

by:mrpez1
Comment Utility
Can you ping the host you're trying to connect to? If so you might try connecting using the IP address. Although this won't solve your problem, it might be a work around.
0
 
LVL 20

Expert Comment

by:What90
Comment Utility
I'd put the either the VPN's default gateway or the proxy server for Internal LAN in the  IE -> Tools -> Internet Options -> Connections - Lan setting -Proxy details.
If you don't know them - check with the local IT team.

I'd also check that setting on Netscape and see if they have been change at all.
0
 

Author Comment

by:jelything
Comment Utility
Well, I can't ping the IP address that the help desk gave me, and they don't want me to try anything in the lan settings for IE, since that's not how their stuff is set up.

I checked Netscape's settings, but it all looks pretty generic.

I'm tempted to uninstall IE, but I can't afford for things to go squirrelly on me now :(

J
0
 
LVL 5

Expert Comment

by:mrpez1
Comment Utility
Try going into the command prompt and typing ping <hostname and domain>. For instance: "ping host1.expertsexchange.com". (hmmm....that's why the dash is in this site's name....)

I'm assuming that's the format of the address you are putting into netscape and successfully connecting with, If you can resolve that name with your DNS settings it will give you the IP address of the host. Then put that ip address into IE and see what happens. Hopefully b/c you are bypassing DNS by providing the IP address directly you won't get that error and won't have to change anything drastic.
0
 

Author Comment

by:jelything
Comment Utility
I got the ip address of two of the servers I can't connect to, and tried using the ip address in both Netscape and IE.  Netscape worked both times, and IE gave me a 500 error both times.

Do you think re-installing IE would help?
0
 
LVL 5

Expert Comment

by:mrpez1
Comment Utility
Couldn't hurt.... Netscape is definately not using a proxy server, right?

When you pinged, you got the IP address but was the ping successful?
0
 

Author Comment

by:jelything
Comment Utility
Netscape is definately not using a proxy server.

When I pinged, I got the IP address but the ping was unsuccessful.  (Timed out)
0
 
LVL 5

Expert Comment

by:mrpez1
Comment Utility
Generally, if your VPN is configured properly you should be able to ping the remote LAN. If it weren't for Netscape working, I'd say the VPN isn't set up right. Netscape isn't getting a cahced page, is it (working offline)?

I'd give What90's suggestion a try then do the reinstall. If you're still stuck after that, I'd look at the VPN.
0
 

Author Comment

by:jelything
Comment Utility
Netscape isn't getting cached pages (one of the sites I'm hitting is a web application and it works fine right up to the point that javascript stops me.)

When you say 'look at the VPN'... do you mean on my end or on the server's?  Help desk has walked me through my setup and it is as they recommend.  Is it possible the problem is at their end?

JJ
0
 
LVL 5

Expert Comment

by:mrpez1
Comment Utility
Does help desk think you shouldn't be able to ping the LAN from your computer? That's a big problem. Unless that's some sort of "feature" on Contivity client. Although I haven't used that one, every VPN client I've used creates a tunnel from the client computer to the remote LAN/VPN Server. It seems like your packets (with the excpeption of Netscape) aren't going through the tunnel and are just using your default gateway and thus getting lost. I commiserate with you having to deal with a useless helpdesk but you're going to need thier help to troubleshoot this as you don't have access to the remote VPN server.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 20

Accepted Solution

by:
What90 earned 166 total points
Comment Utility
Your helpdesk should have all the relevent information for the VPN client, and the proxy settings required to get you going.

If they can't help you and you don't have any admin abilities then I'd stick to netscape and log a call with the helpdesk to resolve the problem.

Not much use, but your system may have a particular config only know to your company such as proxy ip address or port number they use.


0
 
LVL 11

Expert Comment

by:ewtaylor
Comment Utility
It is not IE it is the website you are connecting to check the app you developed
502: Bad gateway
The server from which you tried to access a document needed to obtain that document from another server, and received an error message from that server in the process.

0
 
LVL 5

Assisted Solution

by:mrpez1
mrpez1 earned 166 total points
Comment Utility
Then why would netscape work?
0
 
LVL 11

Expert Comment

by:ewtaylor
Comment Utility
Why do you need to access it from IE? I am confused I thought it was developed for IE? Are you just trying to test it and make sure different browsers can use it?
0
 
LVL 20

Assisted Solution

by:What90
What90 earned 166 total points
Comment Utility
jelything -

Can you get a second laptop and test the vpn and IE on that one. This would at least clear up the if it just your machine and something that's effecting your copy if IE.
0
 
LVL 11

Expert Comment

by:ewtaylor
Comment Utility
Ahh unless I miss my guess he has developed this app and is using IE for it and netscape for all other browsing. He needs to check his app more than likely it is a permission or coding issue.
0
 

Author Comment

by:jelything
Comment Utility
I need to get to my application with IE because it was developed exclusively for IE and there is some javascript in there that won't run in Netscape.  I need to be able to access my app in test and prod, so I need to get there from IE.  

For all the other intranet documents I need to get to, I can use Netscape.

There are several servers that are only accessable via the intranet, and I can't get to any of them from IE, just Netscape.  Its not just my app that does this, it it any intranet site.

I'm going to bug help desk today some more and try some of things you folks have suggested.
0
 
LVL 11

Assisted Solution

by:ewtaylor
ewtaylor earned 168 total points
Comment Utility
Well then
Make sure there is no proxy server filled in under 'LAN settings'.
Disable automatic detection of a proxy server.
0
 
LVL 11

Expert Comment

by:ewtaylor
Comment Utility
Looks like a 3 way split.
0
 

Author Comment

by:jelything
Comment Utility
I am very sorry.  I will split the points.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

One of the Top 10  common Cisco VPN problems are not-matching shared keys. This is an easy one to fix, but not always easy to notice, see the case below. A simple IPsec tunnel between fast Ethernet interfaces of routers SW1 (f1/1) and R1(f0/0). …
Do you have an old router lying around the house that you don’t know what to do with? Check the make and model, then refer to either of these links to see if its compatible. http://www.dd-wrt.com/site/support/router-database http://www.dd-wrt.c…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now