[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 305
  • Last Modified:

Perl CGI Counter randomly skips

I am using the code below to count hits on a web site.
Problem is it randomly skips on the tenth digit?
      For example 10 may show up but 20 shows as 10..:
      5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,10,21,22,23,24,25,26,27,28,29,20,31,32
This is random.. sometimes the tenth digit is correct sometimes it doesn't increment until the last digit hits 1.

This does not use FLY or SSI.. it is called with the following html:
          <img src="http://website/cgi-bin/counter.cgi?1">  
          <img src="http://website/cgi-bin/counter.cgi?0&w">

Here's the code:
---------------------------------------------------------------
  $digits_basedir = "http://website/cgi-bin/counter/";
  $count_file = "count";
($place, $Write) = split(/\&/,$ENV{QUERY_STRING});

open(COUNT,"$count_file") || die "Can't Read From Count File $count_file, Error : $!\n";
($count) = <COUNT>;
close(COUNT);
$count =~ s/\n//;

if ($Write =~ /w/i) {
   $count++;
   open(COUNT,">$count_file") || die "Can't Write To Count File $count_file, Error : $!\n";
   print COUNT "$count";
   close(COUNT);
}
$count = "0000000000".$count;
@chiffres = split(//, $count);
@chiffres = reverse(@chiffres);
print "Location: ".$digits_basedir.$chiffres[$place].".gif\n\n";
0
Stella Pauley
Asked:
Stella Pauley
  • 8
  • 7
1 Solution
 
healthstatusCommented:
I'm guessing the browser or your ISP is caching the image since the URL for the digits isn't changing.  Try adding a &x to the  <img src="http://website/cgi-bin/counter.cgi?1">   so it becomes  <img src="http://website/cgi-bin/counter.cgi?1&x">   that may get the cache into thinking it is dynamic (which it doesn't think it is currently).  The other thing to try is get to 19. close the browser, clear your cache and then go to the page and see if it pops up as 20.
0
 
Stella PauleyAuthor Commented:
I set it to &x and had the same problem.
I also ran it up to 119, closed the browser, opened browser, deleted cache files, then hit the page and got 110 instead of 120. then 121..

Thanks, any other ideas?
0
 
healthstatusCommented:
I may be barking up the wrong tree, but I still think it is a cache issue, probably the ISP or your network proxy server.
You might try putting the meta tags:
<META HTTP-EQUIV="Pragma" CONTENT="no-cache" />
<META HTTP-EQUIV="Expires" CONTENT="-1" />
on your web page and see if that makes any difference.
0
2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

 
Stella PauleyAuthor Commented:
Same results with the meta tags.
Same results with or without going through a proxy.
0
 
Stella PauleyAuthor Commented:
You may be right on the caching though..
When the web shows 250 the count text file shows 260.
0
 
healthstatusCommented:
Try changing

print "Location: ".$digits_basedir.$chiffres[$place].".gif\n\n";

to

print "Location: ".$digits_basedir.$chiffres[$place].".gif?".$count.'\n\n";

0
 
healthstatusCommented:
oops - typo

print "Location: ".$digits_basedir.$chiffres[$place].".gif?".$count."\n\n";
0
 
Stella PauleyAuthor Commented:
same results...
0
 
healthstatusCommented:
Really!? When you right click (windows I hope) the image and look at the properties what does it show as the URL for the images? or look at the source.
0
 
Stella PauleyAuthor Commented:
properties of each image show:
http://website/cgi-bin/counter.cgi?1&x

images are layed out as:
4&x  3&x  2&x  1&x  0&w

Here's the "View Source" (yes its windows)
----------------------------------------------
<HTML>
<head>
<META HTTP-EQUIV="Pragma" CONTENT="no-cache" />
<META HTTP-EQUIV="Expires" CONTENT="-1" />
</head>
<body>
<img src="http://website/cgi-bin/counter.cgi?4&x">
<img src="http://website/cgi-bin/counter.cgi?3&x">
<img src="http://website/cgi-bin/counter.cgi?2&x">
<img src="http://website/cgi-bin/counter.cgi?1&x">
<img src="http://website/cgi-bin/counter.cgi?0&w">
</body></HTML>
0
 
healthstatusCommented:
Do you have the ability to change the links to https (page and the image links)? Just for the sake of testing?
0
 
Stella PauleyAuthor Commented:
Ability... Yes...
But I don't have a Certificate file for the ssl..

IIS v5.1
0
 
healthstatusCommented:
Well that will just pop a certificate error in your browser but still load the page, usually networks won't cache https pages.  I guess from what I see, it is not a coding issue, other than the technique used is susceptible to problems.
0
 
Stella PauleyAuthor Commented:
IIS won't let me use ssl without a certificate file..

Thanks for the help..
0
 
Stella PauleyAuthor Commented:
I found the problem.. the &w was in the wrong spot..
I had it pulling image 4, 3, 2, 1, writing to the log file, then pulling image 0...

I moved the &w first image source (the one with a 4) instead of the on with the 0..
this way it writes to the log file then pulls image 4, 3, 2, 1, 0...

I still did need the cache disabled.. without that it then randomly skipped any digit..

Thanks for the help...
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now