Slow Linux

Hi Experts,
     i have new pentium IV 2.66 GHz Processor and 640 MB of RAM in my system. but still i face a slowness in my system. the booting is very slow and some applications are opening very slow. does it make slow because of partitions i made? here' the dtails of my partitions

/boot -  100 MB
/swap - 1.75 GB
/          - 12.5 GB
/home - 5.25 GB

     what could be the problem...

       thanks in advance
LVL 7
maheshexpAsked:
Who is Participating?
 
Alf666Connect With a Mentor Commented:
First, don't hold me responsible if anything breaks down :-)
You might want to ask the help from a friend who knows a bit about PC hardware.

Unplug all power from your box
Open it
Find your two drives.
They should both be plugged on the same cable (a 40 or 80 wires gray cable).
You should have a second cable looking the same on the box.
There is a possibility that you have a CD drive on the second cable.

Unplug the second disk and plug it on the second cable.

With a bit of luck, it will be recognized as slave on the second cable too.

Close, replug, and test.
0
 
Alf666Commented:
Could you send the result of the following command ? :

hdparm -d /dev/hda

(assuming your drive is on /dev/hda).

Just so you know, 1.75 GB of swap is lots too much. It won't hit your system's performance, but you waste precious disk space :-)
768M would have been largely enough (not that it makes a big difference on a 20G HD though, but that's one movie less :-)).
0
 
avizitCommented:
I generally have the size of swap approximately twice my RAM . but have never gone beyond 1GB as swap size .. not much point beyond that.

okay regarding your slowness , you may also like to

paste the results of

top command

and also disable services which you dont use. eg if you dont have any printer attached , no pint running the cupsd , similarly check for samba / ftpd etc etc

-Abhijit

0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
maheshexpAuthor Commented:
my '/' partition is at /dev/hdb2

[root@localhost root]# hdparm -d /dev/hdb2

/dev/hdb2:
 using_dma    =  1 (on)
0
 
maheshexpAuthor Commented:
regarding sevices, i  had disabled all the unwanted services...can u give me a good parition idea for installing linux on the a P 4 2.66 GHz Machine, 640 MB RAM, 20 GB Hard Disk
0
 
Alf666Commented:
partitioning is a personal choice. One can always argue, but yours is neither better, neither worse than any other. I just added this swap comment for yoru information, but it is definitely not that problem you're encountering.

Why is you / on hdb ? What other disks do you have on your system ?

As avizit said, you can also post the result of a "top" command. But it would not explain why it's slow on booting. BTW, what do you call slow ? How long does it take to boot ?
0
 
maheshexpAuthor Commented:
on hda i have windows....hdb is 20 gb hdd
0
 
maheshexpAuthor Commented:
1:05 mins to get login screen
40 seconds to get my desktop
( calculated using my stopclock he..he...)

so totally it gets me ~2 mins to get into my system.

Also applications such as mozilla, OpenOffice, Eclipse and others are loading slow at first time annd a bit faster second time

but WinXP seems to load quicker.
0
 
maheshexpAuthor Commented:
i had posted the hdparm command's OP already
0
 
Alf666Commented:
It does not seem fast indeed.

I suspect a hard drive problem. Can I suggest that you remove your first drive, and leave only that one inside ? The drawback is that you'll have to boot a rescue disk in order to change /dev/hdb to /dev/hda entries in fstab.

Ideally, your PC should have two IDE buses. I suggest you have one disk as master on each one in place of one master and one slave on the same bus.

0
 
maheshexpAuthor Commented:
sorry i can't get ur ans...i am some what weak in the hardware side
0
 
Percepti0nCommented:
Try adding more RAM, that may help. The applications you run are probably eating up the RAM. If that isn't the case, a reboot may help, but that is only a temporary solution, so just get some more RAM, will definitely help.
0
 
maheshexpAuthor Commented:
it's already 640 MB...why need more
0
 
Bozzie4Commented:
I agree that it's possibly a harddrive problem . Do a

hdparm -tT /dev/hdb

to check the speed it's actually running at.

Tom
0
 
maheshexpAuthor Commented:
/dev/hdb:
 Timing buffer-cache reads:   1068 MB in  2.00 seconds = 534.00 MB/sec
 Timing buffered disk reads:   86 MB in  3.23 seconds =  26.63 MB/sec
0
 
Bozzie4Commented:
You could try and improve the performance (if your drive supports it), but this level of performance should give you 'mediocre' performance, not 'super-bad' like you experience it:

hdparm -X66 -d1 -m16 /dev/hdb

Caution : this could lock up your system  (and apparently, you could loose data too, but I've never experienced this myself)!
If it works, you can add this to your rc.local or whatever , to set it at boottime

cheers,

Tom
0
 
maheshexpAuthor Commented:
what are all these values refers to
0
 
Alf666Commented:
I would not try such commands. Your disk appears to be working just fine.

You have largely enough RAM (except if you run something *huge* and you did not say so). Your disk appears to work correctly.

You never sent the result of a top command :

top

0
 
avizitCommented:
on a very slim chance , have you installed any new programs on your own and maybe you downloaded the nightly builds and not the stable versions . sometimes they have memory leaks.

( ps: that would still not explain the longer boot time )
0
 
maheshexpAuthor Commented:
which command? i can't get what u meant by top command
0
 
avizitCommented:
try
man top

- /abhijit/




0
 
Alf666Commented:
The command that's named "top".

0
 
maheshexpAuthor Commented:
top command

 22:36:16  up 14 min,  3 users,  load average: 0.12, 0.17, 0.16
72 processes: 70 sleeping, 1 running, 1 zombie, 0 stopped
CPU states:  cpu    user    nice  system    irq  softirq  iowait    idle
           total    0.0%    0.0%    0.0%  33.3%    33.4%   33.1%    0.0%
Mem:   642376k av,  290096k used,  352280k free,       0k shrd,   16828k buff
        60700k active,             165016k inactive
Swap: 1839400k av,       0k used, 1839400k free                  124696k cached

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND
 6330 root      15   0  148M  19M  2716 S     4.1  3.0   0:12   0 X
 6609 root      15   0 42912  13M 11108 S     1.1  2.1   0:00   0 kdeinit
 6662 root      17   0  1104 1104   884 R     0.1  0.1   0:00   0 top
    1 root      16   0   420  420   360 S     0.0  0.0   0:04   0 init
    2 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 keventd
    3 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kapmd
    4 root      34  19     0    0     0 SWN   0.0  0.0   0:00   0 ksoftirqd/0
    6 root      25   0     0    0     0 SW    0.0  0.0   0:00   0 bdflush
    5 root      25   0     0    0     0 SW    0.0  0.0   0:00   0 kswapd
    7 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kupdated
    8 root      18   0     0    0     0 SW    0.0  0.0   0:00   0 mdrecoveryd
   12 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kjournald
   88 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 khubd
 4158 root      15   0     0    0     0 SW    0.0  0.0   0:00   0 kjournald
 4282 root      18   0     0    0     0 SW    0.0  0.0   0:00   0 kjournald
0
 
Alf666Commented:
Unfortunately, you'll have to look on the hardware side.
Probably an IRQ problem.

You can also try to put your second disk on your second IDE channel (which you certainly have).

0
 
maheshexpAuthor Commented:
can you tell me how to put my HDD in second IDE channel
0
 
avizitCommented:
Just one more  precaution, if you look carefully on the HDD you might see some instruction on setting the jumper for master and slave , so set the jumper correctly according to the diagram provided therein.

even my knowledge of PC Hardware is flaky , so the same disclaimer as Alf666 applies :p



/abhijit/
0
 
ngopuCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
Accept Alf666's comment as answer

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Gopu N
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.