We help IT Professionals succeed at work.

Debuging not working under Eclipse platform

rajaamirapu
rajaamirapu asked
on
220 Views
Last Modified: 2010-03-31
Hi,
How to enable debuging under Eclipse platform.
Thanks
Raja
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2016
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT
Top Expert 2016

Commented:

Author

Commented:
Thanks for the link.It is going to debug view and the debug is terminated.
Any suggestions
CERTIFIED EXPERT
Top Expert 2016

Commented:
I don't know what you mea by 'terminated' but check compiler options. Make sure debugging is on.
CERTIFIED EXPERT
Top Expert 2016

Commented:
(Usually the -g argument to the compiler)
Mayank SPrincipal Technologist
CERTIFIED EXPERT

Commented:
What is the problem? Can you elaborate a little more? Have a look at: http://linuxdevices.com/articles/AT6046208714.html

Author

Commented:
When i debug, it is not going to debug and not displaying the results it is just staying like that
Mayank SPrincipal Technologist
CERTIFIED EXPERT

Commented:
You have to Step Into or Step Over using F5 or F6.... did you read the link that I posted?

Author

Commented:
I have found out the solution now
I am giving the solution for future reference

 it is working i need to deploy the org.eclipse.debug.ui_2.1.1 plugin
Any way thanks for your suggestions
Mayank SPrincipal Technologist
CERTIFIED EXPERT

Commented:
Oh, you mean to say that you didn't have debugging enabled initially at all? That's perhaps what CEHJ meant when he said:

>> Make sure debugging is on

Author

Commented:
Thanks  CEHJ i solved the problem with your suggestion.
CERTIFIED EXPERT
Top Expert 2016

Commented:
8-)

Make sure you understand how changes to your programming environment translate to the 'real' Sun settings or you won't understand Java thoroughly from first principles

Author

Commented:
Basically i am microsoft guy and i have started learning java
CERTIFIED EXPERT
Top Expert 2016

Commented:
Good for you ;-) Best wishes
Mayank SPrincipal Technologist
CERTIFIED EXPERT

Commented:

Author

Commented:
I am  a Microsoft India Community Star
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.