AT command and hyper terminal

I'm developing a SMS web application using a GSM phone connecting to my PC. The phone model that i've chosen is Nokia 8250. After i've connected the data cable (Serial port) to my PC, i used the hyper terminal to test the connection. The settings is 9600, N, 8, with a proper port (COM1). When i typed "AT" on the window (hyper terminal window), i get nothing (meaning no response).

Even when i tried to run my application, i can see from my log file that the response getting from the "AT" command will be exactly the same as the input. Eg: if the at command is "AT", i'll get back the "AT" as input stream from the port. What's the problem?
wcsjoeyAsked:
Who is Participating?
 
anupvijayConnect With a Mentor Commented:
Hi Joey,
drelectro has just given the answer to your query as to why IRDA and not SERIAL.
The modem in 8250 might be only interfaced with the IR port and not the serial port.
Some phone can take AT commands thru both serial as well as IR.
Good luck with IR :-). Let us know whether things worked fine
Cheers,
Anup
0
 
anupvijayCommented:
Do you have any other phone with Data Cable ? If you have then please try the AT command with that also.
Just to narrow down the problem...............

Also what does ithe HT show on its status bar ....does it show "connected" ???

The response you get after typing in "AT" should be "OK" and not the "AT" itself.
You might be seeing this because of the local echo ON in your terminal settings.
Cheers
Anup
0
 
wcsjoeyAuthor Commented:
Currently i only have this cable. I saw the status is "connected", but when i type "AT" i get nothing! (If i set the echo off)...
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
anupvijayCommented:
What is your Flow Control setting ?
0
 
anupvijayCommented:
My flow control setting is set to NONE. Dont know whether it makes any difference.
0
 
wcsjoeyAuthor Commented:
My flow control setting is set to none also.. But it doesn't work either..

Any solution?
0
 
anupvijayCommented:
Hi wcsjoey,

The behavior you see happens when there is no AT supporting device on the other side of the serial connection.
Are you sure Nokia 8250 supports AT command interface.
Have you tried the Nokia PC suite and chekced whether it connects to the phone ? It is available here
http://www.nokia.com.ph/nokia/0,,44580,00.html#Suite

If you can borrow another phone an ericsson or sagem from somewhere you could verify whether it is a problem with
your serial port or PC or the phone itself.

Cheers,
Anup
0
 
HippyWarlockCommented:
You might like this link if you havent already got it:
http://gsm.net.ua/ATNOKIA.pdf
0
 
wcsjoeyAuthor Commented:
Hi Anup,

THe link that u've recommended (Nokia PC suite) is merely for Infrared connection, but i'm using a serial data cable. I can't find any PC suite for serial connection.

I've tried other software like Logo manager, and it does work!
I'm not too sure whether 8250 support at command interface. Can u recommend any website whereby i can check which models supports the at command?


HippyWarlock,
Thanx for ur recommendation, but i've already got the document.

0
 
anupvijayCommented:
Hi joey

I just wanted to check whether you COM port is ok or not. As you said it works with Logo Manager it should be fine.

Have you been to nokia forum's discussion board ?
I picked a reply from there .Here it is. Try it. Might be worth.
http://discussion.forum.nokia.com/forum/showthread.php?s=f8e1b5b8530e7091cdef71bc9ce49788&threadid=3136&highlight=%2ASerial+port+AT%2A

Keep posting whatever u come up with.
Cheers,
Anup
0
 
zahidrahimCommented:
Hello, Phone normally connect with 19200,n,8,1 settings
but you should confirm the settings at first from control panel
Modems-> Modems And properties the speed of the com port will be your baud rate for hyper terminal. i hope this will cause communication in hyperterminal and force you to accept my answer ;)
0
 
wcsjoeyAuthor Commented:
Hi anup,
thanx for ur reply. The link to nokia forum is quite useful. I found from one of the old thread which mentioned that N8250 need the irDa. I've purchased the device and need further testing on this.

However, Do u have any idea why it has to use infrared? Any difference between irda and serial port, in terms of exchanged of data, protocol, etc....??

Hi, zahid,
I'm using the correct speed. (Infact i've tried all) :->
0
 
drelectroConnect With a Mentor Commented:
The 8250 definatly does NOT support AT control via a serial cable, only via IR.
You could just get a serial to irda adapter for your pc.
0
 
virenderpratapConnect With a Mentor Commented:
8210 and 8250 Supports AT commands But NOT the Cummnication Via  Serial Port , U can use IRDA port to communicate and run ur AT commands. :)
0
 
virenderpratapCommented:
The Minimum Nokia Model u can use serial port is 3100
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.