• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 633
  • Last Modified:

Indenting in Code View

Below is a sample of what I see looking at the code in Dreamweaver Ultradev 4.01 - obviously unmanagable.  How can I get it formatted into a legible form w/ the expected indentation?

I've already tried Commands -> Apply source formatting and this does not appear to do anything at all.

In Edit -> Preferences -> Code Format I have checkmarks next to all of the 'Indent' options and I have no Automatic Wrapping selected.

I've just installed a few days ago on WinXP Pro machine.  Previously was using on Win2k machine and had no problems.  

Is this an XP compatibility problem?  Do I have a setting screwed up?  I'm going nuts here - any help would be much appreciated!

What I want:
---------------------------
<table>
   <tr>
      <td>Content
      </td>
  </tr>
</table>

What I have:
---------------------------
<tr> <td height="25" valign="MIDDLE" COLSPAN="12" BGCOLOR="#c5d8f0" CLASS="normaltextlarge" ALIGN="CENTER">Disposable
Commitment</td></tr><tr VALIGN="MIDDLE"><td height="25" WIDTH="26">&nbsp;</td><td ALIGN="CENTER" COLSPAN="2">&nbsp;</td><td ALIGN="CENTER" WIDTH="54" CLASS="normaltextxtrasmall">Current<BR>Units</td><td WIDTH="54" ALIGN="CENTER" CLASS="normaltextxtrasmall">Commit<BR>Units</td><td ALIGN="CENTER" WIDTH="54" CLASS="normaltextxtrasmall">Base<BR>Price</td><td ALIGN="CENTER" WIDTH="54" CLASS="normaltextxtrasmall">Fee
Per<BR>Unit</td><td WIDTH="54" ALIGN="CENTER" CLASS="normaltextxtrasmall">Net<BR>Price</td><td ALIGN="CENTER" WIDTH="75" CLASS="normaltextxtrasmall">Extended<BR>Base
0
frodoman
Asked:
frodoman
  • 4
  • 2
  • 2
  • +2
1 Solution
 
mrichmonCommented:
One trick that may help is to go into design view and change some text - and even change it back.  This often causes DW to give some basic formatting to the code view.
0
 
EsopoCommented:
Seems to me there's something wrong with your DW. I can't think of a way to make it autoindent, I tried a few things in my MX, none worked.

I suggest you download some software to do the reformatting of the html, an example:
http://download.paessler.com/download/aspbeautify.zip (200k)

From the site:
ASPBeautify beautifies the server based VB Script source code of Active Server Pages (ASP) and HTML Files by reformatting the source code (code indention).
It features VBScript- and HTML-indention, automatic clipboard and multiple file beautifying (batch).
- The site: http://www.paessler.com/products/freeware
You can also find it here: http://www.ezgoal.com/house/allfiles.asp?L=A&Order=&Sort=&Step=237&computer+software

I haven't tried this software, exercise caution.

Best regards,

Esopo.
0
 
rockmansatticCommented:
You can also try textpad at textpad.com  free download and colorcodes tags for easy coding.  It  autoformats almost anything that I have opend with it.


textpad.com
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
frodomanAuthor Commented:
Thanks for the comments so far.  I'm aware of other editors but am hoping for a DW fix.

I'm not asking for functionality that isn't there because everything worked fine on my Win2k machine.  Unfortunately I wasn't the one that did the original install there so I don't know if there were settings changed or what.  I did do the install when I moved to WinXP and I'm thinking that there is something configured incorrectly.

Anyone have any ideas?
0
 
mrichmonCommented:
Well, often you can get results like this when a file is transferred from say a Mac operating system to a windows one using binary mode instead of ASCII - or even if you transfer from a web host that is not windows using Binary mode transfer.
0
 
frodomanAuthor Commented:
Good thought but that's not it.  

If I open up a file in notepad the old indented formatting is retained.  When I open it in DW it's fine until I start moving stuff around in design view - it's then that DW screws it up.
0
 
tintedfishCommented:
There are a couple of known compatability issuses with Ultradev and XP. Have a search through he macromedia forums / knowledgebase, I'm fairly sure I have read of this very problem in there. and its solution.
0
 
frodomanAuthor Commented:
I have searched the forums and didn't find anything.  If you can point me to a link I'll be happy to give you the points!
0
 
tintedfishCommented:
Cant find it just now, will have a look later.

Have you tried setting |edit|preferences|code format| indent off, then applying |commands|apply source formatting| to remove all formatting. Save the file. Then switch indent back on  (space and tab size set, overrides off?) and reapplying source formatting?
0
 
frodomanAuthor Commented:
Thanks to all for your efforts but unfortunately none of the suggestions have solved the problem.  Looks like I'm going to be stuck using a 3rd party editor for now...
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now