Solved

xfs configuration :  xfs trouble shooting - particulary when it fails to start

Posted on 2004-04-07
4
649 Views
Last Modified: 2013-12-27
I have Red Hat Linux 8.0 installed on my system(Pentium 4 standalone worstation) . I configured it to boot in graphical mode by default (runlevel 5 for init). My problem is :-----

My X-Server fails to start and thus the desktop does not arrive. It gives the message which tells it could not start the X-Font Server properly and thus cannot start the X-Display. Moreover It does not let me boot up in text mode as the screen keeps on switching bwteen text mode screen and half opened graphical display, both being unstable and transient(not allowing me enough time on the text mode screen to authenticate). Consequently I cannot access my system at all.

How can I prevent the X-Server from trying the start?(And thus get rid of this problem) How can I rescue the system without reinstalling it?(I have some very importane data inside it, which i cannot afford to loose). How can I configure my X-Font server(xfs man entry was not much help)? Is it possible to configure my system in a way, such that it boots up only in text mode? How do I achieve that without reinstallation?

Please give me Red Hat Linux 8.0 specific answers if possible as there exists a lot of fragmentation in the linux world. Pl. help.urgent.
0
Comment
Question by:ray_pro2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 63 total points
ID: 10779490
To have the system start up in text mode you simply need to edit /etc/inittab and set:

id:3:initdefault:

near the top of the file. This edit can be done with vi, emacs, or xemacs while the system is running by switching to an alternate console (Ctrl-Alt-F2) or from a boot to single user mode. Follow the edit with a reboot and it'll come up in text mode.

There can be any number of reasons why xfs is failing to start. One common problem occurs when the permissions on /tmp get changed from mode 1777 (drwxrwxrwt). I assume that this was working before and it might be helpful to know what might have happened or been changed just before the problem was noticed.
0
 
LVL 62

Assisted Solution

by:gheist
gheist earned 62 total points
ID: 10782884
xfs logs some things to syslog daemon facility, examine /etc/syslog.conf, to find log file
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In tuning file systems on the Solaris Operating System, changing some parameters of a file system usually destroys the data on it. For instance, changing the cache segment block size in the volume of a T3 requires that you delete the existing volu…
Introduction Regular patching is part of a system administrator's tasks. However, many patches require that the system be in single-user mode before they can be installed. A cluster patch in particular can take quite a while to apply if the machine…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question