Solved

Urgent:Crystal not showing data at second page( Nagvigation button)

Posted on 2004-04-08
7
187 Views
Last Modified: 2012-06-27
Greetings,

I use CR viewer to show the web report. I have 2 pages, say 1.aspx & 2.aspx. 1.aspx ask the user to pick up the field name then call 2.aspx, 2.aspx pass the parameter and run a sorting then return the report on CR viewer. I only get the report for 1st page. If I click on the 'next' navigation button, I got the following error message:

Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

  Source Error:

                    Line 30:             Dim crReport As New CrystalReport3()
                    Line 31:
error here->  Line 32:             pdrnum.Text = Request.Form("pdr").ToString()
                    Line 33:             ' yrnum.Text = Request.Form("yr").ToString()
                    Line 34:             ' campname.Text = Request.Form("campus").ToString()
 
Above code is from Page_Load function. It seems like the page get refresh when I click on 'next' navigation button, and lost the value for Request.Form("pdr").ToString(). How to fix it?

BTW, I display data in 2 rows(for each record)  in detail section of CR.

Thanks in advance.  
0
Comment
Question by:mrong
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
7 Comments
 

Author Comment

by:mrong
ID: 10782926
The number of total pages is 25, but I can only see the first page of report.
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 10785865
Are you clicking the WEB Page NEXT or the Crystal NEXT Arrow?

mlmcc
0
 

Author Comment

by:mrong
ID: 10785873
Crystal Report NEXT.

Thanks.
0
 

Author Comment

by:mrong
ID: 10792746
I figured it out.
The 'CrystalReportViewer1.ReportSource=?' need to be put outside of Page_Load function.
 
0
 
LVL 5

Accepted Solution

by:
Netminder earned 0 total points
ID: 10820530
Closed, 200 points refunded.
Netminder
Site Admin
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question