Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 37057
  • Last Modified:

Information store dismounted

My information store dismounted themselves, though i didn't make any changes, but when i scan the computer by Norton antivirus i found many netsky@.. Viruses, so I have run the Antivus and cleaned it up  but still information store is not mounted, though I have restarted all exchange & IIS services many times and restart the server as well. All services are running fine. I got the following error when I tried to mount the Mailbox and public store.

Error:

An internal processing error has occurred. try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.

ID no: c1041724
Exchange System Manager

any advice would be hoghly appreaciable
Regards
Maqbool Hussain

0
nepk
Asked:
nepk
  • 11
  • 6
  • 3
  • +5
1 Solution
 
dm_osbornCommented:
How are you doing for Hard disk space? I ran into this problem when I was not being good about backing up the Store. There are several files that get deleted each time you back up that build up rather quickly otherwise.

Simply a lack of HD space can cause this error. I'm sure there are many others ways to generate the error, too.
0
 
ErikKvKCommented:
Did you run the cleanup of virusses over your M-drive, transaction log files or your databases?

This is a sure way to kill your Exchange server.

Try removing all transaction logs and remounting the stores.

Take a look at the database headers (ESEUTIL /MH <database filename>). are they consistent?
0
 
nepkAuthor Commented:
No I haven't run cleanup virus at M drive, but i can't see M drive now. my database is not mounting. i have now deleted transaction log files manually., now when i tried to mount the store again then i got the following error.

error:

database files in this store are inconsistent.

ID no: c1041739
Exchange systen manager

please help
regards
Hussain
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
ErikKvKCommented:
Now run an ESEutil /G <databasename>. This will try to get the database consistent. Make sure that you have at least 25% free space for the temp database that ESEutil is creating.

After this you need to also run an "ISinteg -s <servername> -test alltests -fix" several times until the errors are gone or do not decrease in number. Usually 2 times should suffice.

after this you should be able to mount the database. Now it is advised to run an EXMERGE of all mailboxes to PST's, stop Exchange (dismount the store), delete the database and mount the store so an empty store is created. You can now import the PST into the mailboxes by using Exmerge again.
0
 
dm_osbornCommented:
For future reference, I haven't found it a good idea to delete Transaction logs manually. When you perform a Windows backup of the Store, Exchange deletes all unneeded transaction logs along with a few other files.  If disk space was not the issue, you may have already had some data integrity problems. Going through the database repair process above would have to be done anyway.

You also have the option of moving the databases and transaction logs to another location to get back your HD space. This apparently can be done with the store already dismounted.

Go here:  http://www.winnetmag.com/Windows/Article/ArticleID/4785/4785.html to get a little insight into Transaction logs.

Go here:  http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_tech_note09186a00800c6f5f.shtml for instructions to move the database and logs
0
 
kristinawCommented:
0
 
OneHumpCommented:
Never delete logs on E2Kx.  This is an old 5.5 trick that solved a lot of problems but, because of the storage group architecture in E2K, the log signature is stored in each database.  No log, no store, no dice.  I don't believe a defrag will run when the store is inconsistent.  I think a restore is the best option with a repair (/p) being the last resort.

OneHump
0
 
nepkAuthor Commented:
I have run  ESEutil /G <databasename> and I have more than 25% free space in my hard disk but i got the following error.

Errror: Acees to source database 'exchsrvr\mdbdata\priv1.edb' failed with jet error -1811.

operation terminated with error -1811 <JET_errFileNotfound, File Not Found> after 0.0 seconds.

the same above error occured when i tried to run

c:\program files\exchsrvr\bin\eseutil /p exchsrvr\mdbdata\privi.edb
c:\program files\exchsrvr\bin\eseutil /p exchsrvr\mdbdata\pub1.edb

now what do i do to rum this command properly. please help

regards
Hussain
0
 
ErikKvKCommented:
Looks like your not in the right directory for performing the command.

Make sure that you are in the c:\Program Files\exchsrvr folder, then execute the following:

BIN\ESEutil /p mdbdata\priv1.edb

0
 
nepkAuthor Commented:
I have run eseutil /p successfully now but when it ried to run isinteg the followong error occured. please help.

error:

C:\Program Files\Exchsrvr>bin\isinteg -s sun -test alltests -fix
Databases for server sun:
Only databases marked as Offline can be checked

Index  Status       Database-Name
Storage Group Name: First Storage Group
  1    Offline      Mailbox Store (SUN)
  2    Offline      Public Folder Store (SUN)
Enter a number to select a database or press Return to exit.
1
You have selected First Storage Group / Mailbox Store (SUN).
Continue?(Y/N)y
Isinteg cannot initiate verification process.
  Please review the log file for more information.

regards
Maqbool Hussain
0
 
nepkAuthor Commented:
please reply and help. i am in a very bad position. this is my production email server

0
 
kristinawCommented:
Is the information store service started when you try to do this?
0
 
nepkAuthor Commented:
yeah its started, should I stop the service during the isinteg process?
0
 
nepkAuthor Commented:
yeah its started, should I stop the service during the isinteg process?
0
 
kristinawCommented:
OK, so you ran the repair (eseutil /p). Now, delete all the .log files in the Mdbdata folder (if you have any left in there) and delete the .chk file and temp.edb. After you do this try and mount the database.  If it mounts successfully, then dismount it right away.

do this and then check in again with the results.

kris.
0
 
OneHumpCommented:
nepk, yes, stop the store before running ISINTEG.

OneHump
0
 
nepkAuthor Commented:
I have deleted *.log , *.chk and tmp.edb but now when i tried to mount the data base then again i have receieved the following error. what to do now?

" the database files in the store are inconsistent

ID no: c1041739
Echange system Manager

regards
Hussain
0
 
nepkAuthor Commented:
result of eseutil /MH PLEASE LOOK AT THE STATUS IT SAYS DIRTY SHUTDOEN AND ITS SAY BFORE COMMAND /P AND LOG FILES DELETED "Clean Shutdown" ? IN microsoft article it hsould be marked as Consistent.


C:\Program Files\Exchsrvr>bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\p
v1.edb"

Microsoft(R) Exchange Server(TM) Database Utilities
Version 6.0
Copyright (C) Microsoft Corporation 1991-2000.  All Rights Reserved.

Initiating FILE DUMP mode...
       Database: c:\program files\exchsrvr\mdbdata\priv1.edb

        File Type: Database
   Format ulMagic: 0x89abcdef
   Engine ulMagic: 0x89abcdef
 Format ulVersion: 0x620,9
 Engine ulVersion: 0x620,9
     DB Signature: Create time:06/04/2002 18:11:15 Rand:2847674 Computer:
         cbDbPage: 4096
           dbtime: 204135343 (0-204135343)
            State: Dirty Shutdown
     Log Required: 1-1
   Streaming File: Yes
         Shadowed: Yes
       Last Objid: 39769
     Scrub Dbtime: 0 (0-0)
       Scrub Date: 00/00/1900 00:00:00
     Repair Count: 0
      Repair Date: 00/00/1900 00:00:00
  Last Consistent: (0x0,0,0)  04/12/2004 11:01:04
      Last Attach: (0x1,9,6C)  04/12/2004 11:12:01
      Last Detach: (0x0,0,0)  00/00/1900 00:00:00
             Dbid: 1
    Log Signature: Create time:04/12/2004 11:11:58 Rand:232032517 Computer:
       OS Version: (5.0.2195 SP 4)

Previous Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Incremental Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current snapshot backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

     cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

Operation completed successfully in 1.52 seconds.

please help and advice me
Hussain
0
 
nepkAuthor Commented:
Microsoft exchange event service also not start during booting though its set to AUTOMATIC but it cam start manually. is there any relation of this service with the abouve errors.

Hussain
0
 
nepkAuthor Commented:
At last I have mount the information store and i can send and receive EMails but I can't see the M drive anymore?

any advice
0
 
kristinawCommented:
You got the store mounted? That's great!

I would recommend doing a backup as soon as possible.

You can't see the M drive?
0
 
nepkAuthor Commented:
yeah i can't see M drive. what do u recommend do I backup offline or online?
0
 
mbrownchicagoCommented:
Okay I was able to follow the instructions here to remount my corrupted database sucessfully. (After discovering that my server did not have virus protection on it, installing it and discovering over 300 quarantined viruses). Thank you very much everyone for helping this person because you helped me as well. I am going to backup everything immediately.
0
 
kristinawCommented:
make sure your virus scanner is not doing a scan on the M: drive. Exclude it. immediately.
0
 
joehdzCommented:
I am in a similar situation where I'm unable to remount my mail store.  I am trying to run the isinteg -fix utility, but I get the same error message as above:
 "Isinteg cannot initiate verification process.
  Please review the log file for more information."
This initially started with an unexpected interruption in power (improper shutdown).

Thanks.
0
 
kristinawCommented:
joe,

this question has been closed, best to post a new one in the Exchange server area.

kris.
0
 
itgrooveCommented:
I had this same behaviour (original error). It turned out, I had forgotten to delete the transaction logfiles so the old logs were still sitting in MDBDATA, despite the databases having been recently repaired via ESEUTIL (i.e. I was trying to kick off the isinteg portion of the process).
http://blog.brainlitter.com/archive/2009/05/30/exchange-database-repair-steps-for-exchange-2003-2007-etc-.aspx 
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

  • 11
  • 6
  • 3
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now