?
Solved

X-window problem

Posted on 2004-04-08
15
Medium Priority
?
704 Views
Last Modified: 2010-04-21
Greetings all,
I am getting the following when trying to run "xhost +localhost"

Xlib: connection to "localhost:1.0" refused by server
Xlib: Client is not authorized to connect to Server
./xhost:  unable to open display "localhost:1.0"

My DISPLAY is set to "localhost:1.0"


I guess I want to make sure that X-Windows is running and I guess I want to be able to remove the localhost and add it back in.

Thanks in advance...
0
Comment
Question by:CompuTurk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +6
15 Comments
 
LVL 11

Expert Comment

by:griessh
ID: 10783562
I'm not sure why you use "localhost:1.0" for your display. localhost is the loopback address for your network card.

To access your local display DISPLAY=:1.0 should be much more appropriate and won't give you the error message.

=====
Werner
0
 
LVL 62

Expert Comment

by:gheist
ID: 10784280
what does
host 127.0.0.1
and
host localhost
say???
0
 
LVL 6

Expert Comment

by:bira
ID: 10786590
"I guess I want to make sure that X-Windows is running "

  ps -ef |grep X


0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 6

Expert Comment

by:bira
ID: 10787557
set as:
export TERM=vt220
export DISPLAY=xxx.xxx.xxx.xxx:0.0

where xxx.xxx.xxx.xxx is your IP.

In the server run:

   xhost +


0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10788158
Are you running the xhost command as the original user (who owns the X session), or as a different user? In the latter case, this is wrong: You need to run the command as the user who owns the X session. Only the owner can allow other users (or users on a different machine) to access the local display.
0
 
LVL 2

Author Comment

by:CompuTurk
ID: 10788311
What has happened is while I was on a terminal session my X server has died and I was able to start it by simply opening a new terminal session and issuing the xhost + localhost command.
0
 
LVL 62

Expert Comment

by:gheist
ID: 10789509
What does xauth list say??? Maybe you have broken some part of authority file or so
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 10789840
> .. I was on a terminal session my X server has died and I was able to start it by simply opening a new terminal ..
what is a "terminal session" for you? a simple login (telnet, rlogin, ssh), or a graphical window (xterm, rxvt, etc.) with a shell, or a console login?

  xhost +localhost
is a useless command in most setups, 'cause the X server is setup to allow connections from itself (except someone has configured otherwise, which is unusal)
0
 
LVL 20

Expert Comment

by:Gns
ID: 10801826
Many relatively recent linux distros have it set so that xhost +localhost would actually be meaningful... In relaxing things a bit:-)... So I wouldn't say it'd be completely useless Achim:-)

But I do agree with all the commenters... I ccan't really get a grip on what your problem is (or isn't:-). Could you try rephrasing, and this time be very clear on what you are trying to do, what incarnation of X this is (if nothing else, at least OS and version) etc?

-- Glenn
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 10802544
no, not completely useless, but iseless in most cases, Glenn ;-)
Also wait for some more clarifiations ...
0
 
LVL 1

Expert Comment

by:sanal
ID: 10892185
What OS are you using ? solaris ? linux ?
I believe you are executing this command on a telnet window.  Please try to using this on the CLI window which is part of the graphics console.  It may not work on a non graphics telnet session.

Alternates:
You may type

xhost +ip address of your box

0
 
LVL 2

Author Comment

by:CompuTurk
ID: 10943400
I was able to resolve this issue.  What has happened is, again, the xterm window I had open lost its connection with X window when it crashed.  So, I launched a new xterm window after restarting X server.

Thanks for your help.
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 10972971
Closed, 125 points refunded.

modulo
Community Support Moderator
Experts Exchange
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
Why Shell Scripting? Shell scripting is a powerful method of accessing UNIX systems and it is very flexible. Shell scripts are required when we want to execute a sequence of commands in Unix flavored operating systems. “Shell” is the command line i…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
Suggested Courses
Course of the Month11 days, 16 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question