Solved

Ultra-Slow DELETE

Posted on 2004-04-08
8
1,589 Views
Last Modified: 2012-06-27
Hi there,

I have a table (MyTable) with the following structure:

dataCol1 int,
dataCol2 int,
dataCol3 tinyint,
datacol4 float

dataCol1 and dataCol2 together are the primary key, no other indices are defined on the table.
dataCol1 is a foreign key to another table, dataCol2 is a foreign key to a different table.
There are approx 18000 rows in this table.
The database in total is a little under 1Gb, but SQL Server should be able to cope with that OK.  There were also no active connections to the DB when I ran the command.

I am running the command DELETE FROM MyTable WHERE dataCol2 = x.  In my case, there should never really be more than 70 being deleted at any one time.  

When there are 70 rows to be deleted, this command (run in Query Analyzer) takes approx. 43 seconds to complete.  That's almost 0.6 seconds per row!!  How can this be, and how can I improve the performance so that it works in a (much) more reasonable time scale?

Thanks,

Malcie.  
0
Comment
Question by:malcolmbegg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 8

Expert Comment

by:william_jwd
ID: 10784562
You can improve the query performance by indexing the column in the where clause (dataCol2).  I dont think that there  is any problem with your query...
0
 
LVL 43

Expert Comment

by:Eugene Z
ID: 10784591
when did you last time did indexes maintenances like reindex (see DBCC INDEXDEFRAG or\and DBCC DBREINDEX); update statistics (see sp_updatestats)?
0
 
LVL 43

Expert Comment

by:Eugene Z
ID: 10784601
BTW: could be not so bad to create nonclustered index on column dataCol2
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 12

Expert Comment

by:monosodiumg
ID: 10787700
Do you have any triggers on the table?
Are there any referential integrity constraints to other tables?
Is your DB reasonably defragmented?

mono
0
 
LVL 7

Expert Comment

by:ChrisFretwell
ID: 10787932
What does the query plan show?
Have you run this with profiler on to see what's really happening?

How fast would a select with the same criteria be?
0
 
LVL 1

Author Comment

by:malcolmbegg
ID: 10789769
Thank you all for your help so far.

william_jwd: I tried setting up a non-clustered index on dataCol2 - this had no real effect.

monosodiumg: There are no triggers defined on the table.  The foreign key relationships I mentioned previously are enforced as relationships within the DB.  How can I tell if the DB is defragmented?  If it isn't how do I sort it out?

ChrisFretwell: Query Execution Plan shows the following (in as much detail as I can squeeze in!):

DELETE (0%) <-- Assert (0%) <-- Nested Loops (0%) <-- Clustered Index Delete (70%)
                                                 ^
                                                  |
                                                  Row Count Spool (0%) <-- Index Scan (30%)

The Clustered Index Delete is taking up the majority of the time (obviously), but should it?  Does this plan look right?

A SELECT using the same criteria is pretty fast (almost instantaneous).

Malcie.
0
 
LVL 2

Accepted Solution

by:
LordSilk earned 250 total points
ID: 10790686
Hi,

Have you checked if there are other tables referencing your table? In other words,are there tables with foreign keys to your table?
If there are, check if the foreign keys are indexed. If they are not indexed, SQL server has to scan that table (in your case) 70 times and if it are big tables that could take some time.

Silk
0
 
LVL 1

Author Comment

by:malcolmbegg
ID: 10791042
Spot-on LordSilk, there was one foreign key to this table (which I hadn't noticed), referencing a fairly big table (approx. 400000 records).  I indexed the foreign keys and hey presto, it now deletes virtually instantly.

Many thanks, and thanks also to all others who contributed - especially monosodiumg.  I realise now you were going along the right tracks with your comment, but I only noticed after LordSilk's solution.

Malcie.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction In my previous article (http://www.experts-exchange.com/Microsoft/Development/MS-SQL-Server/SSIS/A_9150-Loading-XML-Using-SSIS.html) I showed you how the XML Source component can be used to load XML files into a SQL Server database, us…
Slowly Changing Dimension Transformation component in data task flow is very useful for us to manage and control how data changes in SSIS.
Viewers will learn how the fundamental information of how to create a table.
Viewers will learn how to use the SELECT statement in SQL and will be exposed to the many uses the SELECT statement has.

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question