We help IT Professionals succeed at work.

Problem with Tomcat 5.0 work with IIS 6.0 using JK2 apj13

xml_abh
xml_abh asked
on
Medium Priority
425 Views
Last Modified: 2012-05-04
I am trying to get Tomcat 5.0 to work with IIS 6.0 using JK2 ajp13.  This is the following URL I used as a resource. http://virtualict.net/support/kb/iis6-Tomcat5-JK2.html#introduction

When I go to
http://localhost:8080/jsp-examples/index.html  (obviously)
http://localhost/jsp-examples (does not work, I am attaching the workers.properties document at the end of the email

The installation is straight forward. Some relevant information:  
IIS Log:
1. 2004-04-08 15:25:01 127.0.0.1 GET /jakarta/isapi_redirector2.dll - 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322) 500 0 0

the tomcat startup shows the follwowing error
2.Apr 8, 2004 12:53:36 PM org.apache.catalina.core.StandardHostDeployer install
INFO: Installing web application at context path /webdav from URL file:C:\Apache\Tomcat5.0\webapps\webdav
Apr 8, 2004 12:53:36 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on port 8080
Apr 8, 2004 12:53:37 PM org.apache.jk.common.ChannelSocket init
INFO: JK2: ajp13 listening on /0.0.0.0:8009
Apr 8, 2004 12:53:37 PM org.apache.jk.server.JkMain start
INFO: APR not loaded, disabling jni components: java.io.IOException: java.lang.UnsatisfiedLinkError: no jkjni in java.library.path
Apr 8, 2004 12:53:37 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/250  config=C:\Apache\Tomcat5.0\conf\jk2.properties
Apr 8, 2004 12:53:37 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 18140 ms

==> The isapi filter used is isapi_redirector2.dll . This shows the desired green arrow.
==> The workers.properties
[shm:]
info=Shared memory file. Required for multiprocess servers
file=C:\Apache\Tomcat5.0\work\jk2.shm
size=1000000

[channel.socket:localhost:8009]
info=Ajp13 worker, connects to tomcat instance using AJP 1.3 protocol
tomcatId=localhost:8009

[uri:/jsp-examples/*]
info=JSP examples, map requests for all JSP pages to Tomcat.
context=/jsp-examples

[uri:/servlets-examples/*]
info=Servlet examples, map requests for all servlets to Tomcat.
context=/servlets-examples

[logger.file:0]
level=INFO
file=c:/Apache/Tomcat5.0/logs/iis_jk2.log


the jk2.properties file has everything commented out as it suggests that it is not required. Is this that might be missing.

## THIS FILE MAY BE OVERRIDEN AT RUNTIME. MAKE SURE TOMCAT IS STOPED
## WHEN YOU EDIT THE FILE.

## COMMENTS WILL BE _LOST_

## DOCUMENTATION OF THE FORMAT IN JkMain javadoc.

# Set the desired handler list
#handler.list=apr,request,channelJni
#
# Override the default port for the socketChannel
#channelSocket.port=8019
# Default:
 channelUnix.file=C:\Apache\Tomcat5.0\work\jk2.socket
# Just to check if the the config  is working
#shm.file=C:\Apache\Tomcat5.0\work\jk2.shm

# In order to enable jni use any channelJni directive
# channelJni.disabled = 0
# And one of the following directives:
#apr.jniModeSo=/opt/apache2/modules/mod_jk2.so

# If set to inprocess the mod_jk2 will Register natives itself
# This will enable the starting of the Tomcat from mod_jk2
# apr.jniModeSo=inprocess


Thanks
Abhay
Comment
Watch Question

Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Hi,

Answer has been provided already, points has to give....

R.K
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.