Solved

Enable ide-scsi for DVD-writer in SuSE 9.0 Pro

Posted on 2004-04-09
2
487 Views
Last Modified: 2013-12-15
Guys,

Recently replaced an old IDE DVD-ROM with a DVD burner (TDK drive +R -R +RW -RW CD-R CD-RW). when I try to use K3b it says I must enable ide-scsi mode. I have tried both forceing it in the grub.conf with :
ide-cdrom ignore=hdd
hdd=ide-scsi
This doesn't work. I have tried disabling ide-cdrom support, but can't find how to do this...

Any suggestions how I can force hdd to use ide-scsi driver????

Da Proff
0
Comment
Question by:prof666
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 17

Accepted Solution

by:
owensleftfoot earned 250 total points
ID: 10790154
Cut n paste :)




My file /boot/grub/menu.lst file is now installed on the third partition. Creating this file is the tricky part, so for anyone interested, here is what mine looks like:

=======================================================

     default         0
     timeout 30

     title           Bonzai
     root           (hd0,2)
     kernel        /boot/vmlinuz-2.4.20-bf2.4 root=/dev/hda3 ro video=vga16:off hdc=ide-scsi hdd=ide-scsi
     savedefault
     boot

     title           Bonzai - single user mode
     root           (hd0,2)
     kernel        /boot/vmlinuz-2.4.20-bf2.4 root=/dev/hda3 ro video=vga16:off single hdc=ide-scsi hdd=ide-scsi
     boot

     title           Windows on /dev/hda1
     rootnoverify    (hd0,0)
     makeactive
     chainloader +1


=======================================================

You'll note that in the above file I've set up scsi emulation (which is needed for burning CDR(W)s. To get scsi emulation working, there are a couple of other things I must do. First, I edit file /etc/modules and add this line:

     ide-scsi

Next, I edit file /etc/fstab and add a line for my CDRW drive:

/dev/sr1 /cdrom1  iso9660 ro,user,noauto 0 0

Finally, I change the symbolic link for my CDROM:

     root@sonic:~# rm /dev/cdrom
     ln -s /dev/sr0 /dev/cdrom
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10790519
YaST2 should be able to make all these changes for you.

Start YaST2 (either via the SuSE menu, or by running /sbin/yast2 as root user)
Select Hardware in the navigation bar and select CD-Rom Drives in the window on the right.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question