Terminal Services logon problem

Hi

I have a windows 2003 server box in "remote desktop for administration" mode. It has worked fine until very recently where now if I connect to the box via remote desktop, I am asked for my username and password, which I enter, but when I click OK it gets as far as "applying settings", then it says "saving settings", then "logging off", and then the RDP connection is dropped. This is the same for all users including the administrator. Nothing is logged in the event log.

Any ideas?
Tom
LVL 1
tomt84Asked:
Who is Participating?
 
berdtConnect With a Mentor Commented:
I had the same problem, in my case it was caused by the (WHQL!) NVIDIA detonator driver I downloaded from nvidia.com.
Other video drivers might have the same problem.
Uninstall your video driver, reboot and try to connect with RDP again.

The driver I downloaded from windowsupdate.com works fine with RDP sessions.

In my case, nothing was being logged either.

Removing everything related with nvidia from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run and HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run did not solve the problem, so it must be the driver itself.

Very weird, I spend hours to figure this out!

regards,

Berdt van der Lingen
0
 
What90Commented:
See if someone has disabled remote desktop option on the server. Could be that simple ;-)
0
 
tomt84Author Commented:
No it all appears to be switched on in the ts manager.

Cheers for your suggestion, any  other ideas?

0
[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

 
What90Commented:
Check under My Computer - properties - Remote and see if Remote Desktop is ticked.
(Ignore the XP part 2003 is the same):
http://www.microsoft.com/windowsxp/pro/using/howto/gomobile/remotedesktop/enableremote.asp
0
 
tomt84Author Commented:
yup remote desktop is indeed already ticked. Sorry!!
0
 
tomt84Author Commented:
Genius. You're a star. Many thanks!!
0
All Courses

From novice to tech pro — start learning today.