FTP and Telnet on Suse 8.0

Hi,

I have a system running SuSE 8.0, KDE and I am having trouble getting ftp and telnet to work.
When connecting to either service, telnet hostname or ftp hostname both reply with similar comments:
c:\> telnet hostname
<screen clears>
  Connection to host lost

c:\> ftp hostname
=Connected to hostname...
  Connection closed by remote host


- I've run a netstat and services are listenting on the correct ports.
- sftp authenticates and functions properly, but ftp is what  I want to work
- /etc/ftpusers file has root commented out.
- /etc/securetty has pts/0 -- pts/9 entries. These entries allow root access on other systems.

I'm running out of ideas. How do I check to see if a firewall is running? If one is not running, what should I try to do?
jameswaltAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jameswaltAuthor Commented:
Another note,

rpm -qa | grep ftp returns
lukemftp-1.5...
yast2-agent-ftp-2.5.2...
yast2-agent-tftp-2.5.1...


ps -ef | grep ftp returns nothing
ps -ef | grep ftp returns nothing
0
Karl Heinz KremerCommented:
lukemftp is a ftp client, you don't have a server installed. Use YaST2 to add software and select the vsftpd package (I hope that this was part of 8.0 :-) You also need to install the telnet daemon. After you've installed the servers, you need to enable them in /etc/inetd.conf - just remove the '#' in front of the lines that start the vsftpd and telnetd programs..
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Karl Heinz KremerCommented:
The ftpd program would only run when a connection is active. Therefore your ps comand will not list anything. You can however start vsftpd as real daemon that stays active even without an active connection. Wether you want to do this depends on how many ftp connections you expect. For just a modest number of connections, use the inetd (or xinetd) method, if you run a very busy server start vsftpd as daemon.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.