Solved

Trouble with IP address

Posted on 2004-04-09
21
726 Views
Last Modified: 2013-11-09
I am using a Windows XP PC to connect to a Netgear Router/Hub and to broadband. The PC did have a wireless and a 10/100 network cards fitted, but this was causing me problems connecting with the 10/100 card, so I removed the wireless card and reinstalled the 10/100. Everything worked fine until now. The NIC IP address has suddenly changed and is no longer recognised by the router.
My system is set up for the NIC to get an IP address automatically, which is provided by the router.

I have tried to reinstall the NIC but no change. Initially the IP address is 0.0.0.0 but then it changes.

I have tried:
ipconfig /renew but with no luck - times out
repairing connection - no luck - IP address problem.

I can't understand why it was working fine and then suddenly stopping.

Could it be a hardware problem with the NIC or router?

Another PC works fine with the router, and notebook works fine with wireless connection to router.

I thought that I had got my network sorted.
Thanks
0
Comment
Question by:colscream
  • 6
  • 5
  • 3
  • +6
21 Comments
 

Author Comment

by:colscream
ID: 10794383
Have just looked at screen when I do ipconfig /all ; I notice that under Windows IP Configuration is says IP Routing Enabled  ....... No

Is this the correct setting?
0
 
LVL 6

Expert Comment

by:parkerig
ID: 10794508
Hi,
Do a ipconfig /all
If dhcp is enabled then it is normal for addresses to change.
If you can't have the ip address changing then enter it in the IP settings of the network card ( control panel, network connections, highlight card, right mouse click, check all looks ok ( ie enabled etc) then properties.) In goto internet protocol ( tcp/ip) properties and put in ip address ( or check DHCP settings etc)

If you need more assistance please advise

Ian
0
 
LVL 7

Expert Comment

by:Worked4me
ID: 10794551

No it needs to be enabled to do this go to start, run, and type regedit.
Now navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
make sure the IPENABLEROUTING has a REG DWORD Value of 0, just double click on the
entry and make sure the Hexidecimal Value is 0.  If this entry is not at this location then
add it.

Good Luck.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 7

Expert Comment

by:Worked4me
ID: 10794566


Sorry colscream that should be spelled  IPEnableRouter.
0
 
LVL 16

Expert Comment

by:The--Captain
ID: 10794589
>Initially the IP address is 0.0.0.0 but then it changes

What does it change to?

Do any other workstations function properly on this network?

Cheers,
-Jon
0
 
LVL 6

Expert Comment

by:parkerig
ID: 10794662
Hi all,
IP Routing enabled.
This is only required if you have more than one network card / device and need to send IP traffic from one card to the next like a poor mans firewall.
It is not required when only only one connection method is active
eg
Laptop at work has wireless card and nic
Unless I enable bridging I can't have both active so I stop the wireless.
Bottom Line IP Routing only needs to be enabled if sending packets from one device to another that are on different subnets etc.

Cheers
Ian

0
 
LVL 51

Expert Comment

by:Netman66
ID: 10795459
I agree - no need to enable routing.

If you get an all zero IP address it indicates that the IP it is trying to use is already being used on the network.

You'll need to investigate which host is using the same IP you are trying to.
0
 

Expert Comment

by:leork2004
ID: 10795752
hi

read through the comments.I think the problem is with router .is there any other pc does it get an ip address and work fine
.if not then your router is the culprit

0
 
LVL 6

Expert Comment

by:parkerig
ID: 10795840
Back again,
You say "Another PC works fine with the router, and notebook works fine with wireless connection to router" with this in mind, please confirm that other pc works fine with Wireless card (NIC out). If this is fine then NIC in wireless out. What happens ?
I think you are going to find that the NIC has been damaged or device manager is out of "whack" if the above is correct and NIC still isn't working. However having said that before giving up on NIC , turn of PC remove NIC, Reboot, go to the device manager and delete the NIC from the networking components and then check device manager to make sure still not there. Turn off PC and allow hardware wizard to reinstall NIC.
WHY ???? Sometimes the TCP IP stuff justs gets stuffed and this is a quick way to reinstall the TCP / IP stuff.
There is some more info on this somewhere. When I find it I will post URL
0
 
LVL 2

Expert Comment

by:happispider
ID: 10795962
I've seen "DHCP release" and "DHCP renew" used with my router so I agree with leork2004 try renewing on the router
0
 

Author Comment

by:colscream
ID: 10796048
Yes - another PC connects fine to router with NIC (Windows ME).
Notebook with wireless connects fine.

When I connect NIC with XP machine the light on router just continues to flash.

IP address initially is 0.0.0.0 , but can change to 169.254.242.189 (no idea what that is?)

One new thought, I do have ZoneAlarm firewall installed - but have the IP addresses of my netwoek in the 'Trusted Zone. Could that be stopping it?

Connection has worked fine for 2 or 3 days, but then suddenly stopped mid way through using PC.

Thanks
0
 
LVL 6

Expert Comment

by:parkerig
ID: 10796077
Hi,
The above says to me that the NIC isn't getting the DHCP from the DHCP server.
Probably you have blocked a program with zone alarm by accident.
169.254.242.189 is a default some companies use for NIC.
Suggest in first instance disable zone alarm at startup - must be startyp unloading it doesn't always work
Remove all blocked programs etc
reboot
Zone alarm off
start zone alarm - answer questions as they arise
go to dos
ipconfig /renew
answer zone alarm questions as you go.
then go to services restart the running and automatic ones - answer zone alarm as you go
retick load zone alarm at start
All should be sweet
Ian
0
 

Author Comment

by:colscream
ID: 10796179
Hi Ian

I removed Zonealarm from startup, then did complete shutdown. Restarted PC, without Zonealarm running, but still couldn't get connection to router.

IP address initially 0.0.0.0 , changed to 169.254.242.189.

ipconfig /renew just timed out.

Therefore there was no point in restarting Zonealarm as connection won't work wihout firewall.

Tried to ping 0.0.0.0 and 169.254.242.189 but both unsuccessful.

Have checked that XP firewall is off, within LAC Advanced tab.

Any further ideas?
0
 
LVL 7

Expert Comment

by:Worked4me
ID: 10796380

Hey colscream,

  Log into the router and see if you can find the DHCP log.  This should show the
attempts your PC Card was making to get an IP address.  On a D-link router it says
DHCP discover, DHCP lease X.X.X.X, if you have encryption setup it will usually say
Authentication success, Wireless PC connected.  To the right on mine it says
the MAC address of the PC attempting this.  This will narrow down if your router
even sees your Laptop or not.

  If there is encryption setup on the wireless side check the key in the router and
enter this same key again in the Encryption setup on the Laptop.  Sometimes
you think you have it exactly the same and it's something simple like this.


Good Luck.
0
 

Author Comment

by:colscream
ID: 10796479
Have looked in log - can't find anything of use.

The wireless connection is no problem (this only feeds laptop)

Also the 10/100 NIC in my other PC is no problem - the router assigns IP addresses to both machines.

It is just my new XP PC that just doesn't seem able to talk to the router to get an IP. But as I said before, it was working with an IP address obtained.

Router is a Netgear DG824M - that has always worked brilliantly.
0
 
LVL 6

Expert Comment

by:parkerig
ID: 10798340
Ok thanks for trying suggestions and advising us of more info.
Suggest to now

Swap NIC's in both PC's.
This will tell whether NIC or PC.

Did you do the my computer, properties, hardware, device manager and remove the network adapters so TCP / IP would reinstall ? There may also be a clue there.

Microsoft suggests
http://support.microsoft.com/default.aspx?scid=kb;en-us;822123&Product=winxp
But I'm sure we have covered all this.

I assume that the DHCP client service ( control panel, admin stuff, services DHCP client) is running.
TO be on the safe side highlight it and restart - check Event Viewer for details.

Finally, double check NIC site for updated driver. On a couple of occassions I have done MS critical updates and other things have stopped working.

Ian
0
 
LVL 6

Accepted Solution

by:
parkerig earned 250 total points
ID: 10798366
Finally found URL for forcing TCP stack to reinstall
===================================================================
Comment from kabaam
Date: 04/11/2004 08:21AM NZST
reset your tcp stack
http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q299357&

reset winsock
http://members.shaw.ca/techcd/WinsockXPFix.exe

system file checker from command prompt
sfc /scannow

 http://www.experts-exchange.com/Networking/Q_20949892.html
====================================================================
0
 
LVL 11

Expert Comment

by:nazirahmed
ID: 10799570
<<<169.254.242.189 is a default some companies use for NIC>>>
its not an ip which 'companies' use, its default for windows if there is no dhcp is availble or computer cant find one.
http://members.shaw.ca/techcd/WinsockXPFix.exe was the most prefered solution in the very beginning, but anyway its there now, i and i am positive it will help sort out the prob.
0
 

Author Comment

by:colscream
ID: 10800008
I have taken the NIC from the working PC and put it into XP machine. At the moment it works fine. Will see how it goes - last time when I removed the wireless card the PC worked OK for a couple of days and then packed up.
Thanks for help - will get back to you later.
0
 
LVL 2

Expert Comment

by:wmilliga
ID: 10810028
Sounds like you may have a wiring or autonegotiation problem. Was the XP station that worked using the same LAN cable and/or jack? Check your speed & duplex settings. The address that you are getting is assigned by the card itself because you are probably not getting a response from your DHCP server.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

825 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question