getURL does not allow data to be loaded via loadvars

My website uses 3 different swf files embedded in php pages. One is for the header, the next is the body and the third the footer. When I load my index page all the swf's load correctly and data is pulled into the body swf using loadvars and PHP. The problem is this. When you try to load the index page from a link on the header swf the page loads and all looks well except it will not allow the body swf to pull in data from a PHP file. All the data fields just give me undefined. Using the back button to the index page will reload the data and using a link in a normal html page will work.
smearesAsked:
Who is Participating?
 
Computer101Connect With a Mentor Commented:
PAQed, with points refunded (500)

Computer101
E-E Admin
0
 
hansblixCommented:
Are you using frames? If you can, post a link as well so we can have a look..

-H
0
 
smearesAuthor Commented:
Thanks for your help. I found the problem I think. For now anyhow. It seems my header swf was corrupted somehow. I deleted the links in the behaviours window and reinstalled them and all is working well. At my end anyhow.  If you would like to check your end you are most welcome. http://hmd.com.au   If it is working prices will be listed. If not then all the price fields will say undefined.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.