Solved

Setting up server

Posted on 2004-04-11
4
430 Views
Last Modified: 2010-03-04
Hello


Im trying to setup a webserver at home.
I have read an online tutorial found at:
http://thewishs.com/Web_Work/Dynamic_IPs/.
Its good for newbies such as myself, but does not cover everything.

My problem is that I cant get it to work.
What have I done so far?


My ISP uses static IP, therefore I use Zoneedit.com.
They gave me two nameservers which I should
login and enter at for example goddaddy.com (or whereever the domain namne was bought)
I have done that more than 72 hours ago.

Then, still at zoneedit.com, I set my IP for that domain.
That will be the IP that www.whatismyip.com is showing me (external)

The thing is, that im using a D-link DI-604 to share the ADSL connection with
altogheter three computers. (One webserver)
When I view the settings for my router I can see that all three connected PCs
have their own IP number. Do they (IP) only exist in my "network"?


My server computer is running winXP and as webserver I use Apache.
In Apache I have set port 80 (default).
When I try localhost in the browser I get my test page working
(Classic "Hello world"). So, I guess the server is running!

In the router setting I have opened port 80 for incoming traffic.
I know that there is a lot of steps involved here, but any tip
is welcome.
There are three Pcs connected to the router and I have set the IP.
That is the external IP. From here, how do I "find" my server, which the router has
given another IP for?

By the way, I have searched for some tutorial which covers this. (without success)
Do you know any good tutorial which covers this at a newbie level, please post a link.


Im sorry for the low level question, but the only way to learn is to
deal with it, right???

Thanks / Martin




0
Comment
Question by:martinsmith34
  • 2
4 Comments
 
LVL 1

Expert Comment

by:uecasm
ID: 10804248
You will probably need to do two things (both in your router configuration) to get this to work:

  1. Make your router always give your server computer the same IP address, rather than dynamically assigning it.  This should be in either your DNS or DHCP settings on the router.

  2. Set up a NAPT/NAT entry in your router linking external IP 0.0.0.0 (or whatever your router uses to represent the standard external IP) port 80 to internal port 80 on your server's IP.
0
 
LVL 2

Accepted Solution

by:
tcmv earned 20 total points
ID: 10810168
The feature you should be looking for in your router is called port forwarding ... meaning any incoming traffic on port 80 gets forwarded to a specific internal IP address.  And you need to set your  windows xp machine to NOT use dhcp.  Take the router out of the loop altogether for that.  Specifiy your IP address, gateway, subnet mask, and DNS server entries in the control panel -> network connections ...  Whatever you specify that address to be, make that the same IP address that port 80 is forwarded to.  The DLink router probably has a simple web interface for setting that up.

Hope that helps...
-tcmv
www.mvix.net
0
 
LVL 1

Expert Comment

by:uecasm
ID: 10812284
That's one way to do it.  Or you can just reconfigure the DHCP on the router as I previously suggested.  Set up a permanent client assignment for your server computer, and that way it'll always be assigned the same IP.  The exact method for this varies.  On my router you just go to the DHCP configuration page, copy the client ID (the MAC address, long series of hex bytes), then create a new entry in the preassigned group and put in that same ID.  Then just give it a really long lease time and you're set (for some routers, leave the lease time blank).

Port forwarding is just another name for NAT/NAPT.

Just do whichever approach seems easiest to you; they both should work.
0
 

Author Comment

by:martinsmith34
ID: 10817361
I hope you are not too much in it for the points.
Not even 7 per person. (I will give it by random)


However, I have spent hours to make this work. (By now, not a newbie any more???)
Yes, port forwarding is what im looking for.
At first it didnt help much.
I called my ISP and I called D-Link support.
The D-Link guy told me to turn off the built in firewall in XP.
Like magic, I have my very own webserver waiting for its first attack.

Hmmm, I didnt now that the built in firewall was enabeld by default.
Now I know........................


If you live in the northern hemisphere, it will soon be summer.
Have a great one, and thanks for the effort....


CIAO



0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

As Wikipedia explains 'robots.txt' as -- the robot exclusion standard, also known as the Robots Exclusion Protocol or robots.txt protocol, is a convention to prevent cooperating web spiders and other web robots from accessing all or part of a websit…
If your site has a few sections that need to be secure when data is transmitted between the server and local computer, such as a /order/ section for ordering or /customer/ which contains customer data, etc it would of course be recommended to secure…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now