Solved

San Disk USB Mini-Drive not Recognized by XP

Posted on 2004-04-11
52
376,658 Views
Last Modified: 2013-11-15
My San Disk USB mini-drive powers up, was seen as new hardware by XP which prompted me to allow it to install. However, the San Disk is not in Device Manager or Windows Explorer. I have tried allowing XP to find the drive on boot up or by inserting drive into USB port. The USB port works...I have confirmned that.
0
Comment
Question by:ddrummer
52 Comments
 
LVL 22

Expert Comment

by:dovidmichel
ID: 10801023
Did you install the SanDisk driver for it?
0
 
LVL 13

Expert Comment

by:oldgreyguy
ID: 10801483
0
 
LVL 4

Expert Comment

by:freshair
ID: 10801723
for XP this drive shouldn't need a vendor-specific driver. remove the drive and replug it into your USB port. would that prompt for installation? if it does, then your drive might work after reinstall. if it doesn't, that might mean your driver or system resource allocation have problem. go to device manager and see if you have a conflict (a yellow diamond with black exclamation mark in it) under "Universal Serial Ports".
0
 

Author Comment

by:ddrummer
ID: 10802216
Thanks for responses. FYI I am using the San Disk Cruzer Mini 128. It does not need driver when using XP. Checked Device Manager. There is no conflict under Universal Serial Port. When I reinsert San Disk into USB port it lights up (powers up) but still not recognized by Device Manager or Windows Explorer. I have partitioned my hard drive C through L and assigned drive letter T to my Cd-Rom drive. There should be a drive letter available???
0
 
LVL 1

Expert Comment

by:tanghz
ID: 10806089
I presume that is the individual problem. You's better look for the factory's web site to seek help.
Some small brands fail to meet the proper PnP standard therefore, you may need special Driver to make it up
good luck
0
 
LVL 1

Expert Comment

by:tifosiv122
ID: 10806174
Your HD is:

C, D, E, F, G, H, I, J, K, & L?

And your CD is T?

Whats on M, N, O, P, Q, R, & S?

This might sound dumb but insert the USB device and double click on every drive. I have one USB device that replaces my CD Rom Letter...so D becomes my Pen even if the icon still looks like a CD drive...it's worth a try, it might be working and you didn't even know it.

Thanks,
Erik
0
 
LVL 6

Expert Comment

by:Francois_IT
ID: 10808098
just to be sure... when the San disc is pluged, do you insert a memory stick in the drive?
0
 
LVL 1

Expert Comment

by:tifosiv122
ID: 10808173
Francois - A sandisk Mini Cruiser is the memory it doesn't take additional memory.

Erik
0
 

Expert Comment

by:Thanatos22
ID: 10809418
do you get the green arrow like thing in the taskbar (on the right) and if so I would click on it to confirm that it see a mass storage device...if not I would say that the flash drive is hosed.....
0
 

Author Comment

by:ddrummer
ID: 10809508
Drive letters M through S and U through Z are available. The installation did not create a green icon in the taskbar, nor was any drive letter assigned in Windows Explorer or a device shown in Device Manager. The San Disk powers up so it may be working, the XP system just can't seem to find it. USB also works. Is there a way to do a manual install of the San Disk?
0
 
LVL 1

Expert Comment

by:tifosiv122
ID: 10810031
Did you check each assigned drive letter to see if it infact was the sandisk? I know one of mine appears to be a CD drive but is actually the sandisk. Also, the green icon doesnt always show with removable media.

Erik
0
 

Expert Comment

by:phiz314159
ID: 10810493
I have a cruzer mini 256 and a new XP pro box and I have the same problem.  At first XP recognizes the drive and then all of a sudden it simply disappears.  No sign of it in the device manager and no sign of it in disk management.  Also no sign of any problem with the USB root.  The only thing remotely helpful on the sandisk website is this link: http://www.sandisk.com/tech/faq/223.html, but it isn't much help at all.  What is really strange is that the drive works perfectly fine on both my XP pro laptop and my win2k desktop.  Any other suggestions?
0
 

Author Comment

by:ddrummer
ID: 10813847
phiz314159: You have described that exact problem... including how XP initially recognizes new hardware and then it seems to disappear. A friend tried the same mini 128 on his XP system and it worked which is consistent with what you have experiened. Why do you say that the fix described in the San Disk FAQ isn't helpful? Did you try it? Thanks.
0
 
LVL 2

Expert Comment

by:beaker67
ID: 10815340
Here's a couple things to try...

I know it has been suggested to click on every drive letter listed in My Computer, but something else to try would be to go to the Address bar and manually type any drive letter that ISN'T listed (A:\, B:\, etc.). I have a PNY Attache USB drive and it sometimes isn't listed in My Computer but it IS recognized when type in the drive letter myself. Also, sometimes you have to force Windows to see the drive - go into Device Manager, right-click on any device or category (doesn't matter) and click "Scan for hardware changes." This will usually cause the drive to be listed.
0
 
LVL 4

Expert Comment

by:freshair
ID: 10816312
it sounds very much like there's problem with the hardware or firmware, especially with the USB data wires (of your PC USB port or the flash drive's USB port) or the built-in controller chip of the flash drive.

did you try any other device on the same USB port? did that device work? if your USB port has no problem but your flash drive doesn't work, the problem lies on either your flash drive or your OS.

did you try it on another XP PC system? did it work on that PC? if it doesn't work on another PC at all, then definitely return it. your drive is defective. if it does, then the problem lies on your OS and its compatibility with the flash drive's firmware. get a driver update from Microsoft and/or install the SanDisk driver. if it still doesn't work after driver update, try to use the XP troubleshooter to see if that can fix the problem. if it still doesn't work after all the above attempts, probably you need to return it for an RMA, since there aren't that many USB flash drives that possess quirky behavior under XP like this.

hope this helps.
0
 

Author Comment

by:ddrummer
ID: 10818883
USB ports work fine. 128 Cruzer works on another (friend's) XP system. there are no drivers needed for this device if you have XP system... see phiz314159 above. he has identical problem...
0
 
LVL 4

Expert Comment

by:freshair
ID: 10819436
if the problem has to do with the unstability of XP then you can probably fix it the way as said by his link. my USB CD drive letter also occasionally disappeared from my computer and device manager in the same way, but after I uninstalled all the USB mass storage devices and rebooted, I saw that new hardware found message when I plug a USB drive in. of course I removed all drivers, including the root hub, and had to reinstall everything. since it is USB I don't find a problem with re-installation. personally I don't touch the registry because I don't have the OS disk or recovery console.
0
 

Expert Comment

by:phiz314159
ID: 10820394
ddrummer: I didn't find the SanDisk FAQ tip helpful because they suggested a registry edit (which I'm never that comfortable with), their instructions were a little vauge and quite frankly, I was hoping someone else would try it first. :)  Besides, it doesn't seem like the right answer.

Thanks for eveyone's suggestions.  To sum up:
 - Cruzer mini is not broken: it works on other XP machines
 - USB ports are not broken: other devices work in them; there are no conflicts in the device manager
 - There are NO drivers for this USB device for XP
 - XP DOES recognize the device: XP sees it and then immediately removes it from the drive listings (I've inserted it while watching the device manager and I see it appear and then disappear).
 - There are no messages in the event log.

Questions that no one has answered:
 - Is there a way to do a manual install of the San Disk cruzer mini?
 - Is there a firmware upgrade for the cruzer mini (although I don't know how you'd update it if you can't see it)?
 - Is there an XP patch for USB 2.0 ports? Yes there is: KB822603, but it didn't help. Are there any others?
 - Why does it work on some XP machines and not others? (ddrummer: the machine that the cruzer mini does not work on is XP Pro with SP1a. Is that the same version of XP as yours?)
 - Is there a BIOS setting? I couldn't find one.

Today I tried reformatting the cruzer mini on another XP machine and when I plugged it into the problem machine, it recognized the drive and it stayed recognized.  I was able to read a file off of the drive, I was able to copy a file from the drive to my desktop, but when I tried to copy a file to the cruzer mini, the drive simply disappeared (and a copying error appeared).  Now XP is back to only recognizing the drive for a split second and then dropping it.

I may have to resort to the registry edit after all...
0
 
LVL 4

Expert Comment

by:freshair
ID: 10827582
it looks to me that the USB port senses the hardware when it was just plugged into the port and notifies the OS there's new device plugged in, and then shortly after that the data signals from the hardware port gets either dropped or misinterpreted by your OS, which makes the system thinks your device has been lost, while in reality it is still there. in my opinion it has more to do with the signaling and/or signal interpretation than pure OS issue. it can be a result of badly installed OS, bad signaling/bad device firmware, or both. I returned my drive for an RMA and the new one had never been problemic with my system. but I can't be sure if that could fix your problem. did you try other devices on the same port? did they all work? if all works but your flash drive, it's highly likely that your portable device is defective.
0
 
LVL 4

Expert Comment

by:freshair
ID: 10827637
as for firmware update I don't think they would offer one yet, and there's no need to. my suggestion is to return it for an RMA. if the warranty has expired it's quite likely your device already started to fail and should be replaced by a new one.
0
 

Author Comment

by:ddrummer
ID: 10829557
My OS is XP SP1a.  phiz314159 has correctly identified the issues. It may have to do with problem between San Disk install insructions and XP SP1a.
0
 
LVL 1

Expert Comment

by:tanghz
ID: 10829600
Hi Guys,

what i want to say again is that is a driver and XP device API's problem. They got some sort of mis-understanding from each other.
http://www.sandisk.com/tech/faq/223.html stated the last chance to walk around this problem, please bear in mind, when u install the driver software, don's plug in the USB device except that it is requested. Some USB devices driver has conflicts to WinXP auto-detect program. So, normally install the driver forst, then plug in the device, then follow the installation wizard to get job done. If you didn't do it this way, you got to uninstall all the pieces including the registry key value as that web site instructed. BUT DO A BACKUP OF THAT FILE.  THAT IS THE SPINAL OF THE WINDOWS.
If that is not working, better ask the factory for a solution.
If other USB devices works fine, then don't try to play with USB either the hardware or the software. It will get things worse .
0
 

Expert Comment

by:phiz314159
ID: 10830465
Well I bit the bullet and attempted to perform the registry edit.

The way this project is going it should come as no suprise that none of the registry settings SanDisk suggested I remove were in my registry.

I've sent an email to SanDisk 2 days ago and I haven't heard anything.
0
 
LVL 4

Expert Comment

by:freshair
ID: 10836863
uninstall the USB root hub and reinstall it would help, but one out of 20 - 30 cases this quirk might still repeat. I got my drive replaced, nothing happened any further. but if you're serious about fixing the XP API, my suggestion is to reinstall XP. the API problem comes from not just the registry (which is only a database) and scattered all around the system folders and hidden files. some people said deleting some of the DLLs and some other files would help (I'd look up the file list if you want to), but that's pretty much an overkill comparing to reinstallation.
0
 

Accepted Solution

by:
yldsky earned 250 total points
ID: 11045189
I guess I have the solution here. Go to Control Panel-->Administrative tools-->Computer Management-->Disk Management, then change the your Removable Disk (on the right bottom of the dialog window, just right click it to change) to another drive letter so it wouldn't conflict with the existing ones. That should do it.
0
 

Expert Comment

by:PaulWoll
ID: 11055754
yldsky, that is very similar to what I did.  I had this same problem and found out that XP thought my sandisk drive should be G, when that was my network drive.  I used the disk management and removable disk to remap the file to an available drive and that worked for me as well.
Not sure if this is an XP or a Cruzer bug.
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 
LVL 1

Expert Comment

by:somanywindowsquestion
ID: 11294424
If you have mapped network drive letters:

Try freeing up the 1st available drive letter after your 1st physical drive letters.  (I.E. your CD-Rom is E: and your 1st mapped network drive letter is F:, remove the mapping from F:)

USB Drives typically have problems with mapped network drive letters.  Also, not familiar with your device, but power can be an issue.  If you have not already done so, try plugging into an onboard port as opposed to an external hub, docking station, etc.  Also, front mounted USB port (on deskop machines) tend to be spec'd for low power devices, so try a rear port.  This is not common with flash storage, very common with USB hard drives, CD-Rom's etc.

Whatever the device is, pay close attention to the drive activity LED when you plug it in.  Typically, the LED will flash a couple times while the drive is initailizing, then turn off / remain on color / etc.  See if the LED is exhibiting the same behavior in this computer as it does in another computer where the drive is working correctly, and this might provide some insight.
0
 

Expert Comment

by:ChrisTHall
ID: 11502379
I tried the drive letter thing in computer management...but when I rebooted it and plugged it back in...it lost the setting and went back to trying to be a mapped drive letter.
0
 

Expert Comment

by:Hook74
ID: 11602786
Thanks to "somanywindowsquestions" I got mine SanDisk cruzer mini 256 to work by placing it into onboard USB ports and now Windows XP Pro recognizes it correctly.
When I first tried to use it in front USB ports I had the same problem as "ddrummer".


0
 
LVL 1

Expert Comment

by:shorteng
ID: 11729767
See this MS Knowledge Base Article: http://support.microsoft.com/?kbid=297694

Mapped network drives will mess up removable media devices, if they use the next available letter after your fixed drive letters. Sadly, no workaround other than going to disk manager and changing the letter as someone stated above.

That is not a viable solution on a network though, where users do not have the rights to open Disk manager.

A sloppy solution that somewhat works in that case:
Go to My Computer. Right-click the lowest-lettered mapped drive, and disconnect it. It will still show up, but will say "disconnected network drive". Double-click it, and it will open to your removable media. This works on our corporate network, but then the user cannot get to their network share until they logoff and log back on so the logon script can re-map their network drive (I feel it is best to not tell the users to wander around in Network places trying to map their own drives...)

The only real solution is to change the network drive mapping to a higher letter. It has been E: on our network for many years, and is turning into quite a project to change that without causing too many headaches (personal folder mappings, developed applications, etc.. refer to the network drive letter).
0
 
LVL 1

Expert Comment

by:jmeree
ID: 11767955
I had a similar problem.  I was able to see the device under Control Panel/System/Device Manager/Disk drives/SanDisk...  I uninstalled the device, stopped the USB device on the "Safely Remove Hardware" taskbar icon and removed the device.  Then I inserted the device and it showed up with a drive letter in Explorer.
0
 

Expert Comment

by:vlahomt
ID: 11874193
I had also been fighting the same problem thanks yldsky for the easiest way to fix the problem.  
0
 
LVL 1

Expert Comment

by:clicker666
ID: 11893853
I had the same issue with a batch of new notebooks with built in readers.  They are Windows XP Pro machines on a Windows NT network, and have a number of mapped drive letters, starting with F:  The letters A, C, D and E were already taken, and it appeared that the card wasn't doing anything.  So I disconnected all the network drives and reinserted the card.  Hmmm... it was on drive F:.  Looking around I couldn't find any "obvious" way to change the drive letter.  I reactivated the user's login script and then reinserted the card.  I heard the little beep indicating a USB connection, but the drive letters remained unchanged.  I then double clicked on F:, which still *appeared* to be a network drive, and saw the contents of the card.  So it appears that the card wants a specific drive letter, doesn't change the appearance of the mapped drive, but actually can be explored.

Hope this helps!
0
 

Expert Comment

by:ajkl7476
ID: 12018965
Thank you yldsky and shorteng!!
I had the same problem and following your steps fixed it~
My removable drive is working perfectly now.
0
 

Expert Comment

by:seidenh
ID: 12440948
I also have the problem that phiz314159 so aptly summarized.
I have only drive A (floppy), C, and D (CD drive)
I tried the solution proposed by yldsky and accepted by ddrummer. but I did not see any drive letters to change besides the ones mentioned above.
My path was Control Panel/Aministrative Tools/Computer Management/Storage/Removable Storage/Disk Mangement.
I also tried the Sandisk suggestion of changing regedit, but no luck.
I have an HP N5425 notebook running XP Pro.
Did  phiz314159 accept an answer?

0
 

Expert Comment

by:seidenh
ID: 12450022
I fixed my problem myself.
The trick was to uninstall the USB Host Controller and restarting with the Cruzer connected.
Also erase some MutiLINX files if you use XILINX.
For details, search Google Groups comp.* for USB XP "unknown device"
and read the first 2 entries.
It applies to all USB self-installing devices.
0
 

Expert Comment

by:rjmawson
ID: 12530376
I am having the same problem except the cruzer doesnt work at all the frount USBs, and comes up as not recognized in the rear USBs. I took it into a store and a brand new laptop couldn't recognize it but an old Win 98 machine could read it fine .... this seems highly odd and the wierder thing is that since I tried to use it, my Logitech Wingman game pad is now not recognized (it used to work fine!!!!!).... where do I go from here???!!!
0
 

Expert Comment

by:vishalvashisht
ID: 12654666
I have had the same problem with XP. Seems that it wants to use the E drive to map anything.

The only fix that I can come up with is to unmap the E drive and let the USB device, whether it is a camera or USB key, use pick up the E letter as it's mapping.

Not sure if MS have come up with a fix but we get the same problem with SP1 and SP2. Have tested by using a usb device, making sure it works, then mapping the E drive and reattaching the USB device, which then doesnt work. Annoying but what can you do? : )

0
 

Expert Comment

by:thewizardofahhs
ID: 13169528
If the symptoms are, that device manager reports USB MASS Storage Device is installed and working properly, but the drive does not appear in my computer, or is erratic in Disk Management, I have a solution, but it is somewhat extreme.

I have seen several computers that exhibit these symptoms.  It is sort of like PNP is not working 100% correctly.  Some of these machines had reinstallations of XP that were not completed successfully; others were NEW, right out of the box.

The solution is to run sysprep.
Make sure that you have the sysprep for the exact version (OEM or retail)
Backup the documents and settings folders.
Extract the deploy.cab from the original CD and copy the files to C:\sysprep.
Run sysprep
Select  Do not regenerate SID’s
After resealing or rebooting, you will need to reenter your CD Key.
Your desktop may be different.
You can restore the documents and settings from the backup.

Now that USB Drive will work correctly.
I’m not sure why, but evidently it fixes certain registry keys that cause the original problem.  I will need to do a bit more research on this one to find a less drastic solution.



0
 

Expert Comment

by:alex-is
ID: 13266177
Had the same problem.. worked on some machines but not mine main one

turns out USB is not providing enough power.  I ended purchasing Adaptec USB controller card for about $25.. Works like a charm
0
 

Expert Comment

by:ajkl7476
ID: 13267124
I'm back.  Now I bought a new USB drive (Lexar Jump Drive Secure)  I've got it to read the public drive/partition, but now it won't acknowledge the secured partition.  It works on my home pc (XP) but I can't get it to work on my work pc (also XP). I tried to reassign the letter as I did w/ the public drive but it doesn't give me the option - greyed out.  Any guesses?
0
 

Expert Comment

by:Darkroyal
ID: 14111580
After reading all the comments I am not sure any answers really exist. Here is my problem. I have two Lexar USB Jump Drives, one a 128 meg, the other an 256 meg. They both work fine in all ports but the two front ports. They are usb 2.0. I have used them in the front ports of other XP computers (at work) and they work fine. I have a PNY 64 meg USB 1.1 drive that works fine in the front ports! I don't get it. I wonder if the wiring for the ports to motherboard are wrong or what. Also, there is one extra black wire on the front USB cables that I can't figure out. All the pins are full so I don't know where they go. Any ideas or help would be appreciated.
0
 

Expert Comment

by:wmcelhan
ID: 14127558

From a setupapi.log in WINDIR directory C:\WINDOWS in the case, I found the following concerning some issues I had with windows properly setting up my USB drives.  I'm presently playing aroud with the text file C:\WINDOWS\inf\disk.inf, concerning the problem, and having some fun.

I'll let you know what I find out.  


#I060 Set selected driver.
#-019 Searching for hardware ID(s): usbstor\disksandisk_cruzer_micro____2033,usbstor\disksandisk_cruzer_micro____,usbstor\disksandisk_,usbstor\sandisk_cruzer_micro____2,sandisk_cruzer_micro____2,usbstor\gendisk,gendisk
#-018 Searching for compatible ID(s): usbstor\disk,usbstor\raw
#I022 Found "GenDisk" in C:\WINDOWS\inf\disk.inf; Device: "Disk drive"; Driver: "Disk drive"; Provider: "Microsoft"; Mfg: "(Standard disk drives)"; Section name: "disk_install".
#I023 Actual install section: [disk_install.NT]. Rank: 0x00000006. Effective driver date: 07/01/2001.
#-166 Device install function: DIF_SELECTBESTCOMPATDRV.
#I063 Selected driver installs from section [disk_install] in "c:\windows\inf\disk.inf".
#I320 Class GUID of device remains: {4D36E967-E325-11CE-BFC1-08002BE10318}.
#I060 Set selected driver.
#I058 Selected best compatible driver.
#-166 Device install function: DIF_SELECTBESTCOMPATDRV.
#I063 Selected driver installs from section [disk_install] in "c:\windows\inf\disk.inf".
#I320 Class GUID of device remains: {4D36E967-E325-11CE-BFC1-08002BE10318}.
#I060 Set selected driver.
#I058 Selected best compatible driver.
#-124 Doing copy-only install of "USBSTOR\DISK&VEN_SANDISK&PROD_CRUZER_MICRO&REV_2033\8&1B30A40A&0".
#-166 Device install function: DIF_REGISTER_COINSTALLERS.
#I056 Coinstallers registered.
#-166 Device install function: DIF_INSTALLINTERFACES.
#-011 Installing section [disk_install.NT.Interfaces] from "c:\windows\inf\disk.inf".
#I054 Interfaces installed.
#-166 Device install function: DIF_INSTALLDEVICE.
#I123 Doing full install of "USBSTOR\DISK&VEN_SANDISK&PROD_CRUZER_MICRO&REV_2033\8&1B30A40A&0".
#-035 Processing service Add/Delete section [disk_install.NT.Services].
#E263 Filter Service: Failed to open service "??Ÿ      ??". Error 1060: The specified service does not exist as an installed service.
#E275 Error while installing services. Error 1060: The specified service does not exist as an installed service.
#E122 Device install failed. Error 1060: The specified service does not exist as an installed service.
#E154 Class installer failed. Error 1060: The specified service does not exist as an installed service.
#I060 Set selected driver.
#I125 Installing NULL driver for "USBSTOR\DISK&VEN_SANDISK&PROD_CRUZER_MICRO&REV_2033\8&1B30A40A&0".
#I121 Device install of "USBSTOR\DISK&VEN_SANDISK&PROD_CRUZER_MICRO&REV_2033\8&1B30A40A&0" finished successfully.
[2005/06/01 22:11:25 2784.312]
0
 

Expert Comment

by:Flamebutt
ID: 14160469
My San Disk cruzer was working fine up to a couple of weeks ago. I would plug it in as normal but it failed to show up in the windows explorer.
After pulling what little hair I have left trying uninstalling and then reinstalling (4 of 5 times) I finally figured out where my drive had gone.
Windows was listing my drive in the control panel under Portable Media Devices !!. What a pain in the ass. It takes ages copying or deleting
anything on the drive and I cannot run or read anything direct from the drive (so much for the Cruzerlock 2 software).
How do I get Windows to list the drive as normal? Is it a WMP 10 issue?
p.s the same thing happens with my 1GB i-stick.
0
 

Expert Comment

by:spirefm
ID: 14515572
My computer has 6 USB ports, all on the motherboard, but Device Driver only shows 5 (XP). All 6 work, except with a camera. Why?
0
 

Expert Comment

by:dferronjr
ID: 14533595
I too am having a problem with my Sandisk Cruzer. Can see it in Device Manager and in My Computer/Portable Media, but not in Windows Explorer or My Computer. The device is readable in software. Sandisk seems to have no answers, today. I know that there is one, because I had the problem a few months ago and it was corrected via a Registry edit. Trouble is I didn't save it :((  Assigning different drive letters did not work, uninstall/reinstall/update USB drivers did not work, change from front to rear ports - nope, unplug all but KB/mouse - nope. If it is an API problem, can that be reinstalled/updated?
0
 

Expert Comment

by:dferron
ID: 14616454
Found a great program from Microsoft Download that recognizes those USB Flash Media devices - Microsoft USB Flash Drive Manager (Standard) - that do not show in Windows Explorer. I tried it and it works. I have not tried all the functions, but you are able to explorer the drive just like you were in Windows Explorer. You even have the right mouse functions!


http://www.microsoft.com/downloads/search.aspx?displaylang=en&categoryid=1

Microsoft USB Flash Drive Manager (Standard)
0
 

Expert Comment

by:lgamtech
ID: 14899744
I had exactly the same problem with my Attache 1Gb. Recognized on my XP Pro laptop, but not on my main workstation. Following instructions above, I opened computer management on the workstation and found the UDISK 20X listing in drive management. The simple act of doing that apparently allowed the workstation to identify it and it now shows in Explorer.
0
 

Expert Comment

by:greensword
ID: 15113535
Hello guys,

My colleague got the same problem. I tried disk management, removed some drive and assign a new drive letter to the USB memstick and it now works.
0
 

Expert Comment

by:lgamtech
ID: 15115724
This is pretty much what I've had to do. There doesn't seem to be a permanent fix for it, but simply the act of going into disk management each time I plug in the disk and highlighting the drive (which always appears there even if it doesn't in Explorer) makes the system "find" the drive and display it in Explorer. Thanks! -sd
0
 

Expert Comment

by:kcurnut
ID: 21575121
We have seen this issue arise quite often in our environment.  Because these USB drives come with the U3 software, these devices need to adjacent drive letters to be open to be readable.

We would assign their USB to a different drive letter to be able to access it.  But this only works for that unique USB device.  Same brand USB flash drives will not take the same drive letter.

Our work-around that has helped, was to assign our CD/ROM drive to the Z: drive letter (Right-Click My Computer\Manage\Storage\Disk Management\Right-Click on specified drive to Change the letter).  Thereby leaving D: & E: open for our USB flash drive & its U3 software.  This way, any Flash drive does not need to be assigned - assuming only one Flash drive is plugged in at a time.
0
 

Expert Comment

by:jeapen
ID: 22314032
Whats happening here is that the SAN Disk has assumed an existing drive letter.  For instance, in our environment we already have dirve letter F assigned to our Storage Drives, but often SAN Disk also get assigned the F drive.  So all we have to do is manually thru, My Computer, Manage, Disk Manager go to the F drive and assign it a different drive letter.  For instance, if I were to assign it Drive Letter "S" the SAN Disk will now be my S Drive and the F drive will be whatever it was prior to SAN Disk attachment.  Let me know if this works.  
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Workplace bullying has increased with the use of email and social media. Retain evidence of this with email archiving to protect your employees.
VM backup deduplication is a method of reducing the amount of storage space needed to save VM backups. In most organizations, VMs contain many duplicate copies of data, such as VMs deployed from the same template, VMs with the same OS, or VMs that h…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now