Solved

Tweakui133 will not install

Posted on 2004-04-11
17
395 Views
Last Modified: 2013-12-29
This is a new question, however it has roots in my previous query dated 4/8/04, Title 'Un-Removable Desk-top icon'  Question ID(?); Operating_Systems/Win 98/Q_20947909.html#1079572
Solved by BillDL. After downloading tweakui133 and Winzip I was successful in getting rid of the un-wanted icon following the procedure layed out by BillDL.

 Some time later I attempted to wander around in Tweak to learn more about its capabilties. A box popped up informing me that the file was 'corrupted', etc. and suggested I download it again. I uninstalled Tweak and went for a fresh download,when that was complete  I attempted to unzip by means of Winzip... I was now informed that the file was 'truncated' etc

Another download and this time I let Tweak self-extract which appeared to work until I got to the point of installing the tweak icon  in the Control Panel. Rt/click tweakui.inf> install. This brought up a box: "Insert Disk, The disk labeled 'Tweakui' is now required. etc. Click OK to continue." Having no disk I clicked 'Details"...."Path not found (error number 3)"  It seemed to be looking for tweakui.cnt which was right there.

Another uninstall, download, attempt to unzip, as a matter of fact I have done this routine seven or eight times, some ending quickly with Winzip messages 'This file is truncated, download again', or 'This file is damaged or has been changed etc.

I have tried with Winzip and without Winzip the only difference being different error messages at different points during the process. The uninstall procedure layed out in Tweak Help didn't work. After the uninstall is performed the tweak.exe icon is still on the desk-top. and the four tweak files (.cnt, .cpl, .hlp, .inf) are still wherever I had placed them (desktop or C:\Windows\Temp)
Re-boot ...still there. It was then;  Find> Files and Folders> Named > Tweak and delete them from there. On several occassions when I had placed them at;  C:\Windows\Temp they end up in C;\Windows\Temporary Internet Files\Content.IE5\Wlchapyp or K5mjizy9.

What kind of jack-pot have I gotten into now?

Harshale


   
 
0
Comment
Question by:harshale
  • 10
  • 6
17 Comments
 
LVL 2

Expert Comment

by:getajob20
Comment Utility
Hi harshale,

Simply click browse in the error dialog and point to the folder it is installing from. This will rectify the error.

Matt
0
 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

You have to righ-click the file tweakui.inf and select install.

And that's it. Check your control panel and you will find it there. Double click and use!!

Enjoy.

Zee
0
 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

You can use this link:

http://ftp.pcworld.com/pub/new/utilities/system_resources_tune_up/tweakui133.exe

Extract as suggested to C:\Windows\Temp, navigate to C:\Windows\Temp, locate tweakui.inf and proceed as suggested above.

Zee
0
 

Author Comment

by:harshale
Comment Utility
Good day Matt and Zee

1st attempt; Winzip=uninstalled.     Rt/click the download link> Target as:
'Desk-top'.... Download complete... Lft/click> unzip to 'C:\Windows\Temp'.

In 'Temp'  I find 4 tweakui files, extns .cnt, .cpl, .hlp, .inf.  NO .GID   I mention the lack of .GID because one of my earlier downloads included a
.GID extension. Next; Rt/click the .inf file> click 'install'. Result; Two panels;
Panel 1= "Windows 98 Setup", 3 lines; First 'Importing old tweakui settings'
Second;  'Introducing Tweakui', Third; System Configuration.

The first line; ' Importing Old etc'. was bold-faced for a split second and then the bold-face moved to the second line 'Introducing Tweakui' and the second panel 'Tweakui' was popped in, essentially the 'Help and How To' file. The bold-face  never did progress to line 3; ' Configuring System'.

I let that stuff run or do whatever it was or wasn't doing. After a long wait I closed the 'How To...etc' panel and it took the '98 Setup' panel with it ....no icon in the Control Panel. Uninstall again. After the uninstall I checked the Temp folder and the four files were still there, Re-boot...still there....Find >Files and Folders>Tweak, brought them up and I deleted tham there. I did not delete the tweakui133.exe file because I wanted to use Winzip (my next attempt) on the same down-load, rather than a new one.

Reinstall Winzip; RT/click tweakui133.exe> extract to 'C:\Windows\Desk-top\tweakui133. Opened that folder and the same 4 tweak files were there, still no .GID file. I rt/clicked the tweak.inf and it brought up the 'Insert disk" dialogue box . Behind it was the inactive 'Copying Files' box. Having no disk I clicked OK to get to a second 'Copying Files'  again asking for a disk but offering to let me browse, In the " Copy Files From" box I entered the C:\Windows\Desktop\tweakui133 address. Click OK...no result. It was looking for tweakui.cnt so I added that to the address...still no good. At some point the tweakui.gid file showed up...I have no idea when or why.

So at this point I have tried with and with-out Winzip and it all ends one way or the other at RT/click tweakui.inf....I'll try some more after I send this. One more item I'm curious about; In the past whenever I have downloaded a zip file it was automatically placed at the top of my zip download list and Winzip just took it from there, now it doesn't show up there
 
And that's it for today...Thanks for your efforts thus far and hopefully yet to come.  Harshale

 
 
0
 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

I'm puzzled...

I wonder what may be wrong.

Anyway, instead of TweakUI, you may try the Winguides Tweak Manager (also excellent):

http://www.winguides.com/tweak/

Scroll down for the free trial version.

See this suggestion as a workaround...

Cheers,

Zee
0
 

Author Comment

by:harshale
Comment Utility
Greetings,

I'm going to bail-out on this one...I went thru the drill again today and the result is still the same;  no icon in the Control Panel.

There must be other problems elsewhere in my system.

There is one point that I find curious and worrisome; that is the fact that the 'tweakui uninstall process'  removes the name from the Add/Remove Programs list, yet the four tweak files remain in the Temp folder, necessitating removing them one by one. Could this point toward some other problem?

In any case I will leave this open for another few days just in case there is still any interest in the problem, and then I'll remove it.

The utility did what I had hoped for (removing the MSN icon) during the brief period of time that it was functioning.

Thanks again for the efforts made to solve this.

Harshale

0
 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

Harshale,

You can always try:

Start > Run > type SFC and press enter

Run the utility and it may fnd some corrupted system fle and replace. I wonder.

You may need your Win98 CD.

Thanks for the feedback, even if not that positive.
:(

Zee
0
 

Author Comment

by:harshale
Comment Utility

Zee,

I ran the SFC utility and it came uo with nothing. As I've said though - it really doesn't matter.

I feel that, what with all the down-loads, aborted installs, uninstalls that didn't uninstall, etc., the registry is probably carrying some remnants of all that activity.

I'll pull this, as I said, in a day or so and then  post a new one dealing with; (how did you guess?) identifying, finding, and getting garbage out of the registry, and duplicate entries in the 'msconfig' utility. 'Till then...take care.

Harshale

0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

LOL, oops...

Maybe I can help you there:

RegSupreme
http://www.macecraft.com/brief_rs/

You have a free trial period for this download. It is really good.

FIY the first time I run it in my home PC it found (don't look surprised...) 1500+ obsolete entries!!

And it's quite safe, it makes a backup copy of the deleted items, just in case you may need to restore them.

I didn't till today.

For the startup entries StartupMechanic from  www.startupmechanic.com, very user friendly, self-explanatory, all changes easily restorable too.

Cheers,

Zee
0
 

Author Comment

by:harshale
Comment Utility
Zee

Time to report in....I have been using RegSupreme since your post. At this point in time all is well....everything is operable but there have been adventures along the way. RegSupreme cleaned up a couple of hundred keys and left me with 253 "bad"  keys, that I suppose are fixable with the 98SE disk (which is a story in itself). RegSupreme says all of the 253 need a file that...'does not exist'. A total of 6 files are lacking in order to "fix" the 253 keys. All of them are related to multimedia activities;
.
mplayer2.exe                Media Player              181 keys   Approx.

sndrec32.exe                Sound Recorder           20 keys      "   "

kodakimg.exe                         ?                       22 keys      "   "
kodakprv.exe                          ?                       22 keys      "   "

mspaint.exe                   Paint                            6 keys

cdplayer.exe                 CD Player                      2 keys

Is this a matter of extracting these files from the 98 disk and re-installing them in the proper folders? If so, here is the 'story in itself' referred to above. This computor; (Compac Presario Desk-top), OS; (98SE), modem, etc., all came bundled as part of subcribeing to a DSL service. So much a month and so forth. As such it came with everything pre-installed and pre-configured. Documentation is minimal. It came with 2 disks; 'Quickrestore' 1 & 2. Bottom-line...I have no way to access or restore Windows in part or completely without all the Compac services and add-ons. Once those disks are in play they take over. Each time I have attempted to use them I have ended up with a re-formatted HD and then a real hassle getting back up to date...etc.

Actually, I don't miss a thing: cd player works, IE, Outlook Express works, I could leave it alone and get a long fine but; Installs and uninstalls are still not functioning properly. Installation of Tweakui133 (with and without Winzip) still cannot be effected, installation of anything else seems to work alright. Uninstalling is another matter entirely, to use a failed Tweak install as an example, following the tweak uninstall procedure leaves all of the associated files in place. It's then; Find>Files and Folders> Named.....etc.> Delete. The same holds true for un-installs...something I installed, (Winzip?) was going to remove the 'exe' setup file on the desk-top when I finished and closed the set-up procedure...it didn't. Other programs I have un-installed all left their components in place. Odd.

I attempted to download Windows Media Player hoping it would bring with it the mplayers.exe file and fix those keys , for some reason the download failed...I don't have my notes on that, I might try that again.

StartupMechanic has been helpful and things are looking good in that area.

Somewhere along the way I've 'lost' my volume control short-cut from the system tray and the Accessories>Entertainment folder. But at least the butterfly is gone....that"s where all this started.

Where am I at now? and what would you suggest next?

Harshale

       
0
 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

I believe you may have a few crosslinked files and usually that is not easy to undo.

1. You may want to install a fresh MSI:
http://www.microsoft.com/downloads/details.aspx?FamilyID=cebbacd8-c094-4255-b702-de3bb768148f&DisplayLang=en

2. mplayer2.exe seems to be the Media Player 6. You should be using 7.1. You can check this by searching for the file and then right clicking it and seeing its properties. Probably can be safely cleaned. They probably refer to obsolete links on playlists (media files that were deleted).

3. The same applies to sndrec32.exe and cdplayer.exe.

4. kodakimg.exe and kodakprv.exe are components of (Kodak) Imaging for Windows. Probably also obsolete links to deleted image files. Anyway you can uninstall or reinstall Imaging through Add/Remove Programs > Windows Setup > Accessories. Click Details and you'll see Imaging there. Tick or Untick to install or uninstall.

5. mspaint.exe is, of course, Paint. Again I believe the problem is obsolete links.

I would suggest you clean them one by one, first mplayer2.exe, reboot, then sndrec32.exe, reboot, etc.

This way you will create single backups per utility and you will know which one to restore if one of them stops working or has problems.

The volume control can be selected in Control Panel > Sounds and Multimedia where you can tick "Show volume control on taskbar".

I think you now have some home work.
;)

Looking forward for your feedback.

Zee
0
 

Author Comment

by:harshale
Comment Utility
I downloaded the fresh MSI, then went for the Media Player 7.1  After installing MP7.1, I ran RegSupreme; that took me down to 136 from 253.
All of the entries dealing with mplayer2 were gone...5 new ones showed up, all 5 keys were lacking "pnwrap.dll" and all dealt with mplayer2/extensions and protocols...couldn't have been too important; a re-scan eliminated those 5.

I then looked for sndrec files; 1 found C:\windows\shellnew\sndrec.wav.
I hit the web looking for a sndrec.exe download site, but found none. In the course of the search I ran across a lot of chatter about it and from that I can determine that I don't need the sndrec features. and since everything else is operating just fine it would appear the relevant keys could be eliminated. There are a total of 15.   ??

The Kodak~.exe (81 keys) are still there and relate to the following items: DCXImage, PCXImage, TIFImage, WANGImage, WIFImage, Faxview, and Imaging....again I could not locate a download. Safe to eliminate those keys??

MSPaint...(12 keys)...couldn't locate a download...don't care about Paint, eliminate keys??

cdplayer.exe (4 keys) ...again no download, and again, since all is running well and the file doesn't exist on my machine...eliminate the keys?

The volume control is back since you pointed me toward the Control Panel...I knew it was somewhere but I kept looking in all the wrong places.

It will be interesting to see if Tweakui133 will download and install properly now. I'll wait until I get your thoughts on this post before I move on.

I just took another look at Regsupreme and the key count is now down to
112. They are all, according to RegSupreme, 'invalid entries".

That's it for now, I'll be watching for you thoughts on this stuff.

Take care, Harshale





 
0
 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

Harshale,

From your description those entries sound quite disposable.

Anyway, use the backup feature of RegSupreme: name it something you will remember!! and go for the delete.

Reboot and check if the problem persists.
(and Zee keeps fingers crossed...)
:))

Zee
0
 
LVL 29

Accepted Solution

by:
blue_zee earned 500 total points
Comment Utility

Quick note:

If you managed a correct installation of WMP7.1...

I'm starting to be a little more confident.

Zee
0
 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

Does this mean it worked?

Zee
0
 

Author Comment

by:harshale
Comment Utility
Zee

I had posted a comment here and then hit the 'accept' button, now it's gone. So I'll try sending the comment again.

 The butterfly is gone - The registry is clean - The VC is back - I've learned a lot. Well worth the points!

I tried the Tweakui133 install again, with and with out Winzip with the same types of failures to install. Un-installing both of them did not work, just as before I had to 'find and delete' the files manually.

 I then installed Winguides Tweak Manager and as a quick test, I disabled the Windows splash-screen and re-booted. The splash screen still came up. I went back into Tweak Manager and found the 'check' I had cleared was back in place. Repeated the process...same result. I attempted to use the Tweak Manager un-install and it failed too...more 'find and delete.

I then ran RegSupreme and came up with several keys relating to Winzip and Tweak. 'Fix' took care of them.

It would appear that I have something interfering with both in-stall and un-install, but that's for another time. I'll spend some time putting together what info I can and open a new question on that point.

In the mean time, Take care and thanks     Harshale
0
 
LVL 29

Expert Comment

by:blue_zee
Comment Utility

Thanks but I'm sorry I didn't manage to sort out the real problem you have.

Thank you for the excellent feedback that enabled this dialogue. And I must say it also was a lesson to me.

Take care,

Zee
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

For a variety of reasons, it sometimes makes sense to reboot a Windows-based computer on a regular, perhaps daily basis. This "cures" a lot of ills by resetting processes, flushing caches, refreshing memory, and reestablish network connections. In a…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now