Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Mailbox name cannot be resolved

Posted on 2004-04-11
16
Medium Priority
?
6,763 Views
Last Modified: 2010-09-14
I've setup and configured an Exchange 2003 server. Everything is fine on the server side. However, on my client side, on certain clients, when i try to create a profile and connect to a mailbox on the exchange server using outlook, i get a "The name cannot be resolved. The name cannot be matched to a name in the address list" error.  On the other clients, i have no problems connecting to the server. I've checked through the client settings. All seems to be in order. I obtain my network settings from DHCP. I can even ping the Exchange server. I've even tried running netdiag to test my connections. There don't seem to be anything wrong with the clients. Please help !!
0
Comment
Question by:cheunghc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +6
16 Comments
 
LVL 20

Expert Comment

by:What90
ID: 10803506
Hi cheunghc,


Try forcing the RUS update

You need to go to Exchange System Manager - Recipients - Recipient Update services - select your default Recipient Update service - right click and select update now. That will  display the exchange account info.

Check this link for more info:
http://hellomate.typepad.com/exchange/2003/07/is_your_rus_not.html


Then you need to send a email to that new account to "create" the mailbox in ESM.
0
 
LVL 9

Expert Comment

by:robinluo
ID: 10805159
- On the problem client PC, is it only certain mailbox names that could not be resolved or none of your server's recipient could be resolved?

- The mailbox names that couldn't be resolved on certain PC, can they be resolved on other PC?
0
 
LVL 35

Expert Comment

by:Bembi
ID: 10806337
RUS is one of the most common possible reasons, depending on the interval, the RUS is updated, esp. if you have created the account on the same day.

If this will not help, we found another issue some time ago, on which a damaged TCP/IP stack on the client machine was responsible for this issue. But before we should follow this, try first, what WHAT90 said.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:cheunghc
ID: 10809823
I've tested out on a few PCs. If a PC is unable to resolve the mailbox name, it won't resolve any name no matter which name you try. On a PC that can resolve, it will resolve any/all mailboxes. It's either the PC can or cannot resolve. It's very wierd.

I've tried updating the RUS. It's also the same result. May i hear your theory on the damaged TCP/IP stack ? Anyway, i've setup 2 new PC to try to resolve the mailboxes. Both of them also cannot do so.
0
 
LVL 20

Expert Comment

by:What90
ID: 10809858
Try doing at a comd propmt: ipconfig /flushdns ,then ipconfig /renew

Then try to resolve a the mailbox
0
 
LVL 35

Expert Comment

by:Bembi
ID: 10827441
If you have clean installed machines and you cannot resolve the names on these machines, but on other machines (means RUS has created the entries), it sounds like a network configuration issue.

In general:
Make sure, your name resolution is working properly. As you have a Ex2003 Server, you also have a 2003 server. All W2K machines needs an DNS Server and mostly also a WINS server. Within you client configuration, make sure your clients are pointing to your DNS server and within the WINS configuration, put in your WINS server there and make sure NetBios over TCP/IP is enabled. Make sure, port filtering and the internet firewall is disabled.

On your server, configure your DNS properly and set the option to use WINS Lookup (and WINS Reverse Lookup for the reverse zone).
Check your name resolution (from your client) with
nslookup servername
nslookup servername.yourdomain.xxx (Fully qualified domain name of your server
nslookup IP-Address

All three tests should come back without any delay.

If this is OK, you cann additionaly telnet your mail server by
telnet yourserver 25

this should come back with a banner line.

Try this first and come back, if you have problems.

To repair the TCP/IP stack (on W2K machines or higher), just kick your network connection out, reboot your machine and reinstall the network connection (make sure you can logon locally!!!)

Please tell me something about your clients (OS version, DHCP or manually configured etc.)
0
 
LVL 35

Expert Comment

by:Bembi
ID: 10831679
0
 
LVL 1

Expert Comment

by:obeshawd
ID: 10835434
Hi,

I had the same problem and easily resolved the issue.  All you need to do is remove all the network settings on the client machine (TCP/IP, client for microsoft networks, file and printer sharing).  Remove all of them.  Restart the computer then install and configure your network components.  Restart and whamo, name resolution works again.  
0
 
LVL 35

Expert Comment

by:Bembi
ID: 10836672
obeshawd:
I would follow you as long as there are no registry keys, which will stay and recovered, if you reinstall the network components. This is the general problem. But anyway, its always a chance.
0
 
LVL 1

Expert Comment

by:obeshawd
ID: 10837068
There is no harm in removing TCP/IP and so on.  Just dont remove the ethernet card itself as you will have to reload drivers if you do.  This is a client-side problem, otherwise the problem would extend beyond a few users.  I got this tip from the Microsoft site but I cant seem to find the link I had.  Anyhow, I dont care about points, I just know that this works. Hope this helps the cheunghc.  Try it, if it works, just give the points to Bembi.
0
 

Accepted Solution

by:
modulo earned 0 total points
ID: 11088208
Closed, 500 points refunded.

modulo
Community Support Moderator
Experts Exchange
0
 

Expert Comment

by:limkengyuen
ID: 24155531
So what is the solution for this issue? I have the same problem as cheunghc. But I resolved it just by manually configure my ip instead of using dhcp. But I don't understand why it will like that.
0
 
LVL 10

Expert Comment

by:FamousMortimer
ID: 33671732
I had this same issue, but it only occurred with one (as far as I know) account.  It turned out that there was no RUS entry for our local server, and after creating one and forcing an update, it worked immediately.
0
 

Expert Comment

by:CyberDocSupport
ID: 33853761
Updating the RUS fixed this for me as well.  Thanks guys!
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question