We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Internet Sharing Very Slow Through Host Computer

Skiwi2
Skiwi2 asked
on
Medium Priority
472 Views
Last Modified: 2008-02-26
I have a cable modem used with a LinkSys Router (1 Port) and a Micronet Etherfast 5 ports mini hub 10mb tp8. I have 3 computers that share the internet and network here at home. The network speed is excellent except the internet at times seems to be super slow on the host computer. However, when a site is accessed on the host computer, the client computer internet sharing seems to be fine. Any ideas as to what the problem might be? I also run McAfee VirusScan Professional Edition v7.00.5000. Firewall is set to allow all traffic.
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2004

Commented:
I'm not sure what you mean by "host computer." Is it acting as a gateway for your other PCs? If you have the linksys router and a hub, why not just let the router do the routing for all of your hosts?

Author

Commented:
I guess it's not the host computer. All PC's are having this problem on my Network.
CERTIFIED EXPERT
Top Expert 2004

Commented:
Can you be more specific about the problems you are experiencing? What types of traffic are slow? What speed internet connection do you have? Do they all slow down at the same time? Etc.
CERTIFIED EXPERT

Commented:
Hoe does this all connect?  Does the host have 2 network cards one to the hub and one to the router?  Or have you got the hub and router linked and all computers linked into the hub?

Author

Commented:
All computers are connected to the hub. Each computer has only one network card.
CERTIFIED EXPERT

Commented:
What gateway have you configured all your machines to use?  Scrap ICS and use Nat on your router.

Set the gateway on your computers to the LAN IP of your router, e.g. 192.168.1.1 is default for linksys I think.

Check none of the computers are using any P2P apps or anthing, using all of your upload bandwidth on a Cable modem seriously affects the whole performance.
CERTIFIED EXPERT
Top Expert 2004

Commented:
This is what I was getting at at the beginning. Since you have a router, don't use a PC to share the connection- it's only another thing in between you and the internet.

Turn off IP forwarding and connection sharing on the "host" PC, and DHCP service if it exists. If you then set all of your PCs to use DHCP everything should work fine. If you need static addresses, use:
IP address 192.168.1.x
subnet mask 255.255.255.0
default gateway 192.168.1.1
DNS- let it get one automatically and the router should forward it correct info.

Also make sure that your NICs are not hard-configured for ethernet speed and duplex, or if they are, they need to match your hub's capabilities which will be half duplex and either 10mb or 100mb (or both).

Author

Commented:
Actually I went to a Linksys and got some upgrade software. Now everything is working fine.

Thanks to all.
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.