Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 444
  • Last Modified:

J2EE1.3 & J2SE1.4.2 ....

Hi Experts,

    It's me again ...... This is a following up question of
http://www.experts-exchange.com/Programming/Programming_Languages/Java/Q_20951005.html

Now I installed J2EE 1.3 and J2SE1.4.2. I started a cmd window, and tried "j2ee -verbose".
However, the following is what I got :

C:\>j2ee -verbose
ERROR: Set J2EE_HOME to the path of a valid j2sdkee

Here are my environment variables :
JAVA_HOME = j2sdkee1.3
J2EE_HOME = j2sdkee1.3
path = C:\Program Files\Microsoft Visual Studio\Common\Tools\WinNT;C:\Program Files\Microsoft Visual Studio\Common\MSDev98\Bin;C:\Program Files\Microsoft Visual Studio\Common\Tools;C:\Program Files\Microsoft Visual Studio\VC98\bin;C:\j2sdkee1.3\bin;
---------------------------------------
 Could anyone please give me some help about the error ??? Thanks a lot !!!
0
meow00
Asked:
meow00
  • 10
  • 9
  • 7
2 Solutions
 
CEHJCommented:
>>
JAVA_HOME = j2sdkee1.3
J2EE_HOME = j2sdkee1.3
>>

These are not paths - they're just disconnected strings. They should point to the directories where you installed this software, java sdk and j2ee sdk respectively
0
 
meow00Author Commented:
Hi Experts,

  Here is my C:\>  (in my windowXP machine)
----------------------
 Volume in drive C has no label.
 Volume Serial Number is 0000-042C

 Directory of C:\

2003/12/18  &#19978;&#21320; 12:05    <DIR>          apache
2003/06/12  &#19978;&#21320; 10:07    <DIR>          arcgis
2003/05/31  &#19979;&#21320; 10:38    <DIR>          axessh
2002/12/18  &#19978;&#21320; 10:45    <DIR>          COMPAQ
2002/12/18  &#19978;&#21320; 10:27    <DIR>          cpqs
2003/12/17  &#19978;&#21320; 10:18    <DIR>          cygwin
2004/02/27  &#19979;&#21320; 03:51    <DIR>          Documents and Settings
2002/12/18  &#19978;&#21320; 10:27    <DIR>          hp
2003/08/07  &#19979;&#21320; 07:47    <DIR>          i386
2003/12/29  &#19978;&#21320; 10:50    <DIR>          j2sdk1.4.2_03
2004/04/12  &#19978;&#21320; 09:32    <DIR>          j2sdk1.4.2_04
2004/04/11  &#19978;&#21320; 11:56    <DIR>          j2sdkee1.3
2004/02/26  &#19979;&#21320; 05:30    <DIR>          MSDERelA
2003/08/22  &#19979;&#21320; 09:20    <DIR>          My Downloads
2002/02/07  &#19979;&#21320; 07:19             2,063 my.cnf
2003/12/20  &#19979;&#21320; 09:00    <DIR>          mysql
2003/12/18  &#19978;&#21320; 12:05    <DIR>          phptriad
2004/04/12  &#19978;&#21320; 09:42    <DIR>          Program Files
2004/04/08  &#19979;&#21320; 04:15    <DIR>          Sun
2002/12/18  &#19978;&#21320; 10:45    <DIR>          SWSETUP
2003/07/07  &#19979;&#21320; 04:25    <DIR>          Temp
2004/04/12  &#19978;&#21320; 10:42                 0 test.dat
2004/04/07  &#19978;&#21320; 11:54             4,732 trash.txt
2004/02/28  &#19979;&#21320; 05:35    <DIR>          unzipped
2004/04/12  &#19978;&#21320; 09:43    <DIR>          WINDOWS
2003/12/18  &#19978;&#21320; 12:05    <DIR>          winnt
2003/12/17  &#19979;&#21320; 11:24    <DIR>          WUTemp
2003/08/07  &#19979;&#21320; 06:08    <DIR>          xinstall
               3 File(s)          6,795 bytes
              25 Dir(s)  16,017,285,120 bytes free
-------------------------------
 so I have set the "JAVA_HOME" as : "j2sdk1.4.2_04" and "J2EE_HOME" as: "j2sdkee1.3".

But now I got :
C:\>j2ee -verbose
ERROR: Set JAVA_Home to a path of a valid jdk.
-------------------------------------
Can anyone please tell me what I have done wrong ? Thanks !

meow......
 
0
 
CEHJCommented:
Is j2sdk1.4.2_04 properly installed? Why do you have j2sdk1.4.2_03? I would uninstall/remove the latter unless you have a very good reason for its being there oryou could get problems
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
meow00Author Commented:
err ..... I installed it(j2sdk1.4.2_03) a month ago ... I don't mean to leave it there....but but .... I don't know how to uninstall it ? please help !!! thanks !
0
 
CEHJCommented:
Add/Remove programs
0
 
Tommy BraasCommented:
JAVA_HOME =C:\j2sdk1.4.2_04
J2EE_HOME =C:\j2sdkee1.3
0
 
Tommy BraasCommented:
If you type:java -version at the dos prompt it will tell you which is the default JVM
0
 
CEHJCommented:
It'll tell you the version of java.exe that appears first in the path variable
0
 
Tommy BraasCommented:
Since she apparently doesn't have a java.exe in the path, it has to look in the registry, in which case the default version will be reported.
0
 
meow00Author Commented:
Hi Experts,

    After I removed j2sdk1.4.2_03, the j2ee command seems to be recognized. However, I still have errors while I try to start the j2ee server. THe following is the error message. Could anyone
please give me some helps ?

---------------------------------------------------------------------------------
C:\>j2ee -verbose
Warning: This J2EE SDK release is designed to run on J2SE 1.3
J2EE server listen port: 1050
Naming service started:1050
Binding DataSource, name = jdbc/DB1, url = jdbc:cloudscape:rmi:CloudscapeDB;create=true
Binding DataSource, name = jdbc/InventoryDB, url =  
   jdbc:cloudscape:rmi:CloudscapeDB;create=true
Binding DataSource, name = jdbc/DB2, url = jdbc:cloudscape:rmi:CloudscapeDB;create=true
Binding DataSource, name = jdbc/EstoreDB, url = jdbc:cloudscape:rmi:CloudscapeDB;create=true
Binding DataSource, name = jdbc/Cloudscape, url =
   jdbc:cloudscape:rmi:Cloudscape DB;create=true
Binding DataSource, name = jdbc/XACloudscape, url = jdbc/XACloudscape__xa
Binding DataSource, name = jdbc/XACloudscape__xa, dataSource =
   COM.cloudscape.core.RemoteXaDataSource@e41bc3
Starting JMS service...
Initialization complete - waiting for client requests
Binding: < JMS Destination : jms/Topic , javax.jms.Topic >
Binding: < JMS Destination : jms/Queue , javax.jms.Queue >
Binding: < JMS Cnx Factory : QueueConnectionFactory , Queue , No properties >
Binding: < JMS Cnx Factory : jms/QueueConnectionFactory , Queue , No properties>
Binding: < JMS Cnx Factory : TopicConnectionFactory , Topic , No properties >
Binding: < JMS Cnx Factory : jms/TopicConnectionFactory , Topic , No properties>
Starting web service at port: 8000
Starting secure web service at port: 7000
J2EE SDK/1.3
LifecycleException:  null.open:  java.net.BindException: Address already in use:
  JVM_Bind at org.apache.catalina.connector.http.HttpConnector.initialize
  (HttpConnector.java:1081)
   at org.apache.catalina.startup.Embedded.start(Embedded.java:945)
        at com.sun.web.server.WebService.start(WebService.java:214)
        at com.sun.web.server.WebServer.start(WebServer.java:193)
        at com.sun.enterprise.server.J2EEServer.startWebService(J2EEServer.java:730)
        at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:294)
        at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:913)
            java.lang.RuntimeException: null.open
        at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:350)
        at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:913)
J2EE server reported the following error: null.open
Error executing J2EE server ...
0
 
Tommy BraasCommented:
Another service is already running on, probably, port 8080. Make sure that no other web services are running.
0
 
meow00Author Commented:
err .... I didn't start any service by myself, unless some service is started automatically ..... How do I know if I have other web services running or not ? Thanks !
0
 
Tommy BraasCommented:
Start menu->Control Panel->Administrative Tools->Services

Look for:
Apache Tomcat

With status: Started
0
 
Tommy BraasCommented:
You can also run the command 'netstat' in a command prompt window, and look for port 8080
0
 
meow00Author Commented:
Hi,

   Thanks for the information. I first went to "Start menu->Control Panel->
   Administrative Tools->Services". But I couldn't find "Apache Tomcat" ?!

   Also, I tried netstat, but I don't see port 8080  ? Please help, what should I do or check next ???
Thanks very much !!!
-----------------------------------------
C:\>netstat

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    TaichiPC:2144          67-114-52-58.deploy.akamaitechnologies.net:http ESTABLISHED
  TCP    TaichiPC:2145          67-114-52-58.deploy.akamaitechnologies.net:http ESTABLISHED
  TCP    TaichiPC:2146          67-114-52-34.deploy.akamaitechnologies.net:http ESTABLISHED
  TCP    TaichiPC:2148          f601.mail.yahoo.com:http  TIME_WAIT
  TCP    TaichiPC:2160          216.239.57.104:http    ESTABLISHED
  TCP    TaichiPC:2161          jobs.collegerecruiter.com:http  ESTABLISHED
  TCP    TaichiPC:2162          jobs.collegerecruiter.com:http  ESTABLISHED
  TCP    TaichiPC:2166          hannan.netline.com:http  TIME_WAIT

C:\>
0
 
Tommy BraasCommented:
The ports in use by J2EE RI are:
1050
7000
8000
8080

Try to open a web browser window to the following addresses (just click on them):
http://localhost:8000
http://localhost:8080
http://localhost:8090
0
 
CEHJCommented:
>>
Since she apparently doesn't have a java.exe in the path, it has to look in the registry, in which case the default version will be reported.
>>

The console probably won't look into the registry for java.exe - it certainly doesn't on my machine
0
 
CEHJCommented:
This is the answer you accepted with some speed to your last question:

>>You can use any J2SE 1.3.1 and above. I would recommend 1.4.2,.

The warning message you received above suggests a quite different picture:

>>
C:\>j2ee -verbose
Warning: This J2EE SDK release is designed to run on J2SE 1.3
>>
0
 
meow00Author Commented:
Hi experts,

    Thanks for all the information ! I tried the localhost: 8000, 8080, 8090:

when I tried : http://localhost:8000/ , it automatically becomes https://localhost:8443/
when I tried : http://localhost:8080/ and http://localhost:8090/, I got "The page can not be  
   displayed".

Also .... if "Warning: This J2EE SDK release is designed to run on J2SE 1.3" is true, how do I get J2SE1.3 ? I only see J2SE1.4.2 and J2SE1.5beta on the website .........

    I am stuck and confused ! Please please help !!! many many thanks !

meow.
0
 
CEHJCommented:
>>how do I get J2SE1.3 ?

Personally i'd pay heed to the warning:

http://java.sun.com/products/archive/
0
 
meow00Author Commented:
Also, I don't know why the Java icon (of J2SE1.4.2) showed up in the start bar ? while the server didn't start up successfully .... I don't know how to terminate the program either :-(
 
0
 
Tommy BraasCommented:
>> Also .... if "Warning: This J2EE SDK release is designed to run on J2SE 1.3" is true, how do I get J2SE1.3 ?
J2SE 1.3 is a minimum requirement, meaning that J2EE 1.3.1 will not run on anything earlier. You're fine with 1.4.2. I run the J2EE stack using 1.4.2!

The error you're getting is similar to one I got once. Please post the setting of J2EE_HOME! Plus, whenever you change a system environment variable, you have to open a new command window to get those changes!
0
 
meow00Author Commented:
Here are the variables :

JAVA_HOME : C:\j2sdk1.4.2_04
J2EE_HOME: C:\j2sdkee1.3
-----------------------------------------------------
what does it mean by "whenever you change a system environment variable, you have to open a new command window to get those changes" ?
What should I type in the command window to get the changes ?

many many thanks !!!
0
 
Tommy BraasCommented:
>> what does it mean by "whenever you change a system environment variable, you have to open a new command window to get those changes" ?
It means that if you have a command window open when changing system environment variables, that window will not be updated with those changes.

>> What should I type in the command window to get the changes ?
Just close it and open a new one. The new command window will have the changes.
0
 
meow00Author Commented:
Thanks experts,

I still have the same errors after I have a new command window..... I guess I will try to use J2SE 1.3.1 and see what happens ......

Thanks a lot for helping me out !!!
0
 
Tommy BraasCommented:
Just restart your computer and try again before you install J2SE 1.3.1!!!
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

  • 10
  • 9
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now