Solved

Windows XP and problems files sharing.

Posted on 2004-04-12
4
1,949 Views
Last Modified: 2011-10-03
Hey,

I have a new box that i just installed on my company's netowrk in one of our offices. Anyways, the user can see the internet and get email...but he can't see any of the other computers on the network. Here's a little background on the network. It's made up of 8 computers. They all get ips from our router dynamically. The computers are ether running Windows 98 or Windows XP Professional, and i think one is Windows XP home (yes i know my company has no software standard). Anyways, everybody else can see eachother, savefor this new computer. The Workgroup name on all the computers is the same, including the one that is having problems. When the user goes into my network places and clicks on view workgroup computers, nothing is showing up in the window, not even his own computer. The address bar shows that we are in the workgroup, yet there seems to be no computers....which there really are. The internet connection fire wall that comes with windows is shut off. In my opinion and the other tech's opinion, the settings look right, infact they are the same as all of the computers in the network.....however they are not i guess. Does anybody have and ideas to what is going on? I am getting sick of hitting my head against the wall.


-Pizentios
0
Comment
Question by:Pizentios
  • 2
4 Comments
 
LVL 41

Accepted Solution

by:
stevenlewis earned 250 total points
ID: 10809143
http://www.wown.com/j_helmig/wxpwin9x.htm
and from a great expert lrmoore
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.

-------------

Next, check your XP networking setup:

http://support.chartermi.net/support/pipeline/windows/winxp_network.html

Although this link says to set netbios over tcp/ip to "default", follow the instructions below...

-------------

Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..

----------------

For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)

----------------

Client for Microsoft Networks needs to be the primary network logon for all other machines

----------------

All machines are in the same workgroup


Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.

References:

http://support.microsoft.com/default.aspx?scid=kb;en-us;318030

http://support.microsoft.com/default.aspx?scid=kb;en-us;314366

http://support.microsoft.com/default.aspx?scid=kb;en-us;315267

http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm

http://www.michna.com/kb/WxNetwork.htm




also if this is an xp pro box
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled



or
on the XP machine

Start | Programs | Administrative Tools | Local Security Policy

Security Settings

Sharing Mode- Change this to "Classic Mode - Local users Authenticate as Themselves" (as opposed to "Guest only" the default model)

this fix will be applied after a restart

See:

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/winxppro/proddocs/506.asp?frame=true




0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 10809156
Yea I would agree with stevenlewis first comment. Sounds like Internet Connection Firewall is on to me.

Right click My Network Places and click Properties
Right click you network connection and click Properties
Click Advanced.
Disable Internet Connection Firewall. click ok.
0
 

Author Comment

by:Pizentios
ID: 10813279
i have already turned off the firewall. it says so in the post i put. But i will try out some of the other suggestions that were posted and let you know.

-Pizentios
0
 

Author Comment

by:Pizentios
ID: 10813532
Thanks for your help....it was the netbois settings. I've never run into this problem before, but i guess you learn somthing new everyday.

-Pizentios
0

Featured Post

New My Cloud Pro Series - organize everything!

With space to keep virtually everything, the My Cloud Pro Series offers your team the network storage to edit, save and share production files from anywhere with an internet connection. Compatible with both Mac and PC, you're able to protect your content regardless of OS.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
Are you one of those front-line IT Service Desk staff fielding calls, replying to emails, all-the-while working to resolve end-user technological nightmares? I am! That's why I have put together this brief overview of tools and techniques I use in o…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now