• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 818
  • Last Modified:

Pivot Chart Rounding Inconsistencies

I have a form that has a pivot chart.  The number that is displayed is always an even number when I know that there must be some numbers after the decimal place.  The problem is it just chops off the decimal points.  It doesn't round up or down, it just truncates the numbers.  

The problem is I need to see exact numbers in my pivot chart!  The curious thing is that if I export the pivot chart to a data access page, it doesn't round the numbers and gives me the exact number out to the decimal places.  I need to be able to have the exact number in my form without rounding, it makes reconciling a lot easier!

How can I get a pivot chart in a form to stop rounding (truncating)?

Thanks!
0
Mourdekai
Asked:
Mourdekai
  • 4
  • 2
1 Solution
 
nico5038Commented:
Hmm, might be a problem in the Regional settings.
Just goto Start/Settings/Control panel and activate that.
On the control panel activate Regional and language settings and check the settings for both the number and currency.
For both the decimal separater needs to be equal, both a comma or both a dot.

Just check to be sure.

Nic;o)
0
 
MourdekaiAuthor Commented:
I checked and the formats are exactly the same.  It's a good idea but I don't think that is the problem because if I save the form as a data access page, and open the page on the same machine, the numbers are rounded differently.  The form uses truncated numbers, while the data access page uses the true value.  I think my question might need some rewording to explain itself correctly.  So here is an example:

Let's say the data contains the number of hours that I worked over the last two weeks.  Two weeks, at 5 days a week gives 10 records.  Let's take 10 sample records:

8
7.25
9.75
10.25
8

8.5
7.75
10.75
9.75
6.5

The form would report the total as 82
The DAP would report the total as 86.5

It's like the form doesn't round after adding, but is adding only the integer parts of the numbers.
0
 
nico5038Commented:
Have you tried to use a format statement on the valuefield in the query like:
format([valuefield],"#.00")

Nic;o)
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
MourdekaiAuthor Commented:
I'll try that tomorrow.  One of the data sets are numbers, and the others are currency.  I know that my query no longer worked in the pivot chart when I used FormatCurrency([field]), but I'll give that a shot.
0
 
MourdekaiAuthor Commented:
That didn't work either.  The only option it lets me use when putting the field as the data is "count".  I can't use sum any more.
0
 
MourdekaiAuthor Commented:
Well I found the solution.  I'm not sure I understand why it is the solution, but it works nonetheless.

I changed the data type of the field from decimal to double and it now accurately displays the decimal points in pivotchart view.

I'm going to post a request to PAQ this question.

Thanks for the help Nico, and congrats on your recent 2 Mil!
0
 
NetminderCommented:
User resolved; closed, 500 points refunded.

Netminder
Site Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now