Solved

Securing sending postfix e-mail

Posted on 2004-04-12
3
173 Views
Last Modified: 2010-05-18
I have a redhat 9 server with postfix and dns for "www.mydomain.com".  I have been receiving weird e-mails such as "any_user@mydomain.com", also e-mails with several domains that i suspect are being originated from my own server.

How can i restrict my mail server to accept only outgoing e-mails originated from my lan 192.168.0.0/255.255.255.224 and also for the webmail interface in www.mydomain.com/mail

Thanks a lot !
0
Comment
Question by:diordonez
3 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 10809270
I suspect that you are confused as to the real source of those emails and that you are taking what's in the From: header too litteraly. The From: header corresponds exactly to what's on the piece of paper inside of an envelope. It can be completely different from the envelope Sender, in the same manner that what's on the paper inside of an envelope isn't seen by the postoffice. The From: header can contain anything, or even be absent and the mail will still be delivered to the envelope Recipient.

To see where the message really came from you need to look at the envelope headers and how that's done depends on what mail client you use. For example with Evolution you select "View->Message Display->Show Full Headers". With that visible the first "Received:" from the bottom is the system that originated the message.
0
 
LVL 2

Expert Comment

by:tcmv
ID: 10810387
If you want to watch this traffic in real time, I suggest getting ethereal (or tethereal -- the text based version for the command line) and use the following filter: "tcp port 25", which will catch all SMTP mail traffic.  Watch this traffic for spoofed mail ... in doing so you may be able to determine also if mail is being relayed from your box or if the offending mail servers are enumerating mail accounts using the VRFY command (it's basically like saying "Is Joe a user on this mail server?").

Make sure the following line is in your postfix config file:

disable_vrfy_command = yes

-tcmv
www.mvix.net
0
 
LVL 12

Accepted Solution

by:
mburdick earned 125 total points
ID: 10819819
If you are using the machine to only send e-mail, and not receive, you have two choices:

1) Install / run / modify IPTABLES to block connections to port 25 from anywhere but the addresses you specifiy.

2) Modify the mynetworks parameter of postfix (/etc/postfix/main.cf) to reflect only your local subnet addresses and 127.0.0.1/32. If you do this, you will also need to modify the mydestination paramer and set it to something bogus (or leave it blank).
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

BIND is the most widely used Name Server. A Name Server is the one that translates a site name to it's IP address. There is a new bug in BIND (https://kb.isc.org/article/AA-01272), affecting all versions of BIND 9 from BIND 9.1.0 (inclusive) thro…
Fine Tune your automatic Updates for Ubuntu / Debian
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now