Solved

Linux system cannot utilize NIS usernames served by Microsoft SFU 3.5

Posted on 2004-04-12
3
768 Views
Last Modified: 2012-08-14
Hello,

Background:
I have a system with Windows 2003 server installed on which I also installed Microsoft's SFU 3.5 (latest version).   I have set up NIS on the SFU server, and it is set up to serve out the passwd, group, and hosts parameters.

The Linux system has Red Hat Enterprise Workstation 3.0, with the latest updates.  After binding to the domain, I can see the passwd, group and hosts files from the SFU server:
----------------------------------------------------------------
root@cicero home]# ypwhich
sfusrvr.muos-dev.lmms.lmco.com
[root@cicero home]# ypcat passwd
drparmen:ABCD!efgh12345$67890:10000:10000::/home/drparmen:/bin/csh
sdavidov:ABCD!efgh12345$67890:10001:10000::/home/sdavidov:/bin/sh
donrpar:ABCD!efgh12345$67890:10002:10001::/home/donrpar:/bin/sh
[root@cicero home]# ypcat group
Domain Users::10000:sdavidov,drparmen
Domain Admins::10001:donrpar
[root@cicero home]# ypcat hosts
129.197.16.114 SFUSRVR sfusrvr.muos-dev.lmms.lmco.com        sfusrvr.lmms.lmco.com
129.197.16.114 SFUSRVR sfusrvr.muos-dev.lmms.lmco.com        sfusrvr.lmms.lmco.com
129.197.16.114 SFUSRVR sfusrvr.muos-dev.lmms.lmco.com        sfusrvr.lmms.lmco.com
129.197.163.25 cicero cicero.muos-dev.lmms.lmco.com        cicero.lmms.lmco.com
129.197.163.25 cicero cicero.muos-dev.lmms.lmco.com        cicero.lmms.lmco.com
129.197.163.25 cicero cicero.muos-dev.lmms.lmco.com        cicero.lmms.lmco.com
[root@cicero home]#
--------------------------------------------------
However, which I try to use the NIS passwd entries to, say, change ownership of a directory, it tells me the NIS user is invalid, as:
--------------------------------------------------
[root@cicero home]# ls -l
total 8
drwxr-x---   17 donp     users        4096 Apr  6 17:27 donp
drwxr-xr-x    2 root     root         4096 Apr  7 16:09 drparmen
[root@cicero home]# chown drparmen drparmen
chown: `drparmen': invalid user
[root@cicero home]#
--------------------------------------------------

Does anyone have any ideas about what is going on here?  I have checked and rechecked my settings  on the Win 2K3 and Linux systems, and also
combed the Web for some answers, but there appears to be nothing like this.

Thanks for any help!

"donpar"


0
Comment
Question by:donpar
  • 2
3 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 400 total points
ID: 10809824
Does /etc/nsswitch.conf include nis in the list of resources for passwd, group, hosts, etc? For example:

passwd:    files nis
0
 
LVL 1

Author Comment

by:donpar
ID: 10810766
Hello,

I think you're on to something--don't even remember looking at that file.   I'll check the nsswitch.conf file when I get to work in the morning...

Thanks,

donpar
0
 
LVL 1

Author Comment

by:donpar
ID: 10816215

Hello,

That was the problem...  Edited the nsswitch.conf file to add nis to  passwd, group, etc. and the Windows users and Groups are now recognized as valid on the Linux system.  

(Now that nis is fixed, can look into an issue with permissions accessing an NFS mounted file system (from NFS server on Windows system).  I'll pose that as a separate question, though, once I find out more about what might be going on...)

Thanks for your help!

"donpar"
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
what is the size of a TCP segment 10 87
How to enable SSH in Ubuntu. 7 92
reserve ip address for mac address in ubuntu dhcp server 2 56
Help needed with BIND9 DNS on Ubuntu. 22 93
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now