Solved

File Sharing between XP Home and XP Pro

Posted on 2004-04-12
12
343 Views
Last Modified: 2010-04-11
I have a wireless network using a Dlink router and a laptop running XP Home, and my main computer running XP pro.  I have only TCP/IP installed, and can access shared folders on the laptop (XP Home) fine from the other, but no computers on my network can connect to the XP Pro. computer's shared resources, and when I click on its icon in the "Workgroup Computers" I get the error:

"...not accessible.  You might not have permission to use this network resource."

On my main machine I don't recall ever having set up any passwords ort user permissions.   Any suggestions would be greatly appreciated, please.
0
Comment
Question by:earthman100
  • 5
  • 3
  • 2
  • +2
12 Comments
 
LVL 3

Expert Comment

by:brandinius
ID: 10810626
Did you set up the same logon (user ID and PW) on the main desktop as you have on the laptop? In order to share anything in XP Pro, you need to have that user listed on the user accounts, START/CONTROL PANEL/USER ACCOUNTS  - - or if you're using the Category View, START/CONTROL PANEL/USER ACCOUNTS.
0
 
LVL 6

Accepted Solution

by:
parkerig earned 400 total points
ID: 10810636
Hi,
As silly as it sounds you need to first check that file sharing is turned on and work correctly on the machine that isn't able to be connected to. For simplicity I check

(1) Services - Make sure these are running ( don't necessary need all but this is my stock standard cure all)
Computer Browser
Net Logon
Network Connections
Server
TCP/IP Netbios Helper
Workstation
(2) Network Settings
My Network Places
Right Mouse Click
Properties
Confirm Client for Microsoft Network is ticked
File and Print Sharing for MS .... is ticked

You should then be able to access and share the folders.

The message you are getting is one of those Catch All messages and in general not much help - hence back to basics.

Once all the above is checked, if still a problem, please advise as this is just a statring point.

Cheers
Ian


0
 
LVL 6

Assisted Solution

by:parkerig
parkerig earned 400 total points
ID: 10810656
The next stage is to check the local security policies
Go Start Run

secpol.msc /s

and the Local Security Snapin is loaded.
Have a good look at the user rights assignments and see if anything obvious
Have a good look at the security options and see if anything obvious

Also have a quick look at the below links as these users had similar resolved problems

http://www.experts-exchange.com/Networking/Q_20948303.html
http://www.experts-exchange.com/Networking/Q_20950117.html

If still no joy there is more
Please advise
Ian
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 2

Assisted Solution

by:ErnieExpert
ErnieExpert earned 100 total points
ID: 10810659
First - disable the Windows firewall on the XP Pro machine (look here if you need help http://www.microsoft.com/windowsxp/home/using/howto/homenet/icf.asp)

Next,  let's get one key point out in the open.  When accessing a shared folder on a WIndows XP machine, the user is always authenticated as using the Guest user that is built into Windows XP.  Thus we need to check the following settings.
- make sure Guest account is enabled  (right click My Computer, click Manage, click Local Users and Groups, click Users)

- make sure that Guest is allowed Network access by following these step. 1)  open Local Security Policy from Administrative Tools 2) goto Local Policies => User Rights Assignment 3)Add Guest to 'Access the computer from the network' 4) Remove Guest from 'Deny access to the computer from the network' 5) if you made any changes in this step, you should reboot afterwards

-Since you are in a workgroup settings, the XP Pro machine should have turned on Simple File Sharing
The verify: 1) Double-click My Computer 2) On the Tools menu, click Folder Options 3) Click the View tab, and then click to select the Use Simple File Sharing.

-make sure you are sharing a folder.  1) Right click a folder and select haring 2) select the box "Share this folder on the network"
0
 

Author Comment

by:earthman100
ID: 10810777
OK, great. Well I followed all your great advice, from the top to the bottom, and now I can access the shared drives that show up in my network places, however, when I just try to access the root like \\Server or through the "View Workgroup Computers"  I get the same error.  Why is it that I cannot browse the root shares?
0
 
LVL 6

Assisted Solution

by:parkerig
parkerig earned 400 total points
ID: 10810922
To view a root share you normally need admin rights, so unless you have changed the security at the file system level you normally can't browse.

Having run server 2000 on my home pc for years it was very frustrating at first how limited XP sharing is - but then again it is not intended to be a server. Having now used XP for that last year or so I find it very good as a home / desktop OS.

The view workgroups info is often cached and until systems are stable not really reliable. eg If I unplug my computer from network all the info stills shows and is obviously now unaccessible. So wouldn't worry too much at this stage.

Cheers
Ian
0
 
LVL 3

Expert Comment

by:brandinius
ID: 10812831
You can access the root by going to

\\server\c$

(or d$ if you have 2 disks)

0
 

Expert Comment

by:tancy1
ID: 10820738
use this command

\\xppro\sharenames

User ID and Logon popup

login in using xp pro id
0
 

Author Comment

by:earthman100
ID: 10830706
OK, Got a little further tonight.

I had to install IPX on both machines, then on both machines I created a new account with the same name and password which then allows me to browse the network and the shares.  One thing I wonder is, how can I set it to work without defining a password on my PC.  It is annoying having to log on with the password all the time.

Thank you all for your help, this will be tough figuring how to split points.
0
 

Author Comment

by:earthman100
ID: 10830723
Oh yeah, and in Local Security Setings under Security Options I set the:

Network Access: Sharing and Security model for local accounts
to
Classic: Local Users authenticate as themselves
0
 
LVL 6

Expert Comment

by:parkerig
ID: 10831052
There is an option under control panel users to remove the password

( Change an account , select then choose remove password )

This should work.

The fact you used ipx suggests that the IP stack is corrupt.

Cheers
Ian
0
 
LVL 6

Expert Comment

by:parkerig
ID: 10831065
0

Featured Post

Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question