Solved

Cannot install LIRC on Suse 7.0

Posted on 2004-04-13
6
250 Views
Last Modified: 2013-12-15
I'm trying to instal a remote control in linux. I've tried both lirc-0.6.6 and lirc-0.7pre2 but they both won't compile on my Suse box. (Both have the same problem)

Here's the output(I've removed my username and replaced it by ***):
linux:/home/***/Installation/lirc/lirc-0.7.0pre2 # make
make  all-recursive
make[1]: Entering directory `/home/***/Installation/lirc/lirc-0.7.0pre2'
Making all in drivers
make[2]: Entering directory `/home/***/Installation/lirc/lirc-0.7.0pre2/drivers'
Making all in lirc_dev
make[3]: Entering directory `/home/***/Installation/lirc/lirc-0.7.0pre2/drivers/lirc_dev'
DIR=`pwd`; (cd /usr/src/linux/; make SUBDIRS=$DIR obj-m=lirc_dev.o modules)
/usr/src/linux-2.4.21-99/scripts/pathdown.sh: line 4: TOPDIR: parameter null or not set
make[4]: Entering directory `/usr/src/linux-2.4.21-99'
make[4]: *** No rule to make target `lirc_dev.o', needed by `modules'.  Stop.
make[4]: Leaving directory `/usr/src/linux-2.4.21-99'
make[3]: *** [lirc_dev.o] Error 2
make[3]: Leaving directory `/home/***/Installation/lirc/lirc-0.7.0pre2/drivers/lirc_dev'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/***/Installation/lirc/lirc-0.7.0pre2/drivers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/***/Installation/lirc/lirc-0.7.0pre2'
make: *** [all] Error 2

I've checked that /usr/src/linux-2.4.21-99 exists and is filled with the kernel source. Does anybody know what is going on? I've posted this question to several mailing list without any results.
0
Comment
Question by:asciiman
  • 3
  • 2
6 Comments
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10817540
Are you running the make as root?

Have you considered to upgrade your system to something newer version of SuSE? The problem with old systems like yours is that you cannot upgrade to 9.x in one step, you have to go via 8.x.
0
 
LVL 5

Expert Comment

by:willy134
ID: 10818575
/usr/src/linux-2.4.21-99/scripts/pathdown.sh: line 4: TOPDIR: parameter null or not set

what does the pathdown.sh file look like?  What version of the kerneal are you running ( uname -a )do you have the same sourcefile?

try this
 
cd /usr/src/linux
make SUBDIRS=/home/***/Installation/lirc/lirc-0.7.0pre2/drivers/lirc_dev obj-m=lirc_dev.o modules


does that give your the same error?>
0
 

Author Comment

by:asciiman
ID: 10822799
khkremer: Yes I am running this as root.
I'm not trying to upgrade... I just want to install it. Lirc is not included with the suse distro.

willy: My kernel is 'linux-2.4.21-99-default' (what uname reports) , but  the source is in 'linux-2.4.21-99'

I'll paste the pathdown script in here soon. Hope that'll help. And I'll try your suggestion in the process.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:asciiman
ID: 10823222
khkermer: Correction, it is included in the distro, but it was not installed.

willy: Here's the script:
#!/bin/sh
UP=
DN=${PWD:?}
TP=${TOPDIR:?}

while [ ! $TP/$UP/. -ef $DN ] ;do
      UP=`basename $PWD`/$UP
      cd ..
      if [ "$PWD" = "/" ]; then echo "Lost"; exit 1; fi
done

echo $UP
exit 0

And as for the command:
linux:/usr/src/linux# make SUBDIRS=/home/***/Installation/lirc/lirc-0.7.0pre2/drivers/lirc_dev obj-m=lirc_dev.o modules
/usr/src/linux-2.4.21-99/scripts/pathdown.sh: line 4: TOPDIR: parameter null or not set
make: *** No rule to make target `lirc_dev.o', needed by `modules'.  Stop.  

I guess we have found the culprit.
0
 
LVL 44

Accepted Solution

by:
Karl Heinz Kremer earned 250 total points
ID: 10823556
I understand that you are not trying to upgrade, I just suggested that it might be good idea to think about upgrading. 7.0 is pretty old, we are now (almost) at 9.1.

The top level Makefile in your source tree is supposed to set TOPDIR. If this is not done automatically, just set it manually before you run the make:

export TOPDIR=/usr/src/linux
or
export TOPDIR=/usr/src/linux-2.4.21-99


0
 

Author Comment

by:asciiman
ID: 14776052
Had the same problem with Suse 9.0. The solution was a bit odd. Suse includes the kernel source, but does not store the configuration file in this source. The configure script therefore got out of wack. Therefore you should run:

cp /boot/config-(kernel version) /usr/src/linux/.config
cd /usr/src/linux/
make mrporper
make oldconfig
make depend

Next recompile lirc and everything is fine.

I think we should close this question.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now