We help IT Professionals succeed at work.

Number Pad on AIX 4.3.3 running mwm

powellca
powellca asked
on
Medium Priority
1,321 Views
Last Modified: 2013-11-17
I have a network of NCD 88Ks running mwm from my AIX box and all is well.  Due to administration We are putting up WinXP PCs with Cygwin to get to the R/S6000.  This is working fine, except that the numbers on the number pad do not function at all.  The NumLock will toggle the indicator light, but nothing happens with the keys.  The / * - + and ENTER keys all work, nut not the numbers, or .  This is true on all the WinXP PCs and one PC running Red Hat 9.

When I instaled the NCD 88K X stations I had this problem, but was able to get the number pad to work by adding the following to .xinitrc    xmodmap -e "remove mod2 = Num_Lock" -e "add mod5 = NumLock".  Does anyone have any ideas??  Thanks

Chris
Comment
Watch Question

Gns

Commented:
Um, is that remapping in effect  for your Cygwin X sessions too? Have you tried removing it?
On w2k/cygwin
XWin -query aix5.2_host
works OK... But I do realise that things might be (drastically:) different for that;-)

-- Glenn

Author

Commented:
If I get a shell on the Cygwin PC the number pad works fine.  I run the following to get to X on the AIX box:
start XWin -query %REMOTE_HOST% -lesspointer -kb -fp tcp/%REMOTE_HOST%:7100

The -kb switch is needed to get cygwin to work with AIX.

I also get the same behavior executing an rsh from a linux box to AIX.  Now wth that said, all the AIX sessions are using aixterm as the terminal.  I did open and xterm session and the numberpad numbers showed garbage when pressed - and it was the same garbage regardless of the numlock state.

Gns

Commented:
> The -kb switch is needed to get cygwin to work with AIX.
The qualifier should perhaps be "with AIX 4.3.3":-).
It seems to me this is in part what messes things up... When I run with this set, keypad is seriously messed up in xterm and dtterm (5.2 with CDE...), and no reaction whatsoever in aixterm.
Whith it unset, I get a fully working xterm (honouring the Num_Lock) and a dtterm that give numbers etc regardless of Num_Lock state... and still not a twitch in aixterm.
Using VT102 mode for aixterm (-v) correctly gives keypad escapes without Num_Lock, but the letter "X" for all the numbers with Num_Lock... Sigh. Not really wellbehaved:-). Also works pretty strange with vnc.

Are "locked into using aixterm" for some reason? Or could xterm be an alternative?

-- Glenn

Author

Commented:
I ran Xwin -query AIXHOST to start a session without the -kb switch.  The only change I found was that with NumLock active the keyboard was non-functional at the login screen.  If I turned NumLock off I could log in but the behavior was unchanged from when -kb was active.  I started xterm without the -kb switch and the number pad returned text, but was all garbled - regardless of the numlock state.

I am kind of locked into aixterm.  One application we run is character based and and is set for aixterm.  I suppose its possible to get it to run in xterm, but would take some changes to get it to "look right".

Chris
Gns

Commented:
> returned text, but was all garbled - regardless of the numlock state.
Do you still have the "Num_Lock remap" in effect? That lilely would make the numlock key nonfunctional (try the scroll_lock:).

Hm, I'm not giving up on you, but... I'm off to the dentist (removal of "wisdom-tooth"... <Shudder>), so likely wont have time until next week to look at this. It's not helping that I'm so far from the "exact same setup"... hmmm. I wish gheist would join us, I suspect he's got some likely candidate systems to test on (AIX 4.3.3 and cygwin-on-XP instead of 5.2ML2 and cygwin-on-w2kpro).

-- Glenn
Top Expert 2015

Commented:
> One application we run is character based and and is set for aixterm
export TERM=xterms before runing anything inside aixterm, XFree86 uses a bit different key codes.
Gns

Commented:
Seems like aixterm is rejecting the KP_# ... If you "xmodmap -e 'keycode 79 = KP_Home 7" (instead of KP_7), you should get the numeral. Ugly. BTW gheist, on my setup, setting xterms didn't help.
BTW, do you get working arrow keys? I don't.

-- Glenn

Author

Commented:
Another Monday .....

Well, setting TERM=xterms had no effect.  I tried the xmodmap command, and that had no effect either.  I don't get any response from the 10 number keys or . (del) key regardless of numlock state.

I know this is probably an unanswerable question, but where are the places the mapping could be altered?  I can only guess that there is something, somewhere changing the mapping.

Chris
Gns

Commented:
Check this:
Start the XWin ... as usual
Open a terminal emulator (any:-), and allow the PC running cygwin to connect to the display:
xhost + localhost
start a cygwin bash shell in windoze
in that shell, set display and start an xterm with
export DISPLAY=:0
xterm
in the xterm (that should end up on the cygwin X session) start the xev application
place the mousepointer inside the "event window"
press one of the keypad keys... What keycode/keysym combination does it report? (read the text in the xterm...)

-- Glenn

Author

Commented:
When pressing the 7 (home) key I get:

keycode 79 (keysym 0xff95, KP_Home)

Chris
Top Expert 2015

Commented:
and what does same action from old terminal show ????
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Thank you - The above worked almost flawlessly.  The only key not working is keycode 91 . del  This now just prints garbage - but it does print something.  The keys work as numbers regardless of the num_lock state - but thats not a problem for me.  Thanks for the time, hope the points help.
Gns

Commented:
:-) ... Points are such ... edible things:-)
Take care.

-- Glenn
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.