[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 410
  • Last Modified:

Xfree slow the start

Hello

I've just installed Xfree-4.4 from source, all went well.  When I hit 'startx' the system now, and in the past, is set to boot into KDE.  

But I now have a situation whereby Xfree takes a maybe 30sec to start after typing 'startx'   And when the KDE screen appears the system continues to go slow.   Folders and pieces of txt can take 15 sec to appear.  Any idea what can cause this, I've never had it before?  The log files don't appear to show any errors.   What's going on?

MAC
0
cliffhanger121599
Asked:
cliffhanger121599
  • 4
  • 3
1 Solution
 
gheistCommented:
Client libraries are from different version, this makes some compatibility code used.
You built in suboptimal manner, so it is very slow (gcc -g or so)
Whats going on - it works the way you made it...
0
 
cliffhanger121599Author Commented:
Sorry, don't understand.   Xfree was built with the following optimisation in xf86site.def(I assume this is what you are refering to):

 #define DefaultGcc2i386Opt  -O2 -fomit-frame-pointer -march=i686

If not, how would you build it??

MAC
0
 
gheistCommented:
I never build it, I use packages....
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
cliffhanger121599Author Commented:
I said the log file had no errors?   This is right at the beginning:

  XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/Cliffhangers:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

The rest looks normal

Any ideas???

MAC
0
 
gheistCommented:
start XFree86 without tcp listener
add -nolisten tcp parameter to X in Xservers files in
/etc/X11/xdm
/usr/X11R6/lib/X11/xdm
/usr/lib/X11/xdm
/usr/share/config/kdm
or somewhere else your X looks for Xservers file.
You will lose capability to export DISPLAY=your_host:0 to get remote access (and close one listening tcp port)

There might be a problem with name to address resolution against nameserver too, basically check out if your host name(s) is resolvable from /etc/hosts, 45 second timeouts are characteristic in this case.
Seems like yours look up inet6 address of your host which is not possible via your nameserver???
I do this in /etc/hosts
127.0.0.1 localhost localhost.my.domain hostname hostname.my.domain
::1 localhost localhost.my.domain hostname hostname.my.domain
10.10.10.10  dns-hostname dns-hostname.my.domain
so all interprocess trades are kept inside host itself

If you help me with uname -a from your system (feel free to remove host name), I will help you more with name resolution configuration.
0
 
cliffhanger121599Author Commented:
That's it!   The problem was name to address resolution against nameserver.   I had the follwing in /etc/hosts:

127.0.0.1 www.linuxfromscratch.com hostname localhost

I have no network card at present.   It worked with XFree 4.2, why not with 4.4?

Anyway the points are yours

thanks

MAC
0
 
gheistCommented:
because 4.2 did not support inet6 address family...
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now