certification authority

I am having an issue with my server certificate, I installed CA service so that I can make and issue my server certificate.  I followed the instructions as per Microsoft’s website and all seems well from the server at least

Now when I have another box (not the server) connects to my web site: example: http://whatever.domain.com/. They get a “Security Alert” no problem there I guess.
It has a message that says:
“The server certificate was issues by a company you have not chosen to trust. View the certificate to determine whether you want to trust the certifying authority.”

Then at the end when it asks me if I want to proceed I have the options of ‘yes’, ‘no’, ‘view certificate’

When viewing the certificate in the General Tab it reads:
This certificate cannot be verified up to a trusted certification authority.
In the Certification Path is says all is OK.

I don’t know why this is happening because my server that also has the web server on it is the “certification authority”.

Also even when I install the certificate and revisit the site I get that pop up prompt

So… to make a long story short, I need some help (hand holding  ... walk through type of help).

I need to get this working in less than 8 hrs.
LVL 1
weguardyouAsked:
Who is Participating?
 
Tim HolmanConnect With a Mentor Commented:
>When viewing the certificate in the General Tab it reads:
>This certificate cannot be verified up to a trusted certification authority.
>In the Certification Path is says all is OK.

This means that your certificate isn't trusted by any of the authorities that appear under this section of the web browser:

Tools > Internet Options > Content > Certificates

..this is normal behaviour, as your self-signed certificate has not been approved by higher sentient beings yet.  As soon as you get a proper server certificate from somewhere like Verisign, this will continue to be an issue.
Nonetheless, your SSL session is still safe and encrypted as long as you don't go giving away your keys to anyone !


0
 
JaniceLawCommented:
The problem you are having is the CA itself is not trusted by the web browser. What you have at the moment is a self-signing certificate. Basically, you are telling the web browser to trust you because you trust yourself. For solutions, look at the question below.

http://www.experts-exchange.com/Networking/Q_20950930.html
0
 
weguardyouAuthor Commented:
Well that doesnt do it for me.  you see even when i test with my remote clients and install my certificate into their browser manually.
When i close out and revisit the site.  The same thig happens.  I get that pop/up again.
0
The Lifecycle Approach to Managing Security Policy

Managing application connectivity and security policies can be achieved more effectively when following a framework that automates repeatable processes and ensures that the right activities are performed in the right order.

 
JaniceLawCommented:
Can you check something for me? After you install the certificate, double click on the lock icon and tell me what you find in the Certification Path. Also select the root entry and click on view certificate and what you have showing under the general tab.
0
 
weguardyouAuthor Commented:
Yes, I understand that now.  But my thing is this:  Even when a person on a remote system installs the certificate to their browser. And later on revisit the site, they again receive that message popup.  Is that normal?  In my thinking I was under the impression that it would no longer pop up that message.
0
 
Tim HolmanCommented:
Yes, this is normal.
I believe you can change this default behaviour by altering IE advanced settings, but then this isn't what 'the masses' should be expected to do just to be able to view your website, so again your forced down the valid, trusted certificate route...

IE > Tools > Internet Options > Advanced - 'warn about invalid site certificates'
0
 
jermsmitCommented:
One solution is to get a cert from a root authority, this should allow you to give out certificates under your name to others and they will be valid due to a trust relationship.
 
0
 
Tim HolmanCommented:
Any reason this last comment was accepted as an answer ??  
0
 
huntermisCommented:
It's funny that the FireFox browser will install the certifiicate and will not prompt you again upon returning to the site while IE forces you to click "yes".  They don't even give you the opportunity to add the CA as a trusted source.  I guess I will have to spend a little dough.
0
All Courses

From novice to tech pro — start learning today.