Solved

Updated glibc packages for redhat 9

Posted on 2004-04-15
8
604 Views
Last Modified: 2013-12-15
I tried to download some patches from:
https://rhn.redhat.com/errata/RHSA-2003-325.html#Red%20Hat%20Linux%209
to update my redhat 9.

When I tried "rpm -i glibc-common-2.3.2-27.9.7.i386.rpm", the screen said the package conflicts with file from package glibc-common-2.3.2-11.9.  I supposed "glibc-common-2.3.2-11.9" is the current glibc package in my redhat 9. But because of lots of dependencies, I can not remove "glibc-common-2.3.2-11.9".

What I need to do to do the sucessful upgrade? Another question is there are quite a lot of package files of glibc, e.g. glibc-2.3.2-xx.rpm, glibc-common-2.3.2-xx.rpm,glibc-debug-2.3.2-xx.rpm, glibc-devel-2.3.2-xx.rpm etc and etc. What are these different packages for?
0
Comment
Question by:victorli
8 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 10839174
What you really need to do is to use up2date against RedHat's servers or Yum (see http://linux.duke.edu/projects/yum/) to do this update. There are a number of files involved, and not just those that begin with glibc.
0
 
LVL 1

Author Comment

by:victorli
ID: 10839470
Thanks jlevie, I browsed the url of yum and downloaded a .rpm file and a .tar.gz file. But it seems there is no examples explain how to install or how to use it. Could you please give me a quick example?

Regards
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10840640
rpm -ih yum-2.0.6-1.noarch.rpm to install. Then follow
http://www.phy.duke.edu/~rgb/General/yum_HOWTO/yum_HOWTO/yum_HOWTO-10.html to use it.
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 3

Expert Comment

by:tolgadalkilic
ID: 10847188
try installing your updated packages as:
rpm -Uvh glibc-common-2.3.2-27.9.7.i386.rpm

this means upgrade the package.

If you want to use yum type package manager, try SYNAPTIC
it is X-based, graphical tool, checks dependencies and does a lot of things more.
0
 
LVL 1

Author Comment

by:victorli
ID: 10851446
thanks everybody, I will try what you suggested on Monday and get back to you later.
0
 
LVL 1

Author Comment

by:victorli
ID: 10855206
(1) when I tried "rpm -Uvh glibc-common-2.3.2-27.9.7.i386.rpm" the screen said:
V3 DSA signature: NOLKEY, Key ID ....
dependicies:
glibc-common=2.3.2-11.9 is needed by (installed)  glibc-2.3.2-11.9

(2) After installing Yum, I tried "yum upgrade glibc-common-2.3.2-27.9.7.i386.rpm" but the screen said:
Cannot find any package matching glibc-common-2.3.2-27.9.7.i386.rpm available to be upgraded.

for (1), I use rpm to query and found glibc-common-2.3.2-11.9 package has been already installed.
for (2) I checked the documentation but still not get through, could you please give more detailed instructions? Thanks.


0
 
LVL 40

Accepted Solution

by:
jlevie earned 150 total points
ID: 10856424
(1) isn't going to work because of dependancies. As I said earlier there are several packages that are needed, including at least:

glibc-2.3.2-27.9.7
glibc-common-2.3.2-27.9.7
glibc-utils-2.3.2-27.9.7
nscd-2.3.2-27.9.7

and possibly:

glibc-debug-2.3.2-27.9.7
glibc-devel-2.3.2-27.9.7
glibc-profile-2.3.2-27.9.7

depending on what's currently installed. And to make it a bit more complex it is important to upgrade with the correct CPU architecture RPM's.

As to (2). What you should do, with yum installed, is to simply execute 'yum update' and allow it to update all outstanding errata.
0
 
LVL 1

Author Comment

by:victorli
ID: 10864630
Thanks, everybody.
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Linux Mint 18 31 89
AWS - HAProxy- KeepAlived 5 42
nagios 4 php error after installation 6 92
Run same command on multiple files in Linux 3 31
Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question