Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Windows Messenger & .NET Passport Automatic Sign-In

Posted on 2004-04-15
2
Medium Priority
?
6,546 Views
Last Modified: 2008-01-09
This is more of an FYI than a Question.

I was having a problem similar to that described by others:   Windows Messenger 4.7 was signing me in automatically (according to one of my Contacts who saw me online) every time I boot the machine, even though I see no evidence of having started Messenger (no icon, no startup box, etc.).  But the Services section of the Task Manager reveals that Messenger (msmsgs.exe) is indeed started.   Messenger only lets me sign out -- I cannot exit because it says "other programs" are using it.  With Office 2002, that is only a problem if Messenger was enabled in Outlook, and once you clear that checkbox, you're fine.  In addition, Norton Antivirus sometimes disables its auto-protect on boot (because, on occasion, this automatic loading of Messenger starts before NAV).

I'm running XP Professional, NOT using Outlook 2003, already clicked the options in Messenger to clear "Run this program when Windows starts," and I want to be able to manually start Windows Messenger 4.7 when I wish.

Checked out all of your very helpful suggestions from a post on March 6, 2004
http://www.experts-exchange.com/Operating_Systems/WinXP/Q_20909399.html
(including the MS Support links), and the answer appears to be two-fold:

When I set up my new box, I vaguely remember that I associated my MSN Messenger name with their .NET Passport wizard because it asked.  Stoopid me.

You have to jump through some hoops to get to the .NET Passport Wizard again.  Easy to set up the association, not so transparent to get rid of it, and you'll need Admin Rights.

1) Go to Start Menu - Settings - Control Paner - User Accounts
2) Click on the User Account you want to change
3) Click on "Change my .NET Passport."
4) In the Related Tasks area on the left, Click "Manage my Network Passwords."
5) Select and remove any Passports listed.
6) Reboot.

This should clear the email address from your Passport, so that you can log in and out manually.

But wait, there's more....If you're using Norton Antivirus, and if you have Enabled it to protect your Windows Messenging in the Instant Messenger options, YOUR COMPUTER WILL CONTINUE TO LOAD "msmsgs.exe" AND you will not be able to Exit Windows Messenger.  In fact, Norton Antivirus was the program that was using and would not let me exit Messenger.

Clear that Norton setting (but make sure you manually scan any attachments sent to you via IM), and the problem is solved.  Your passport will be associated with your User Account in XP, but only as an anonymous login (i.e., you should no longer see your email address when you go to change your .NET Passport settings of your User Account).

Hope this helps someone.   Your insightful comments have helped me more than once.
0
Comment
Question by:ewiseman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 2

Accepted Solution

by:
dsvarups earned 540 total points
ID: 10840115
Open your registry and find the key below.
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger\Client]

Create a new DWORD value for each of the optional restrictions from the table below. Set the value to "1" to enable the restriction or "0" to disable it.

PreventAutoRun - Do not automatically start Messenger  - 1
PreventRun - Do not allow Messenger to run  - 1

Restart Messenger for the changes to take effect.
Note: This tweak is applicable to MSN Messenger 4.x, this restriction has been removed from version 5 of the software.

Registry Settings
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger\Client]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Messenger\Client]
Value Name: PreventAutoRun, PreventRun
Data Type: REG_DWORD (DWORD Value)
Value Data: (1 = enable restriction, 0 = default)

This has worked for me although if you upgrade Messenger to 5 or later this will not work.
0
 

Author Comment

by:ewiseman
ID: 10845727
Thanks.  I'll re-enable NAV's IM protection and give it a shot.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are 2 things you must have in order to connect to the internet behind a router, The "Gateway IP" of the router, which is usually something like 192.168.xxx.1, I've seen routers with default values of: 192.168.0.1, 192.168.1.1, 192.168.11.1, …
If your system is showing symptoms of browser hijacks or 'google search redirects' check out my other article (http://rdsrc.us/u3GP7A) first and run the tool TDSSKiller (http://rdsrc.us/GDBBs4) to get rid of the infection. Once done, and if the …
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question