Solved

linux incoming connection

Posted on 2004-04-16
7
313 Views
Last Modified: 2010-03-18
If I'd like to allow certain remote hosts to log into my linux box, how do I specify those hosts (i.e. allow remote login)?   Can I type a command from a bash shell or do I save the name/ip, username of remote host in some file, and if so, which one is it and how can I specify?   Please let me know.
0
Comment
Question by:skyblue01
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 8

Expert Comment

by:da99rmd
ID: 10840850
What service ftp etc. are you trying to stop allow access to ?
And  what linux distro are you using ?

/Rob
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10841631
You would put their hostnames (or ip addresses) in /etc/hosts.allow and put ALL:ALL in /etc/hosts.deny
0
 
LVL 8

Assisted Solution

by:da99rmd
da99rmd earned 50 total points
ID: 10841807
But thats just for indet.d and xinet.d services.

/Rob
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 

Author Comment

by:skyblue01
ID: 10851478
>What service ftp etc. are you trying to stop allow access to ?
>And  what linux distro are you using ?

I'm just trying to allow ssh access from my windows box(say, hostname windows) to my linux box and was trying to setup the linux box to accept such incoming connection.   In my windows box, when I initiate an ssh connection to linux, I'll be needing a login name and a password.   This needs to be set up in linux, right?   How would I do that?

I'm using FedoraCoreI

>But thats just for indet.d and xinet.d services.

What do you mean by that?   You mean what I said above doesn't apply to /etc/host.allow and /etc/host.deny?
0
 
LVL 17

Accepted Solution

by:
owensleftfoot earned 300 total points
ID: 10853077
For ssh access all you need to do is make sure sshd is started. Its usually installed by default.Issue the command "chconfig sshd on" - if you get an error you will have to install the openssh-server rpm from your fedora installation cdroms. Then reissue the previous command. Then issue the command "service sshd start" to start the ssh server. Adding a user is simple. "useradd windows" will add a new user called windows. "passwd windows" will allow you to set the users password. To use ssh you will need an ssh clent for windows.
You can get a good free one at http://www.chiark.greenend.org.uk/~sgtatham/putty/

The bits about hosts.allow and hosts.deny were because I thought you wanted to only allow access to certain ip addresses. As da99 says this only applies to services run with the xinetd superserver. However most servers can be started from there - sshd included. But I guess you dont need hostbased authentification.
0
 

Author Comment

by:skyblue01
ID: 10854480
Thanks for the detailed explanation.   I'll see what I can do.
0
 
LVL 8

Expert Comment

by:da99rmd
ID: 10857335
You dont have to do a computer specific account to allow/disallow access you can as its described above access this account from anyware.

If you want to just be be able to access the sshd from you linuc computrer you have to block it in your firewall.
do you have a firewall running at this moment ?
If you want help setting up the rule just post back.

/Rob
 
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question