Solved

Internet Explorer 6 cannot open secure sites (SSL)

Posted on 2004-04-16
32
50,286 Views
Last Modified: 2012-06-21
Hello,

I have a mysterious problem here. I cant access any secure sites. (SSL)

I am running IE6 on Windows 2003 Enterprise Server machine.
All updates WERE up-to-date. Cause I cant access windows update now. I tried to reinstall. But no solution.

When I look in HELP box it says :

Version : 6,0,3790,0
Cipher Strenght : 0
Product ID: 69...........
Update Versions : 0

Moreoever I cant access Add/Remove Windows Components:
It says : Setup librari iis.dll could not be loaded, or function OcEntry could not be found. Contact your system administrator. The specific error code is 0x7e.

But when I remove iis starting line in sysoc.inf it works. But I dont like the idea.

Any idea experts?
0
Comment
Question by:masirof
  • 18
  • 7
  • 3
  • +2
32 Comments
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10841704
This is the WindowsUpdate troubleshooter, which may get us started.  Have you tried changing IE to all the default settings?  Are you behind Firewall?  Any idea what you did last?  Is TLS checked in IE ?  Was your cypher strength once at 128?

http://v4.windowsupdate.microsoft.com/troubleshoot/

Tested for worm/virus/trojan, Spyware and/or Browser hijacking activities?

More when I can, shortly.
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10841827
I'm having a tough time finding the specifics for your W2K environment; but this does have your change in cypher strength 0; check the link for more detail and applicability to you:
CAUSE This behavior can occur if the Schannel.dll, Rsabase.dll, or Rsaenh.dll files are missing, damaged, or of the incorrect version.
RESOLUTION To resolve this behavior, use the method that is appropriate for your operating system.  More at this source:
http://support.microsoft.com/default.aspx?scid=kb;en-us;261328&Product=ie600

---

Re. the version and ZERO updates, very strange.  Did find these resources, though.  Again, please check the link for applicability and full detail for your environment.  This is only one brief synopsis:
To install the Internet Explorer 6 for Windows Server 2003 versions of this update, you must be running Internet Explorer 6 (version 6.00.3790.0000) on Windows Server 2003 (32-bit or 64-bit) or you must be running Internet Explorer 6 on Windows XP 64-Bit Edition, Version 2003.  more on variables here....
http://support.microsoft.com/default.aspx?scid=kb;en-us;828750&Product=ie600
MS03-040: October, 2003, Cumulative Patch for Internet Explorer

and more here...

http://support.microsoft.com/search/default.aspx?InCC_hdn=true&Catalog=LCID%3D1033%26CDID%3DEN-US-KB%26PRODLISTSRC%3DON&withinResults=&QuerySource=gASr_Query&Product=ie600&Queryc=6.0.3790.0&Query=6.0.3790.0&KeywordType=ALL&maxResults=150&Titles=false&numDays=&InCC=on


0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10841922
0
 
LVL 6

Author Comment

by:masirof
ID: 10842116
I will try these now
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 10842149
masirof,

Asta should have given you the solution by now..


Also check these

a) IE .. go to tools --> Internet options --> advanced and scroll down to security and enable SSL

Check SSL 2.0 and SSL 3.0

b) Donot set your security settings too high.. Check this
http://www.microsoft.com/windows/ie/using/howto/security/settings.asp

c) Check this
http://support.microsoft.com/default.aspx?scid=kb;en-us;813444

d) HOW TO: Troubleshoot Situations Where You Cannot Complete MSN Sign-up OR Connect to SSL Secured (128-Bit) Web Sites by Using Internet Explorer in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;813444

************************
The following is the database I had created for windows update issues. Check them aswell

Windows Update Scan for Updates Stops Responding at 0%
http://support.microsoft.com/default.aspx?scid=kb;en-us;812956&Product=w98

Errors Occur When You Try to Install Updates from the Windows Update Web Site
http://support.microsoft.com/default.aspx?scid=kb;en-us;817753

http://support.microsoft.com/default.aspx?scid=kb;en-us;318892&Product=wupd

Windows Update Troubleshooter
http://v4.windowsupdate.microsoft.com/troubleshoot/

Windows Update Is Not Installed
http://support.microsoft.com/default.aspx?scid=kb;en-us;811269

OEM files solution
http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q281967&ID=KB;EN-US;Q281967

Comprehensive Microsoft Trouble-Shooter
http://support.microsoft.com/default.aspx?scid=KB;en-us;q303399

Temporarily Remove content of IE Uninstall Folder
http://computing.net/windowsme/wwwboard/forum/30205.html

*******************************

0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10842225
I just cannot find all the errors you've posted above nor the problems specifically to any one product, sorry to admit.

Here are some links, one in particular about the most recent April update Security-wise, if it sheds some light.
http://www.microsoft.com/technet/security/bulletin/winapr04.mspx
http://search.microsoft.com/search/results.aspx?st=a&View=en-us&s=5&qu=windows%202003%20server%20can't%20access%20add%20remove%20programs


SharePoint Portal Server 2003 and Windows SharePoint Services currently do not support SSL termination
http://support.microsoft.com/default.aspx?scid=kb;en-us;831106

0
 
LVL 6

Author Comment

by:masirof
ID: 10843111
Nothing helps :((
Also I have .NET Studio installed. I think problem started by then.
I joined our corporate domain, and then when I realized that I had problem I exit it again.
Problem persits :(
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 10843120
Not sure if server 2003 has got system restore feature like xp . If yes , try that ..
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10843245
Which Service Packs installed for Net.studio?  This shows you some of them in the download options:
http://search.microsoft.com/search/results.aspx?View=msdn&p=0&s=1&c=&st=b&qu=net.studio+internet+explorer+6&na=54
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10843284
Is it possible that you're using passport and there's a login problem for you?  Here's some reference to that, if it helps.
http://support.microsoft.com/default.aspx?scid=kb;en-us;315734
0
 
LVL 6

Author Comment

by:masirof
ID: 10843959
I dont know what to do. I tried everything though. I have installed 2003 a few days ago and I do not want to go that painfull installation process again :((
Do you think this is the only solution?
0
 
LVL 6

Author Comment

by:masirof
ID: 10843971
And one tip more:
I installed 4 service packs which were rated critical and were published 2 or 3 days ago. And after that I installed .NET (removed already.)
Should I try to unistall SPs??
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10844876
Sometimes the problems are really tough to isolate.  Sometimes the most bizarre things help resolve roadblocks, such as
Multiple Reboots

The fact that you had everything up to date with updates before and now they're "missing" leads me to believe that you have some corruptions.

For the Operating System, or the server side, can you scan the Logs for errors and problems noted there?

Have you tried pasting one sample https:// URL into the Privacy tab of IE 6 choosing the edit and pasting the URL, choosing allow again and then closing IE and testing that link again?

Back to WindowsUpdate after multiple reboots and clearing cache again as well as renaming hosts file to oldhosts to test, as well as http://www.officeupdate.com for office-side of things that may be configured elements in IE may help.

More when I can.
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10844885
Also, checking the MS Download site, choosing your default language and specifics from the left may help in terms of updates that you may not be seeing or that were installed and updated in the registry but since corrupted:
http://www.microsoft.com/downloads/search.aspx?displaylang=en
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10844929
You said you installed and removed .net .... do you mean passport.net or .net framework?  The latter has some issues, you'll find here:
http://support.microsoft.com/search/default.aspx?InCC_hdn=true&Catalog=LCID%3D1033%26CDID%3DEN-US-KB%26PRODLISTSRC%3DON&withinResults=&QuerySource=gASr_Query&Product=NETFrame&Queryc=uninstall&Query=uninstall&KeywordType=PHRASE&maxResults=25&Titles=false&numDays=&InCC=on

Also this for IE 6 ...
Changes to Restricted sites Zone Settings
The following "Restricted sites" zone settings have been changed:
The Active Scripting setting is set to Disable, and your previous setting is not retained.
The Java Permissions setting, which is located under the Microsoft VM heading, is set to Disable Java, and your previous setting is not retained.
The "Script ActiveX Controls marked as safe for scripting" setting is set to Disabled, but your previous setting is retained.
The "Allow Meta Refresh" setting is set to Disabled.
NOTE: By default, the "Restricted sites" zone is used by Microsoft Outlook Express 6, and can be used by Microsoft Outlook to restrict active content in Hypertext Markup Language (HTML) e-mail messages.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
182569 Description of Internet Explorer Security Zones Registry Entries
More here.....
http://support.microsoft.com/default.aspx?scid=kb;en-us;300443&Product=ie600

Sorry for all the segmented responses, but am very busy and want to get you the help I can when I can.
0
 
LVL 6

Author Comment

by:masirof
ID: 10848287
astaec, your responses have been helpful, but problem is not solved yet.
Now I principially want to resolve this question.
And one thing, I stopped some services and set them to manual and I dont know which ones now.
But I restarted most I remembered, including Cryptographic Services and HTTP SSL service.
I read in your posts that Cryptographic should be started, and its started.

Is it really that I have to reinstall 2003?
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 27

Accepted Solution

by:
Asta Cu earned 200 total points
ID: 10849308
I'm sorry to hear the problem persists.  Personally, I would not do a reinstallation, if not needed and can be resolved in other ways.  But only you would know best in terms of timing and requirements how long you can investigate the problems.  I've asked other Experts to look here and hope they have some additional insights for you.  I've found some additional resource links in the hope it helps with the Windows Server 2003 environment; such as feature packs and more info, and sharing that below.  These all include additional hyperlinks for more information so that you can pick and choose the links which best describe your environment and needs.
http://www.microsoft.com/windowsserver2003/downloads/featurepacks/default.mspx
http://www.microsoft.com/windowsserver2003/downloads/updates/default.mspx
http://www.microsoft.com/technet/security/default.mspx
Windows Server 2003 Tools links
http://www.microsoft.com/windowsserver2003/downloads/tools/default.mspx
Deployment kit as well as Technical REference links
http://www.microsoft.com/windowsserver2003/techinfo/reskit/deploykit.mspx
http://www.microsoft.com/resources/documentation/WindowsServ/2003/all/techref/en-us/default.asp

Authorization and Access Control Technologies
http://www.microsoft.com/resources/documentation/WindowsServ/2003/all/techref/en-us/Default.asp?url=/resources/documentation/windowsServ/2003/all/techref/en-us/w2k3tr_sec_authz_over.asp

I hope others better versed in this environment will step in here to shed light on the roadblock for you.  I'll return when I can to check on progress.

Asta
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10849328
I'd also look through the topic area below which is specific to the Windows Server 2003 environment, since others may also have this problem.
http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/

I've posted a 50 point question there on your behalf in the hopes Experts will step in here to help you further.  Here is that request:
http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_20957561.html

Asta
0
 
LVL 6

Author Comment

by:masirof
ID: 10858077
Thanks,
It is solved mysteriously as well, I did some updates, uninstalled some updates.
But computer is very slow, I think I will reinstall it.
Thanx again :)
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10858525
Thank you for the update and "B".  The mysteries always get to me, to say the least in terms of troubleshooting.  Sometimes the strangest events solve problems, not the least of which is the rebooting multiple times; and updates, done before that didn't help do help when done again.  Sometimes it isn't "what" is done so much as the order in which they are done, since system files can be overwritten by install routines and tough to find (older dlls replacing newer ones, etc).  

As regards the performance issue which persists for you (slow, as you say) ... and that you think you'll reinstall.  It "may" help, but you did say at the onset ...
"I tried to reinstall. But no solution." .... with that in mind, unclear if this will help you.  Frequently reinstallations do help, but also mean service packs and other add-ons require reinstallation as well.

If you'd like to continue the collaboration effort here to troubleshoot the "slow" issue, just comment and I'll respond when I can.  It also helps to note what all is running in the background at the time the performance goes down to see if we can find the culprit (perhaps a memory leak in a poorly written program, sometimes if applications are stopped before they load completely, they remain in memory and increase resource drains,etc.) ....  checking logs may also help.

Listening further when time permits.

Asta

0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10858541
Just as a quick overview for IE 6 and "slow"; these may add some insights
 Text Input May Be Slow If You Use the Japanese Input Method Editor
 (314312) - If you use the Japanese Input Method Editor (IME) to type Japanese text in a text area that is embedded in a table, it may take a long time for the characters to be displayed on the screen.
 
 Internet Explorer Cannot Download Office Documents from an IIS Server When Content Expiration Is Set to Expire Immediately
 (317208) - When you try to download Microsoft Office documents from a server running Internet Information Services (IIS) to a client using Microsoft Internet Explorer version 6, you may receive the following error messages: Internet Explorer cannot download...
 
 "Page Cannot be Displayed" or "Timeout" Error Messages When Browsing the Internet
 (262264) - When you are connected to the Internet and you attempt to reach Web pages, you may experience the following behaviors: You may receive "Page Cannot be Displayed" or "Request Timed Out" error messages while browsing in either Internet Explorer or other...
 
 Microsoft Internet Explorer may stop responding for up to six minutes
 (833301) - Describes a problem with Internet Explorer that stops responding when it uses Wininet to connect to a Web server. You can work around the problem by setting the timeout value in IIS to a time that is longer than the timeout value on the client.
 
 Internet Explorer Appears to Stop Responding When You Start It
 (220902) - Microsoft Internet Explorer may appear to stop responding (hang) when it opens, but the animated globe in the upper-right corner of the browser window may continue to spin, and you may receive a "Detecting proxy settings..." message in the status bar.

More here...  http://support.microsoft.com/search/default.aspx?InCC_hdn=true&Catalog=LCID%3D1033%26CDID%3DEN-US-KB%26PRODLISTSRC%3DON&withinResults=&QuerySource=gASr_Query&Product=ie600&Queryc=slow&Query=slow&KeywordType=PHRASE&maxResults=150&Titles=false&numDays=&InCC=on
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10858552
0
 
LVL 6

Author Comment

by:masirof
ID: 10859473
Thanks.
I have a newly installed OS now.
Installed all updates and it looks just fine now.
But have not installed .NET Studio. I am afraid :)
"B" was just to say for answer seekers tell that solution here specified is not exact solition. If upcomes to someone else.
I checked your profile, cool. Check mine ;)
Thanks again.
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10860457
Good morning, masirof.  

Checked your profile and you're kind of new to this site; welcome!  Didn't see any details about yourself in the Profile other than your question participation but it looks like you are into a broad spectrum of technical issues.  Thanks also for updating this question and confirming that the reinstall helped you resolve this and the kind words.  ":0)   ...  Typically a reinstall of any kind "can" impact service packs and fixes, so you may want to review WindowsUpdate again and check to see what may be needed and/or missing.  On the other hand, some recent IE 6 updates have caused "some" issues for "some" users with "some" configurations.  Isn't computing fun?  The adventures and troubleshooting hurdles never stop.

Have a great day, I'll return when I can, if more is needed.

Best wishes,
Asta
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10860546
I also noted in another question of yours that you have Office 2003 and had to reinstall it.  Another package that "may" have updates to download and install.  For that check here, and have your Office disks handy, if needed.

http://office.microsoft.com/officeupdate/
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 10868289
In researching another problem, found this (brief synopsis) ... sounds quite similar, no?

" Indications of Infection  - More here at the McAfee source link:  
 
Parasitically infected files, increasing in size by 65,555 bytes.
Existence of the Registry key detailed above.
------------------->  Missing critical system files (May onwards) indicating delivery of virus' payload.  "
http://us.mcafee.com/virusInfo/default.asp?id=description&virus_k=104469
0
 

Expert Comment

by:fhoitz
ID: 11299517
Hi... I am experiencing the exact same problem on server 2003, ie. unable to open SSL sites and add/remove windows components. It occurred when I installed KB835732. I've contacted MS and they also saw this before:

Issue:
When installaing MS04-011 (KB835732) on Windows Server 2003 (Standard and Web Editions), the installation would hang at "Copying LSASRV.DLL...".  The last line in the KB835732.log is: AtomicReplaceFile: Calling HpReplaceSystemModule(C:\WINDOWS\System32\lsasrv.dll, Hxxxxx.tmp, _000019_.tmp, FALSE ).

Technical briefing:
This should be the file done after SCHANNEL.DLL.  The system was hung and unresponsive except to the "Windows Security" window using
Ctrl+Alt+Del and to load task manager.  At this point, the system has to reboot. Using MSConfig to disable all third-party services and startup routines, the installation would still hang The temporary fix to get back into the OS was to boot to "Last Known Good..." and uninstall the KB835732 Hotfix.

Solution:
We found that Kaspersky Anti-Virus had to be completely uninstalled to allow the installation to be completed successfully. Once the AV was completely uninstalled, the security update could be installed. However, SChannel.dll was not installed by the security update as there was no file there to update. At this point, no SSL (HTTPS) would load. We then had to copy the Schannel file from the extracted files of the KB835732 hotfix.


The system hung at boot, so using recovery console I've copied lsasrv.dll into dllcache so I could boot into the OS again. I have also re-registered all IE6 DLLs again, but to no avail... I'm now stuck... any ideas????
0
 

Expert Comment

by:fhoitz
ID: 11299789
Ok, Ok, Ok... the solution:

Extract WindowsServer2003-KB835732-x86-ENU.EXE using the /x switch from Run command to a temp directory and copy schannel.dll to system32 folder. All is well again! ;o)
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 11301522
What a fiasco this has been; thanks for posting the details which can help others, along with the solution you found and implemented.

Asta
0
 

Expert Comment

by:pbgormley
ID: 12004542
fhoitz,

I have the exact same problem as you - Windows Server 2003/Exchange 2003 with Kaspersky and I cant view SSL websites, Windows Update, Add/Remove Programs, I get the SCHANNEL.DLL errror !!

Could you possible help me here - I'd be willing to open a new question worth whatever points you like or is there a method of transferring points ?
I really need help, cheers mate.

pbg
0
 

Expert Comment

by:pbgormley
ID: 12007175
fhoitz,

I've since opened this http://www.experts-exchange.com/Web/Browser_Issues/Q_21123120.html woth 500 points, help !
0
 

Expert Comment

by:fhoitz
ID: 12007387
Hey there... well, really, the solution is given already above, but here it is again... just go to the corporate Windows Download and search for KB835732 and extract it via Start-Run and type in the path and file name followed by /x.

This will extract the contents of the package to a temporary location of your choice. Just copy the schannel.dll to your system32 folder, reboot and all is well again.

Sometimes you may have to uninstall Kaspersky completely though before doing the above.. Hope this helps! Chao, Frank ;o)
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

How many times have you been browsing the internet, with multiple tabs open, and closed the wrong one? Have you ever clicked 'Close all tabs' instead of 'Close current tab' ? Internet Explorer 8 now brings to you, what Firefox has had for a wh…
Bada platform is becoming more and more famous this days and people talking about same. Some friends included those who have bada OS mobile asked me "what is bada?"and "what its features?". That encouraged me to research and write this article. [st…
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now