Solved

PIX 506e VPN Server and Web Forwarding

Posted on 2004-04-16
4
555 Views
Last Modified: 2010-04-17
My company has been using a Cisco PIX 506e to provide VPN access between two internal networks for the last year or so.

I have just been requested by the bosses to open up the internal web server behind the pix so that it is accessable to the other internal network.

I checked up on my Cisco commands, and added a Static and changed my access-list's. The web server was now accessable, but the pix will no longer authenticate the VPN user.

The errors showing up in the cisco's debug log are:

106023: Deny tcp src outside:192.168.0.2/59573 dst inside:192.168.0.3/1723 by access-group "acl-out"
106011: Deny inbound (No xlate) tcp src outside:192.168.0.2/59573 dst outside:192.168.0.3/1723

My pix configuration is:

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ******** encrypted
passwd ******** encrypted
hostname internal-506e
domain-name internal-domain
no fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
fixup protocol http 80
no fixup protocol ils 389
no fixup protocol rsh 514
no fixup protocol rtsp 554
no fixup protocol sip 5060
no fixup protocol sip udp 5060
no fixup protocol skinny 2000
no fixup protocol smtp 25
no fixup protocol sqlnet 1521
names
access-list acl-in permit udp any any
access-list acl-in permit tcp any any
access-list acl-out permit tcp any host 192.168.0.3 eq www
access-list 101 permit ip 192.168.12.0 255.255.255.0 192.168.13.0 255.255.255.0
pager lines 24
logging on
logging buffered debugging
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside 192.168.0.3 255.255.255.0
ip address inside 192.168.12.3 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNPool 192.168.13.10-192.168.13.20
pdm location 192.168.12.2 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 192.168.12.0 255.255.255.0 0 0
static (inside,outside) 192.168.0.3 192.168.12.2 netmask 255.255.255.255 0 0
access-group acl-out in interface outside
access-group acl-in in interface inside
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group VPNGroup accept dialin pptp
vpdn group VPNGroup ppp authentication mschap
vpdn group VPNGroup ppp encryption mppe 40
vpdn group VPNGroup client configuration address local VPNPool
vpdn group VPNGroup client configuration dns 192.168.12.2
vpdn group VPNGroup pptp echo 60
vpdn group VPNGroup client authentication local
vpdn username VPNUser password ********
vpdn enable outside
terminal width 80

I've tried reboot's and different access-lists all without success.

Yours
Adam
0
Comment
Question by:BlindAdmin
  • 2
  • 2
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 130 total points
Comment Utility
You blew it when you made a static xlate using the outside IP

>ip address outside 192.168.0.3 255.255.255.0
>static (inside,outside) 192.168.0.3 192.168.12.2 netmask 255.255.255.255 0 0

Remove that static entry and try this to forward just port 80 to the inside host:
static (inside,outside) tcp 192.168.0.3 80 192.168.12.2 80 netmask 255.255.255.255


0
 

Author Comment

by:BlindAdmin
Comment Utility
Yup, thats worked, its an undocumented feature of the Pix's I presume.

Cheers
Adam
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
0
 

Author Comment

by:BlindAdmin
Comment Utility
Yeah, we've just found that as well...

I'm working of an old hard copy reference manual (6.1), which for some reason doesn't mention the ports.

Thanks for the solution, it all works without any problems.

Adam
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Access shared drive during VPN session 9 61
MPLS VRF bridging 4 46
Eigrp Router 5 44
Command "logging persistent size .... " 6 24
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now