Solved

Sonicwall soho series firewall reporting Malformed Packet on ports 137-139, UDP every 2 minutes

Posted on 2004-04-16
7
583 Views
Last Modified: 2013-12-05
Hello,

A sonicwall soho series firewall (about 5 years old.. unsure on the version/model/firmware numbers) reports and drops a "Malformed Packet" everytime Samba broadcasts a packet on UDP ports 137-139.  

The linux distribution is Red Hat Enterprise Linux ES 3.0.
The version of Samba is the latest offered from RHN.

Source IP - 192.168.1.8 (samba server) - Destination IP - 192.168.1.255 (broadcast)

I have seen on Linuxquestions.org that others have had this problem when combining Sonicwall and Samba.  However there were no solutions offered.  Furthermore, Sonicwall's whitepapers does not have any information regarding Samba/SMB.

What was tried so far:

1) I have allowed Netbios broadcasts via a checkbox in the Sonicwall configuration
2) I have created an Allow rule for any internal UDP packets on ports 137-139 originating from 192.168.1.8

My intuition says that this is not a problem with SMB but possibly a network configuration problem on the Samba server's eth0 interface - or, it is a Sonicwall mis-judgement of a SMB packet (possibly corrected in recent versions of it's firewall family).

I will post my ifconfig eth0 output as soon as I have remote access to the server.  

Let me know what extra information is needed.

Thanks in advance!

0
Comment
Question by:dhaurey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10843364
I dont have any experience with sonicwall. But is there not an option to turn off checks for malformed packets?
0
 

Author Comment

by:dhaurey
ID: 10844299
Unfortunately, owensleftfoot, I did not find such an option.  
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10846561
Like you I found a couple of references to the same problem on the net with no solutions. What version of samba does RHE 3 ship with? The latest version of samba appears to be 3-0-2a - upgrading to this version is worth a try.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:dhaurey
ID: 10846930
We currently have samba-3.0.2-6.3E.  This version was downloaded directly from Red Hat Network...  I wonder what other options we have..?
0
 
LVL 17

Accepted Solution

by:
owensleftfoot earned 125 total points
ID: 10850279
You said that sonicwall doesnt have an option for ignoring malformed packets. I was going to suggest that you allow all packets on ports 137 & 139 but I see from rereading your posts you have already tried this. The thing that gets me though is that if smoothwall is configured to allow packets to these ports, why is it examining them anyway? There may not be an option for ignoring malformed packets but are there options as to how "strict" the packet analysis is? Apart from that Im stumped. You didnt actually need help anyway - you have already tried all the things that anyone could have advised you on. It just appears to be one of those occasions where computers get the best of us :) New firewall perhaps? You could always turn an old 486 into a firewall using the excellent  http://www.smoothwall.org/
0
 

Author Comment

by:dhaurey
ID: 10851014
If it were entirely up to me - we would replace the sonicwall with a soho-series Pix (like the 506).  However, hardware procurement is out of my hands.  

It is so hard to believe that so few have used Sonicwall with Samba.  

This makes me think that we are missing something.

hmm..
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 10853043
As you said, your firewall is pretty old. Any duplication of your problem seems only to involve redhat from 9.0 on. People are either using it with an older version of redhat or are using a more up to date version of the firewall.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you sitting there reading this and wondering how to get started with Linux? It almost seems like picking the right Linux distribution is about like picking the right college or buying a new car if you read some of the article out there. Relax… l…
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question