Solved

Logon Failure: The target account name is incorrect.

Posted on 2004-04-16
22
75,437 Views
Last Modified: 2011-08-30
Hi,

When I try to access my server through network neighborhood or from run: \\server (1 of 2 domain controllers), I get this error: "Logon Failure: The target account name is incorrect."
When I access the server with the IP address it works fine.

Any help will be appreciated.

Johan
0
Comment
Question by:jananzi
22 Comments
 
LVL 3

Accepted Solution

by:
haresh-nyc earned 500 total points
ID: 10852253
hi,

the error you described is VERY common when NetBios is screwed up.

open a dos prompt, and type
nbtstat -n

do this on both machines (the server you're trying to access, and the machine you're doing this from)

if you don't see at least the machine name, and the netbios domain name,
you have netbios issues.

check to make sure your machine name does not have any space in it.
make sure there aren't two machines with the same name.
you could even consider changing the computer names to something else, and see what happens.

what happens when you
ping -a servername   ?

(servername) above is the computer name with no periods, and no domain name.
just the computername of the server.

haresh
0
 

Author Comment

by:jananzi
ID: 10853777
Hi Haresh,

Thanks for responding! The problem trying to access the Domain Controller via My network places is from many PC's not only one. I have changed the PC name of 1 of the client pc's, also removing it from the domain and put it back onto the domain but it did not resolve the problem.
I have also checked nbtstat -n and did not see any problem there. I can't change the domain controllers name because of obvious reasons. The problem is not with the client PC's I think but with the specific server. What is interesting though is that the server having the problem being accessed from the network also has exchange on it. The outlook clients connect fine, no problem, the interesting part is that outlook connects with the servername.
When I ping the servername it resolves the name to the correct IP.

Is it not DNS that is screwed..........I have checked it but it seems to be OK.

Regards

Johan
0
 

Expert Comment

by:jspianos
ID: 11471848
SNAP!
Our network is experiencing the same problem:
Exchange 2000 appears to be accessible too but not the shares (\\server\share).
Pinging the server - no probs.
Some users found restarting their PC did the job for them but this may be a co-incedence.
So far I've read it could be an Active Directory replicating issue, possibly something to do with passwords but I don't recall anything changing here.
What's going on?
I'm working on the issue and seeking support. If I get the solution I'll post it here...
If anyone else can help in the meantime?!

Paul
0
 

Expert Comment

by:bergm57
ID: 11532592
I have had the same problem and have been working with a couple of sharp guys under the Microsoft Networking section.  It seems to be related to DNS as AD is dependent upon it.  They gave me some good advice.  You may want to check there.
0
 
LVL 1

Expert Comment

by:jsarinana
ID: 11534734
I'm having the same problem, Exchange 2000 clients work fine, ping works fine but some users are having problems with a shared folder on the server. Bergm57, you wrote about DNS and AD and you have "You may want to check there" any feed back where to check would be appricaited
0
 

Expert Comment

by:amullee44
ID: 11568706
I am able to map a drive on some machines to a specific ip address and share, but no longer able to map or browse to a share via network neighborhood or the server name.  I have a mixed NT 2003 enviroment running AD.  If anyone has any suggestions it would be very helpful for many users are unable to access their folders due to the "Target account name is incorrect" error.  

Bergm57:  when you say to check "There", where in the MS networking section do I check for addtional help in this matter.
0
 
LVL 1

Expert Comment

by:jsarinana
ID: 11568894
In my case I had two things going on, a broken security channel that I broke when fixing an Exchange problem, I had to run the SMTPReinstall.exe command and reinstall Exchnage 2000 and then install service packs, after this my security channel was broken. When this server which is a Domain controller tried to replicate to my other Domain controller I ended up with a replication problems and that is when I started getting access denied problems. I did the following and now I'm ok: http://support.microsoft.com/?id=329721

Hope this helps
0
 

Expert Comment

by:johncharnock
ID: 12750193
Check that File and Printer Sharing are ticked on your Server network adapter properties

John
0
 

Expert Comment

by:anthonix
ID: 14464330
Check that computer account (here 'server') in AD isn't created at two places (in two domains).
0
 

Expert Comment

by:mjdavey61
ID: 14892464
Hi gang, I had the same problem when trying to access one domain controller from another.
I read all this great stuff......and then I just said, what the heck....Let's try a reboot!

Now it works like a charm.....

See, you to can become a network consultant like me!

See ya,

Thanks

Mike
0
 

Expert Comment

by:perk03z06
ID: 15116805
I have issues similar to this, but I just tried the following with strange results ...

Workstation systems cannot access resources on another workstation, so, on those workstations I tried ping -a ComputerName

The target system's IP is not being returned to the host systems, rather an IP of another system on the network.

How is that happening?
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 1

Expert Comment

by:sanjumc27
ID: 22865373
if you are able to access the target system  using ip address; and not able to access computer name ; problem is in your PC; Just Flush the dns cache and re register to DNS.
use the following command;

ipconfig /flushdns
ipconfig /registerdns

and still problem exist;
add the target system anme in host files.

it will work
0
 

Expert Comment

by:taverny
ID: 22998368
haresh,
I have the same issue than johan, and I opened a new post.
it might be the netbios that you mention for me
It's driving me crazy, maybe you can help me there:

this is what I get from the server when doing nbtstat -n:

Local Area Connection 2:
Node IpAddress: [192.168.0.5] Scope Id: []

                NetBIOS Local Name Table

       Name               Type         Status
    ---------------------------------------------
    OBT            <00>  UNIQUE      Registered
    OAKBROOK       <00>  GROUP       Registered
    OAKBROOK       <1C>  GROUP       Registered
    OBT            <20>  UNIQUE      Registered
    OAKBROOK       <1B>  UNIQUE      Registered
    OAKBROOK       <1E>  GROUP       Registered
    OAKBROOK       <1D>  UNIQUE      Registered
    ..__MSBROWSE__.<01>  GROUP       Registered


and I get this from the user:
Local Area Connection:
Node IpAddress: [192.168.0.4] Scope Id: []

                NetBIOS Local Name Table

       Name               Type         Status
    ---------------------------------------------
    SPAREOAK       <00>  UNIQUE      Registered
    OAKBROOK       <00>  GROUP       Registered
    SPAREOAK       <20>  UNIQUE      Registered
    OAKBROOK       <1E>  GROUP       Registered

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23918870.html#a22997218



0
 

Expert Comment

by:mhmfasy
ID: 23026891
Hello group, I am also facing the same problem "Logon Failure" i tried all the suggestions. but same problem, for the time i mapped the users with the IP address. But need to find out the real solution for this.
0
 

Expert Comment

by:mentisgroup
ID: 23390266
I found the same issues with an xp pro domain member client pc, when logging in from startup, it would work, but if i logged off then back in i would get the original error mapping say" net use g: \\servername\share . Logon Failure: The target account name is incorrect, is what i get when doing the logoff/logon. To get around this, i changed the login script to: net use g: \\servername.domain.lan\share and now it works. Not sure why, as it tried everything above and lots of other stuff. My login script is specified in the ad user account for login script parameter, where all that is specified is logon.cmd, which resides in \\dc\netlogon
0
 

Expert Comment

by:LQdev1
ID: 23793375
try using FQDN instead of just a "servername"
0
 

Expert Comment

by:DNSSupport
ID: 24853488
After struggling with this same issue for several hours I came across this MS KB article:

http://support.microsoft.com/kb/325850

I had the additional symptom that the DHCP server installed on that DC (which was working in the past), was now showing up as unauthorized. Any attempts to authorize it would fail.

Apparently the communication between domain controllers in 2 sites were having a problem.
The article describes using:

netdom resetpwd /s:{server} /ud:{domain\User}  /pd:*

This resets the intersite Kerberos password that apparently got out of sync on one of my DCs.

Be sure to stop the KDS service before using the above command. (described in the article)
You will need to reboot after running.

Seemed to solve all my issues.
0
 

Expert Comment

by:tgizel
ID: 25122679
if it only works with a FQDN, check your DNS settings under Advanced TCP/IP settings.  Make sure the correct DNS suffix is specified in Append these DNS suffixes in order.
0
 
LVL 1

Expert Comment

by:KCDean
ID: 25440127
Make sure to not have any of your server network cards set to operate under power management settings. Over the weekend when things would quiet down the cards would go into sleep mode and Monday morning the first 20 mins would be strange connection issues until everything replicated properly....  This seemed to have fixed my problem..
0
 
LVL 1

Expert Comment

by:KCDean
ID: 25672200
Just a slight correction my real problem was I had my proxy set to hand out 5 ips in a small range. I did this snapshot a server and forgot about that setting I had changed a while back.. problem resolved for me...
This message is very generic which can lead to so many issues in this case this was my problem..
0
 

Expert Comment

by:stadarnet
ID: 26293226
For me it was a site issue. 3 sites and one had two subnets which was confusing the system.. Deleted the extra subnet and everything worked fine.
0
 
LVL 4

Expert Comment

by:internetsavant
ID: 34197957
I saw this same error while trying to troubleshoot SCCM non-clients and my fix was checking DNS.  The hostnames that were appearing in my Collections (discovered via AD/Heartbeat, not network) were showing either old hostnames or valid hostnames with incorrect PTR records.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

A brief overview to explain gateways, default gateways and static routes OR NO - you CANNOT have two default gateways on the same server, PC or other Windows-based network device. In simple terms a gateway is formed when a computer such as a serv…
The Need In an Active Directory enviroment, the PDC emulator provide time synchronization for the domain. This is important since Active Directory uses Kerberos for authentication.  By default, if the time difference between systems is off by more …
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now