HrESEBackupSetup Backup Error with ExSrv 2003

I have been unable to get my newly set up W2K Server and ExSrv 2K3 to backup the Information Store using the Backup uitility. The report shows:

The 'Microsoft Information Store' returned 'Instance not found' from a call to 'HrESEBackupSetup()' additional data '-'The 'Microsoft Information Store' returned 'Functions called in an invalid sequence.' from a call to 'HrESEBackupClose()' additional data '-'
The operation was ended.

I found a MS article related to this, but it referred to when you back up the System Satte at the same time. I am not doing this. I have checked for other instances of ntbackup running but there are nne. I tried disabling the volume shadow copy service but no difference.

The backup WAS working for a while, then I noticed that my daily scheduled backups had stopped.

My the heck can't Microsoft supply products which work properly in such a critical respect?

Can anyone advise?
leemingdAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
David WilhoitConnect With a Mentor Senior Consultant, ExchangeCommented:
You cannot back up the RSG, I didn't realize you had added one....there's the issue. Have a good one, bro!

d
0
 
Exchange_AdminCommented:
Is your tape drive located on the Exchange server?

You say that the backups were working. Well what has changed? Any new software, drivers, hardware installed?
0
 
leemingdAuthor Commented:
No changes have been made. I am backing up onto a separate HDD at present, we haven't got our disk imager and mobile HDD yet.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
David WilhoitSenior Consultant, ExchangeCommented:
If the exchange files are on the system partition, and you're performing a system state backup along with the Exchange backup simultaneously, that's the problem. Do these 2 backups separately. the system state backup will freeze the Exchange config until the backup is complete, regardless of whether or not the system state portion of the backup job is completed.

D
0
 
David WilhoitSenior Consultant, ExchangeCommented:
Sorry, I should have read a little closer, you've already checked this part out.....my bad. So, all things considered, something changed...anything you can think of at all? If it was working before, it should still be working without issue, unless it was interfered with...

D
0
 
leemingdAuthor Commented:
Hi,

As you noticed, it is being backed up on another disk. I have done more tests, and it seems that it only objects when I include the Recovery storgae group. If I backup only the first information store, it works OK.

I have not done anything yet viz the recovery group, and the folders where the edb and stm databases are stored, are empty (Recovery group). The error above, only refers to the Recovery group. That must be it....

So If I only back up the First Information Store, that is enough to recover from a complete systems failure?

DL
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.