How do I enable 8bit mode linux desktop?.

I am working on linux 7.2, I am using gnome desktop.
I can login from original desktop to second desktop  by ctrl + alt F2 , allows me to login second desktop, however I would like to know how to open GUI desktop?. ordinary "startx" command does't help.
so can anyone help me how to enable 8bit desktop mode?.
thanks in advance
Who is Participating?
Karl Heinz KremerConnect With a Mentor Commented:
As I already mentioned, -depth is one of the options that X supports :-)

For startx you need to indicate that you are specifying server options:
xinit <client options> -- <server options> This means that the command should look like this:

xinit -- -depth 8 :1

(and, it's only one '-' for server options)
You can't start another X server and Gui display on an alternate console. The X server that is running the original, login, desktop takes over the video card.
Karl Heinz KremerCommented:
You _can_ start a second X server. I do this all the time: I have three X servers running right now on my Linux system. One is the local X session, one is is a remote session running on my Solaris machine, and the third is a remote session to another Linux box.

You may run into problems when you run two different X sessions connected to the same config files in your home directory, but other than that it would work just fine.

Run X --help to find out which parameters the command supports. If you want to run a completely different configuration, you should probably create a copy of the XF86Config file and use the -xf86config <file> parameter. You can also specify the bit depth with the -depth <n> parameter.

The trick to get more than one server running is to use the :1 (or :2, :3) display number. The default display is :0, which is on the 7th virtual console (Alt-Ctrl-7), with :1 you get a server running on the 8th console...

X gives you just the server, nothing else. You probably want your normal desktop. This is done with startx. You can pass a display number to startx as well
startx -- :1
(I cannot test this right now, but it should work).
Karl Heinz KremerCommented:
BTW: If you do have a remote machine that runs xdm with remote logins enables, you can do this:

X -query <remote server> :1

This will convert your Linux box into a X terminal.
X --depth 8
runs x at depth 8
X --depth 8 :1
as described above.

startx --depth 8 should also work.
I have several times used several X desktops on a local machine because one desktop needs to be 8bit for some application.  Then I use ctrl-alt-f7/f8 to switch between the two.  I also have to start the display manager by hand

export display=:1
startkde (if that doesn't run X itself)
xterm //as a backup

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.